6,225 reputation
22231
bio website
location McKinney, TX
age
visits member for 4 years
seen 19 hours ago

Aug
25
revised How can I paste (overwriting) with vim?
fix typo, per comment
Aug
23
awarded  Yearling
Jul
31
awarded  Guru
Jul
16
reviewed Approve suggested edit on Special File that causes I/O error
Jun
17
answered Make tmux block until program completes
Jun
17
awarded  Constituent
Jun
10
awarded  Caucus
Jun
5
reviewed Reject suggested edit on join : “File 2 not in sorted order”
May
22
awarded  Good Answer
May
20
answered Use system clipboard in vi-copy mode in tmux
May
13
comment Is there an equivalent of GNU Screen's “log” command in tmux?
@sebelk: If you consider an individual line to be an “entry” then you could use a shell’s read and date to arrange that. E.g. bind-key H pipe-pane -o 'exec bash -c "while IFS= read -r line; do echo \"\$(date +%%Y%%m%%dT%%H%%M%%SZ%%z): \$line\"; done" >>$HOME/"#W-tmux.log"'
Apr
29
awarded  Nice Answer
Apr
21
answered Get TMux scroll buffer contents
Apr
2
answered Why does `tmux` copy operation always output temporary gibberish to the terminal?
Mar
29
awarded  Good Answer
Mar
27
awarded  Populist
Mar
22
comment Tmux monitor activity change highlight color
Maybe the white text you are seeing is iTerm’s foreground color; i.e. tmux’s default, not white/colour7. window-status-format is used for all inactive windows (an alerted window is necessarily inactive), so it makes sense that it would override the window-status-activity-… settings. It works like this (for an inactive window with an activity alert): first window-status-{fg,bg,attr} are applied, then (window-status-activity-{fg,bg,attr} are applied, then the string generated from window-status-format is output. The items that come later can always override the earlier items.
Mar
22
comment Tmux monitor activity change highlight color
screen-256color is appropriate for inside tmux, but you should also make sure that you are using xterm-256color outside tmux (i.e. when attaching to or creating a session). Are you sure your iTerm color configuration has not been altered (⌘I, then the Colors tab)? A command like bash -c 'for c in {0..15}; do tput setaf $c; echo colour$c; tput op; done' (out/inside tmux, with xterm-256color/screen-256color) should show you this series of colors: black, red, green, yellow, blue, magenta, cyan, and white (then the “bright” versions of these colors; solarized changes all this).
Mar
22
comment Tmux monitor activity change highlight color
@Ionthas: It works for me with my old copy of tmux 1.6 (and my recent master-branch compiled version) under iTerm 2. It might have something to do with the terminal emulator you are using outside of tmux, or possibly the terminfo entry you are telling tmux to use to talk to that emulator. What is your outside terminal emulator, and what TERM are you using when attaching to tmux?
Mar
22
answered Tmux monitor activity change highlight color