944 reputation
620
bio website
location
age
visits member for 3 years, 3 months
seen Dec 6 at 23:48

Jan
8
awarded  Popular Question
Oct
23
awarded  Popular Question
Oct
3
awarded  Popular Question
Sep
10
awarded  Yearling
Sep
6
comment “globbing” (*) comes from “global command”… Huh?
well, that too, but I was just alluding to the sheer opacity of the name grep. Hmmmm, "sheer opacity": there's an oxymoron for you!
Sep
6
accepted “globbing” (*) comes from “global command”… Huh?
Sep
6
comment “globbing” (*) comes from “global command”… Huh?
Regular expressions seem to be a rich source of Unix conundrums, including the one that has probably scared away, or at least mystified, the most people: grep...
Sep
6
awarded  Organizer
Sep
6
revised How to keep a line from being remembered in the history?
changed [history] tag to [command-history]
Sep
6
suggested approved edit on How to keep a line from being remembered in the history?
Sep
6
asked “globbing” (*) comes from “global command”… Huh?
Aug
26
revised Corrupted gnu-screen session not displaying UTF-8 correctly
added 157 characters in body
Aug
26
comment Corrupted gnu-screen session not displaying UTF-8 correctly
@n.m.: sorry, that crucial chunk of information got lost in a cut-and-paste shuffle; I've now fixed the error (see UPDATE)
Aug
26
revised Corrupted gnu-screen session not displaying UTF-8 correctly
added 157 characters in body
Aug
26
revised Corrupted gnu-screen session not displaying UTF-8 correctly
added 1190 characters in body
Aug
26
comment Corrupted gnu-screen session not displaying UTF-8 correctly
...In any case, I will set my locale for future sessions, but is there any way to fix the current "corrupted" gnu-screen session?
Aug
26
comment Corrupted gnu-screen session not displaying UTF-8 correctly
@DravSloan (and @StephaneChazelas) in my current configuration for OS X I'm not setting any locale-related variable. I'm not sure why this is, since my configurations for Linux do set LANG and LC_ALL to en_US.utf8. I do remember having spent a few crazy hours some time ago trying to figure out how to set the locale for OS X Lion, and finding copious amounts of contradictory information... My current OS X configuration, despite not setting the locale, does work normally (i.e. fresh gnu-screen sessions work fine)...
Aug
26
revised Corrupted gnu-screen session not displaying UTF-8 correctly
added 389 characters in body; edited tags
Aug
26
asked Corrupted gnu-screen session not displaying UTF-8 correctly
Aug
22
accepted strange “bad file descriptor” error