Tag Info

Hot answers tagged

3

OSX does not have the same version of utilities as Linux. The common denominator you can count on is POSIX, which defines cal but none of its options. There are two common versions of cal on Linux: the one from util-linux (e.g. on Fedora) and the one from FreeBSD (e.g. on Ubuntu). Both have the -3 option. OSX is based on FreeBSD, but its version is an older ...


3

The ~/.inputrc file is a bash thing, not a zsh thing as far as I know. It controls the behavior of readline, the zsh equivalent of which is zle. You can modify its behavior using the bindkey command. So, to get Ctrl Left and Right back, add these lines to your ~/.zshrc (there might be a better place for them, an equivalent to ~/.inputrc but I don't know it ...


3

It is good you tagged the question with zsh, since in that shell you can use extensive glob qualifiers including test done on file names: $ ls -1 AAAA* AAAA_2012-10-03_BBBB AAAA_2014-12-28_BBBB AAAA_2015-01-03_BBBB AAAA_2015-02-03_BBBB AAAA_2015-10-03_BBBB $ d1='2014-12-15' $ d2='2015-02-03' $ print -l *(e:'[[ "${${REPLY#*_}%_*}" > "$d1" && ...


3

nohup is ineffective against watch because watch installs a signal handler for SIGHUP which overrides the one installed by nohup. nohup works by setting the signal handler for SIGHUP to SIG_IGN which causes the signal to be ignored, and then it runs the program it was asked to run. This works well with target programs that leave the signals configured the ...


2

Enabling the option MENU_COMPLETE will skip the correction and immediately insert the first possible match.


2

If your variable is exported (bash: by the export command or by default because of set -a) then a called shell gets it in its environment like any other process would.


2

the right command was $ stty iuclc after I checked the settings with $ stty -a the real problem maker was the program Textexpander. I figured that out when I had the issue in my regular terminal shell and the option iuclc was not available.


1

This looks like normal default zsh behavior. Whether combining characters are displayed combined during autocompletion is controlled by the combining_chars shell option. To have it complete to cão, put this in your ~/.zshrc file. setopt combining_chars I can't reproduce your behavior where this is the default for non-login (zsh vs -zsh) shells. In the ...



Only top voted, non community-wiki answers of a minimum length are eligible