Tag Info

New answers tagged

0

You could try rebuilding the rpmdb rpmdb --rebuilddb This fixed a similar problem for me.


0

Because they are arch dependent. Either rebuild the .src.rpm on the arch. you care about (the one in the source repos. is built on a random supported arch), or download and unpuck the .src.rpm and yum-buildep on the kernel.spec.


0

You should do ldd /lib64/libldap-2.4.so.2, check output for 'undefined references', find package which provides that undefined lib, find your repo, manually download the rpm which provides that lib, install it with rpm -i <missing>.rpm. Most probably your problem is due to bug in libldap or your manual intervention into packaging system. I happen to ...


1

In your script use rpm -q packagename: if rpm -q vim-enhanced then ... else ... fi


2

You can try: #yum list installed | grep tmux tmux.x86_64 1.9a-5.fc21 @updates or: #yum list installed tmux Loaded plugins: langpacks Installed Packages tmux.x86_64 1.9a-5.fc21 @updates ...


0

You accidentally typed reposync and hit Enter? Look before you leap... I don't understand exactly what that means (which yum repositories?) The software you install via yum etc. comes from online repositories. You can find some information about them (such as the URLs) in /etc/yum.repos.d, although it is not very interesting. You should not need to ...


2

The second error (from the comments): database malformed error should be corrected by yum history new sudo yum clean all sudo yum history new I would just remove the entire cache directory ( /var/cache/yum/i386 ) for the first error since yum clean isn't removing the directory causing the error. Yum will redownload what it needs.


1

yum search also looks at installed packages, use "yum search -v" to get the extra information (like where it was found). My guess is that you have these installed, but not available, you can easily check this with "yum list extras" (or better "yum list distro-extras", but I don't think that's in el6).


0

Hi to resolve similar issue it helped me to install .x64 version first. It seems like yum is complaining about different version of .x64 package installed and .i686 you want to install. So sudo yum install gtk2.x86_64 sudo yum install gtk2.i686 worked for me


0

Thank you for your help, I find a solution, I've download on rpmfind.net and install the missing dependencies one by one but for Fedora 20 64 bits (dependencies for Fedora 19 64 bits is uncomplete), it works perfectly.


0

The issue is missing dependencies. Maybe CentOS 7 is still new and does not have all packages built for it yet. It looks like you may be able to use fedora 19 packages instead. That is, download the packages you need from a fedora19 yum repo and then install them. It looks like you could follow this tutorial: ...


1

This yum plugin adds the "--merge-conf" command line option. With this option, Yum will ask you what to do with config files which have changed on updating a package. https://apps.fedoraproject.org/packages/yum-plugin-merge-conf


0

The error message Couldn't resolve host 'mirrorlist.centos.org' points to an issue with name resolution. Try the command host mirrorlist.centos.org: if it fails, then that is the first problem to solve (check your DNS settings, and whether the machine is able to connect to the internet at all).


0

"Error Type: Error Value: File contains no section headers." I got this error that pops up regurarly. I am really new to centos and am using it for schools work. I must have tried to change something in the yum file to follow some directives from our website but must have provoked some error. Also, when i try some yum commands as this one, i get this ...


0

In Fedora, the orphan package means no candidate repos for it to update! If the orphan packages were generated by you disable yum.repos.d/some.conf. yum distro-sync Other orphan packages, the command may be dangerous. yum remove $(package-cleanup --orphans) or, just use the safety command. yum remove name-of-page


0

Thanks for providing a good answer. However, I find that this way is simpler and doesn't require yum-utils: sudo yum --disablerepo=\* --enablerepo=my-cool-repo install \* That being said, yum-utils is useful for other things.


0

Grepping yum's output is the most obvious way: yum list installed | grep @epel However, you can't display extra packages properties and it's difficult to parse with a script. The tool repoquery from the package yum-utils is the tool, but it isn't installed by default. repoquery -a --installed --qf "%{ui_from_repo} %{name}" | grep '^@epel' and a more ...


0

Instead of yum, use repoquery from package yum-utils. repoquery --disablerepo=* --enablerepo=my-cool-repo -a | xargs sudo yum -y install


1

You could use the repoquery command, for example. repoquery -i nmap


1

Messing with the RPM database didn't yield any particularly good results. I ended up noticing that some of the glibc packages were i686 and others were x86_64. For instance: Package: glibc-2.12-1.149.el6.i686 (CentOS-OS) Requires: glibc-common = 2.12-1.149.el6 Installed: glibc-common-2.12-1.149.el6_6.5.x86_64 I didn't like that, and I expect that ...


0

I was able to resolve a similar issue by downloading the rpms manually to the system (note, you will need to have all the dependent rpm's) saving them to a folder and running: yum localupdate /folderlocation/*.rpm My issue revolved around yum finding inconsistencies when getting the RPM's from the repo's I was pointing to. The symptoms though presented ...


1

The RPM DB is confused. My recommendation, having encountered this before, it to rpm -e --justdb the newer "duplicate" package installed, then yum upgrade the package, then rpm --rebuilddb just because I'm a bit of a paranoiac. Once you've gone through the first two steps, you should be able to install the newer packages, assuming your repo is properly in ...


2

So, I looked at your package list, and only two, vnc-server and xterm are actually yum packages (e.g. RPMs). The rest are libraries, and (unfortunately) you cannot install files and libraries by listing them out like that (would be nice, though). However, there is an easy yum command you will have to run on each file/library, and you may find many are ...


1

This is not due to hyphens in the package name - what you're trying to do is exactly how it's supposed to work. Yum is having problems either because of the colon in the version you're specifying, or because the version you're specifying isn't available in any of the repositories you have configured on the system. Do you see that specific version of OpenJDK ...



Top 50 recent answers are included