New answers tagged

2

You're referring to xorg/lib/libXt/Resource.c #define MAXRESOURCES 400 used later in the same file: } else if (num_resources >= MAXRESOURCES) { XtAppWarningMsg(XtWidgetToApplicationContext(widget), "invalidResourceCount","getResources",XtCXtToolkitError, "too many resources", (String *)NULL, (Cardinal *)NULL); return NULL; ...


0

The most common cause of touchpad issues on Arch Linux, including the one you are describing, is not installing the Synaptics touchpad driver. The package is called xf86-input-synaptics Go ahead and run pacman -Syu xf86-input-synaptics and then restart X, and your touchpad should start behaving normally.


0

Xterm provides a way to do select/paste using the keyboard, but (a) it is not often used and (b) requires a little work to configure it. Refer to Default Key Bindings in the manual, to see that there are predefined bindings including these: Shift <KeyPress> Select:select-cursor-start() \ ...


1

I worked around my own solution from various posts around. This creates a title containing user, hostname, pwd, tty and currently executed command (for bash). This looks like this (no command being executed): .:[user@hostname:/home/user][pts/10]:. And like this (executing a command): .:[user@hostname:/home/user][pts/10] {tail -F /var/log/syslog}:. ...


1

I finally figured out what's wrong just a couple of days ago after scrounging through multiple sources. Combining everyone's responses here: Ubuntu Mono is a TrueType font and TrueType fonts require xterm to be compiled with FreeType library support. To check whether xterm has this, use the ldd /path/to/xterm/binary command and see if it says freetype in ...


2

This question was first posted to stack overflow, where I answered it a year ago, noting that the actual package did not provide the style RegularForPowerline (apparently OP was confused with some aspect of the output of fc-list: fc-list shows me Regular where you have RegularForPowerline.


4

short: xterm uses a single font (except for the special cases of double-width characters), while the other terminals use additional fonts (and they use those fonts for the characters not found in your requested font). long: the character you are interested in is not part of the font, which appears to be something like fonts-hack-tty in Debian. The missing ...


2

It is an old one, but for anyone coming here, the solution is: XTerm*faceName: Ubuntu Mono:style=Regular and if you want to see the change immediately then run: xrdb -merge .Xresources xterm


2

Michael Horner's answer is close, but overlooks a detail: XTerm.VT100.translations: #override \ Shift <Key>Up: scroll-back(1) \n\ Shift <Key>Down: scroll-forw(1) uses the default units for scrolling. To ensure that you get lines, you need to add a parameter: XTerm.VT100.translations: #override \ Shift <Key>Up: ...


1

As Thomas Dickey explains, xterm has no built-in way to input characters by codepoint. (Presumably because that's pretty bad UX.) Vim does, though: in insert mode, press Ctrl+V then u then 4 hex digits (or Ctrl+V then U then 8 hex digits). For a more convenient way to input characters, use Compose, digraphs (which are Vim's built-in compose facility), or an ...


4

xterm doesn't implement a hexadecimal-input feature because all of the text editors which handle UTF-8 provide their own equivalents (emacs, vim and vile, of course, even nano). This could be useful in a shell script, but is not often mentioned. The feature was first implemented in Windows, of course. To enter multibyte (e.g., UTF-8) characters in xterm, ...



Top 50 recent answers are included