Tag Info

New answers tagged

1

The tool you are looking for is 'xrandr'. Running xrandr without parameters gives you the list of known outputs, attached devices, available resolutions (including preferred ones and used ones). For example, to deactivate an output, run xrandr --output NAME-OF-OUTPUT --off To set an output to on and its preferred resolution, run xrandr --output ...


1

Preliminary note: it appears that xmodmap has recently changed; old settings won't work. For your case, look at the number of values for keycode 53 (6 values: x X x X multiply approximate), which works, and for keycode 32 (4 values: o O odiaeresis Odiaeresis), which doesn't work. ISO_Level3_Shift will select the 5th or 6th value, but they are not set for ...


0

I threw caution to the wind and spent £26 on a Geforce GT610. The driver recognises it and it can drive a 3rd monitor. Best results, to my eyes, came after using nvidia-settings to configure each screen (including the two driven by the same GPU) as its own X display, then ticking the Xinerama box. One general problem I've had after doing this: Xinerama ...


0

In theory, a program that loses its connection to the X server could just try reconnecting until a new X server is available. In fact, I've written programs that do this. It requires extra code, because you have to re-run your GUI-initialization routine to re-create your resources (windows, bitmaps, fonts, etc) on the new X server, and refresh all your ...


0

x0vncserver (in Debian and Ubuntu in the package vnc4server) may help to regain access to crashed or at least no more accessible X session, e.g. with x0vncserver display=:0. And then there is xpra which allows the user to view remote X applications on their local machine, and disconnect and reconnect from the remote machine without losing the state of the ...


0

In current Ubuntu releases, at least since 14.10, the keyboard-configuration package has an option to re-enable Zap: $ sudo dpkg-reconfigure keyboard-configuration


0

Try the following: Grant another user on the local machine access to our X server. It’s pretty easy: $ xhost +SI:localuser:anotheruser localuser:anotheruser being added to access control list Then your user must show up when you: $ xhost Reference


3

Why is it called eDP1? Because it is an embedded display port style adapter, and not a video graphics array style one.


0

As an alternative you can try: xdotool type --clearmodifiers -delay 0 "string to type at fake input" I found it works a lot better than xte version 1.02 which seemed to have a 255 character limit. Or xte version 1.0.7 which seemed to ignore all newlines in the string.


0

I have the same issue and SSH with -X or -Y gives same result. Here is the reason and "answer" in form of a workaround. The reason is that the menu background aka "the black bar" is rendered on top of the gnome panel instead of behind it. I have created this bug report at xquartz, and hopefully they will solve it. ...


0

Have you tried disabling the "firstboot" service? chkconfig firstboot off (assuming RHEL6) should disable it. You can also add firstboot --disable to your kickstart to disable it during kickstart.


1

I had the same problem. Very hard sometimes with the nVidia cards to get the resolution right by futzing directly with xorg so I like to use arandr for this kind of thing. (This is one of the few times that I find the GUI stuff better then the command line approach.) pkg_info tells us about arandr: # pkg_info -d arandr Information for ...


0

Try adding setxkbmap pl to your starting scripts (e.g .bashrc)


0

I've set my keyboard layout by editing /usr/share/X11/xorg.conf.d/10-keyboard.conf. If it doesn't exist go ahead and create it. Put this inside: Section "InputClass" Identifier "system-keyboard" MatchIsKeyboard "on" Option "XkbLayout" "pl" EndSection Save and restart X. For more information see the section titled Using X configuration files ...


1

Fedora doesn't use an xorg.conf by default as this allows the X server to probe for its configuration. It assumes that the X server knows best. However, if you add an xorg.conf it will simply override the probed values. A minimal example might be: Section "Screen" Identifier "Default" Monitor "Monitor1" Device "Device1" EndSection Section ...


0

If you must have it automatically detect the display when it is plugged in, it seems that the cleanest solution is to add a UDEV rule to run a script containing your xrandr commands. Here is an example from one user's solution1: Monitor (output) UDEV events with udevadm This step will be most important for each user. Run udevadm monitor --environment ...


2

xrandr1 may be the solution you are looking for so that you don't need to log out/log in. From How to use xrandr: The old days where you had to restart X when plugging a new monitor are gone. With RandR 1.2, you can plug/unplug monitors whenever you want. Running the following line will query all outputs and enable them with their default mode: ...


0

if your local machine is running windows(7+) you can just use this from the CommandLine: ssh user@server cat /home/user/file | clip


-2

There is a workaround to this problem: Open the "Keyboard preferences" dialog, the "Layouts" tab Use "Add" button to add another keyboard layout, any layout will do, the first one is Afganistan, it works too On the "Choose a Layout" dialog use the "Add" button to add selected layout and close the dialog You are back on the "Keyboard preferences" dialog, ...



Top 50 recent answers are included