Hot answers tagged

7

Finally, I've found out a solution, just an other line (previous not needed: wpa-ap-scan) wpa-scan-ssid 1 I've not really found it in any documentation... just in a forum post.


7

How about iwgetid? The iwgetid(8) man page says: iwgetid is used to find out the NWID, ESSID or AP/Cell Address of the wireless network that is currently used.


6

The errors wpa_supplicant produces are not necessarily related to your wpa_cli connection problem. The trouble here is that wpa_cli is unable to establish connection with wpa_supplicant - unable to open the control socket. This can have several causes: user running wpa_cli is unable to access the socket given e.g. in wpa_supplicant.conf: ...


5

You are confusing kernel drivers and user-space drivers. In your case, you may certainly use WEXT, but also nl80211 (I think). WEXT (or WE= Wireless Extensions) are the modification introduced to the Linux kernel in 1997 by Jean Tourrhiles. According to this Web page written by Tourrhiles himself, The Wireless Extension (WE) is a generic API allowing ...


5

wpa_passphrase [ ssid ] [ passphrase ] generates a WPA PSK from an ASCII passphrase for a SSID. Then store it as network={ ssid="your ssid" psk=outputfromabove }


5

Take a look at the output from this command to confirm what drivers/modules the kernel is using for your given hardware. $ lshw -C network ... *-network description: Wireless interface product: Centrino Wireless-N 1000 [Condor Peak] vendor: Intel Corporation physical id: 0 bus info: pci@0000:03:00.0 logical name: ...


4

Preferred DHCP addresses are usually configured on the DHCP server side. You will need to add an entry in your DHCP server's address table for your device's MAC address and assign it to an IP address. DHCP servers can vary. If this is a small network your DHCP server may be your router or gateway. The address can fall in the range of DHCP addresses but it ...


4

wpa_supplicant does have support for ndiswrapper and should be run like this: wpa_supplicant -i wlan0 -D wext Instructions how to install ndiswrapper drivers - however I never use ndiswrapper. If it does not help you have to say what is the output of: wpa_supplicant -i wlan0 -D wext As a side note - to use WPA you need user program called wpa ...


4

Unfortunately I have to answer the question myself now. "Unfortunately" because the answer is "No, it is not possible". I took a look at how PAP is working, and came to the conclusion that it is logically impossible to store the password as a hash value. With PAP, the username and password are sent directly to the authentification side. Therefore, the ...


4

You can check what the access point is broadcasting in its beacons by doing this (you'll need the wireless-tools package): $ sudo iwlist wlan0 scanning The output varies by device, and will display every SSID the interface can see. My WPA2 access point gives this (from iwlist's very verbose output): IE: IEEE 802.11i/WPA2 Version 1 Group Cipher : ...


4

Did you setup your passphrase with wpa_passphrase? e.g %> wpa_passphrase SSID passphrase network={ ssid="SSID" #psk="passphrase" psk=28964ba6ea8b8f3a0db1c4414b327da253d0af5d4f4adccec0f8abf5b05b10f8 } Otherwise wpa_supplicant -B -i [wireless device] -c /etc/wpa_supplicant/cli.conf won't work at all


3

I have the same problem. /etc/network/interfaces Manpage says for dhcp method: hwaddress class address Hardware Address. class is one of ether, ax25, ARCnet or netrom. address is dependent on this choice. then maybe the problem is the class option. I'll try it. Other option is not supported by firmware.


3

Finally, the written errors didn't affect the system. My /etc/network/interfaces file looks like (only wlan part) : iface wlan0 inet static address 192.168.2.1 netmask 255.255.255.0 pre-up wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -B With this config, I can use the sudo wpa_cli command without error ! Thanks to ...


3

Probably what is happening here is that some other process owns the wireless chip inside your computer, so NetworkManager isn't allowed to do anything. In this case, that process would be wpa_supplicant or whatever is calling wpa_supplicant (and acting on the information in /etc/network/interfaces). Instead of randomly installing things, you should stop and ...


3

You can set the option disabled=1 in the corresponding network entry in wpa_supplicant.conf. This will prevent wpa_supplicant from automatically connecting to the network (it'll still try to connect to it if you specifically ask it to do so).


3

The key to solving problems such as this is knowing how to ask the question. I searched Google looking for "how to access panera bread wifi" and turned up this gem. Auto login to open Wifi This article had several scripts that could be used to facilitate the auto logging in. I've opted to include the example for Panera Bread which leverages Python's ...


3

Braiam suggested in the comments that if wpa_supplicant@wlan0 doesn't exist, I may need to create it myself, and also pointed me to a page in the Arch Linux wiki describing how to do so. I had to tweak things slightly for Fedora, but the following worked for me: Create a systemd unit, /etc/systemd/system/network-wireless@.service: [Unit] ...


3

Quoting the ArchLinux wiki: Note: Because of the process substitution, you cannot run this command with sudo - you will need a root shell. You should be able to use su -c under sudo like so: $ sudo su -c 'wpa_supplicant -D nl80211,wext -i wlp4s0 -c \ <(wpa_passphrase "some ssid" "password")'


3

Process substitution <(…) creates a pipe, uses /dev/fd to give a path that's equivalent to the file descriptor where the pipe is, and passes the file name as an argument to the program. Here the program is sudo, and it passes that argument (which is just a string, as far as it's concerned) to wpa_supplicant, which treats it as a file name. The problem is ...


2

Create a new file /etc/modprobe.d/rt2800usb.conf with the following line : options rt2800usb nohwcrypt=1 Reboot Or blacklist the defaut drivers and use the nl80211driver to connect through wpa_supplicant: nano /etc/modprobe.d/blacklist.conf add the following lines: blacklist rt2800usb blacklist rt2x00lib blacklist rt2x00usb Connect through the ...


2

It APPEARS that the ar6k driver has flaws. I'm surprised about this being an Atheros product. Check out the hardware notes/forums for your particular system regarding this driver. The shell command and .conf file didn't appear to have any errors. Can you connect to a non-encrypted network?


2

This is a known bug, check this launchpad bug report. There is only one suggestion offered to fix it, message n.24: Oops this has been going on since 2009 and a developer did respond that it is simply for roaming in corporate environments with multiple access points to connect to. If you only have one AP at home go into network manager, select "Edit ...


2

If you want wpa-supplicant to run using that config upon boot, then you should put the command in rc.local. As root, open up /etc/rc.local in a text editor and paste in your command: wpa_supplicant -i eth0 -D wired -c /etc/wpa_supplicant/mywired.conf -B Make sure that Systemd is running rc.local: sudo systemctl enable rc-local and reboot. Should work. ...


2

This following steps resolved the problem. Run once (restarts the machine): echo "options iwlwifi 11n_disable=1" > /etc/modprobe.d/iwlwifi.conf /usr/sbin/update-initramfs -u reboot Then the following script must be re-run every time restoring from hibernation or booting the system. /bin/systemctl stop network-manager /sbin/modprobe -r iwldvm iwlwifi ...


2

Just Download a Live-Distro of your choice (with wpa_supplicant) with the same arch (32/64 bit) you'll choose for gentoo later, too Create a bootable USB-Stick from it Boot from the USB-Stick Most of the upcomping steps require root privileges, so you could do a su in your Live-Distro and go on as root. Create your partitions (/boot,/home/,/) e.g. with ...


2

The cheap Realtek wifi firmware, linux kernel drivers and the hardware itself are terribly buggy. People in the ARM community have been working around the clock to try to mitigate some of the problems, back porting old versions of realtek kernel modules and old versions of hostapd, and often old versions of firmware too. One of the drivers backported for ...


2

You can generate the NtPasswordHash (aka NTLM password hash) yourself as follows: echo -n plaintext_password_here | iconv -t utf16le | openssl md4 Prefix it with "hash:" in the wpa_supplicant.conf file, i.e. password=hash:6602f435f01b9173889a8d3b9bdcfd0b


2

Since you have the wireless tools and wpa supplicant installed, you have all you need. But for WEP you don't need the wpa supplicant. Configure your network via /etc/network/interfaces: auto wlan1 iface wlan1 inet dhcp wireless-key <key> wireless-essid <ESSID>


2

I've not found official documentation about the /etc/network/interfaces config. You can find the documentation at /usr/share/doc/wpasupplicant/README.Debian.gz. Under Chapter 4: Troubleshooting there's a section titled Hidden ssids: In order to be able to associate to hidden ssids, please try to set the option 'ap_scan=1' in the global section, and ...


2

As last quote says, you have "dhcp", when you should have "manual" for wlan0. Try changing iface wlan0 inet dhcp to iface wlan0 inet manual in /etc/network/interfaces. Another choice is to use manager for network connections, for example Gnome's Network Manager or WICD.



Only top voted, non community-wiki answers of a minimum length are eligible