Tag Info

Hot answers tagged

12

The package you are looking for is called wpa_supplicant, it handles logging into protected wireless networks. If you use it from Ubuntu (or other debian based distributions) it's fairly easy to set up and the process is rather simple (check the debian wiki for a few pointers). I don't know much about arch linux but it shouldn't differ too much. If you ...


9

iwconfig (and its wireless extension API) is deprecated (it's in "maintenance only mode" and "no new features will be added"). Use iw instead. This requires a moderately recent kernel (e.g. >= 3.0) with support for nl80211. using iw dev wlan0 scan, you can figure out the protocol used: If there are Supported rates below 11mbps (except 6), there is ...


8

It's not just you. See here: http://www.dd-wrt.com/wiki/index.php/Wireless_Bridge#Limitations Basically, the spec for WiFi says that any wireless adapter can only have one MAC address, which makes bridging WiFi an impracticality. There are several bugs in several forms describing slightly different symptoms filed against VirtualBox (735, 2975, 5503, etc.) ...


8

Under Linux, you can use the iw* series of commands to configure and display information about wireless networks: iwconfig - configure a wireless network interface iwlist - Get more detailed wireless information from a wireless interface iwpriv - configure optionals (private) parameters of a wireless network interface iw - show / manipulate wireless ...


6

You should be able to use the user-mode networking stack. Start qemu like this: qemu-system-x86_64 \ -smp 1 -m 1024 \ -net user,net=10.0.0.0/8,host=10.0.0.1,hostfwd=tcp:127.0.0.1:2222-10.0.0.2:22 \ -net nic \ -cdrom systemrescuecd-x86-2.0.1.iso -boot d The important options: -net nic: Show a virtual network card for the guest -net user: ...


6

I'm guessing the real problem is that you don't know what a SSID is. It's the technical term for the network's name, i.e. the thing that shows up in a listing of available networks. If you don't know what network you're supposed to connect to, you'll have to ask somebody at your location. As the Arch wiki explains, you can get a list of available networks ...


5

For posterity sake, the best way to create an AP is using the hostapd program, which is available here and prepackaged in many distros. In Debian or derivatives, the packages comes with a file /usr/share/doc/hostapd/examples/hostapd.conf.gz, which is an example configuration. You need to copy the file to a different directory (your $HOME, for example), ...


5

Udev is the system component that determines the names of devices under Linux — mostly file names under /dev, but also the names of network interfaces. Versions of udev from 099 to 196 come with rules to record the names of network interfaces and always use the same number for the same device. These rules are disabled by default starting from udev 174, but ...


4

$ readlink /sys/class/net/wlan0/device/driver ../../../../bus/pci/drivers/ath5k In other words, the /sys hierarchy for the device (/sys/class/net/$interface/device) contains a symbolic link to the /sys hierarchy for the driver. There you'll also find a symbolic link to the /sys hierarchy for the module, if applicable. This applies to most devices, not just ...


4

Maybe there's a better way, but I've used lshw -class network (as root) and it gives me this output: *-network description: Ethernet interface product: 82566MM Gigabit Network Connection vendor: Intel Corporation physical id: 19 bus info: pci@0000:00:19.0 logical name: eth0 version: 03 ...


4

Google results show quite a few people successfully using that stick. There seems to be a driver in the kernel that recognizes it but results are hit and miss, possibly due to v1 vs v2 of that product. Since most of these are from last year, I suspect it just works now. Some people say that ralink's drivers work better. They have a stick that uses the same ...


4

You need to install kernel headers to compile a module. The kernel headers are not part of the kernel source (or at least not all of them are), they are generated when the kernel is compiled, and some of these headers depend on compilation options. There is an unofficial kernel header package. If you prefer to do things yourself, compile your own kernel. ...


4

You could (or do?) probably use wpa_supplicant; using its ctrl_interface configuration key, you can allow non-root users (e.g. those with group wheel) access via wpa_cli (i.e. /sbin/wpa_cli scan_results [1]) # allow frontend (e.g., wpa_cli) to be used by all users in 'wheel' group ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel There's also a ...


4

Create a hostname file in /etc with the interface's name. /etc/hostname.iwn0 Add to it: dhcp nwid "Name of network" wpakey password Restart the interface. sudo sh /etc/netstart iwn0 This way connection to the wireless network will be attempted on boot. If you don't know the name of the wireless interface run, ifconfig and look for 802.11 in ...


4

One method for configuring multiple NIC cards is through the use of what's called bonding. It goes by other names as well: Bonding Channel Bonding Link Aggregation Using NetworkManager What version of NetworkManager are you using? Version 0.9.8 is the first that purports to offer support for network bonding. excerpt from phoronix.com Add a ...


3

I have the same network hardware in my laptop running Ubuntu 10.10 Maverick. For the wireless adapter, you need the binary Broadcom STA proprietary drivers. Ubuntu should prompt you to install them when you first start, but if you're lacking a network connection, that might be why it's not working. Fortunately, the stuff you need is on the 10.10 ...


3

It looks like the wireless device is recognized and the driver is working, otherwise we would not see wlan0 in the list given by iwconfig. First, look to see if your system has a switch or a function-key for turning off wireless, and make sure it's not activated. After that, check the Network Manager applet; this is an icon in your notification area. If ...


3

wpa_supplicant does have support for ndiswrapper and should be run like this: wpa_supplicant -i wlan0 -D wext Instructions how to install ndiswrapper drivers - however I never use ndiswrapper. If it does not help you have to say what is the output of: wpa_supplicant -i wlan0 -D wext As a side note - to use WPA you need user program called wpa ...


3

Do you have a compelling reason to build them on your own? If not, I suggest you to take two steps: Install the rpmfusion repository Perform this on the command line: su -c 'yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm ...


3

The output of dmesg indicates clearly: [63047.811382] ath9k_htc 2-1.2:1.0: ath9k_htc: Please upgrade to FW version 1.3 -- you have a problem with firmware. You should rebuild the firmware blob and the kernel module. I don't use Fedora, so I can't give you the exact commands. You must refer to the manuals (or forums) for your distribution-specific ...


3

According to this page, the driver's name is zd1211rw. Is that missing from your filesystem? Depending on your distribution, you can re-install the kernel and/or kernel modules. The driver isn't on 2.4.25 (the earliest Linux version I have lying around), but it definitely is on 2.6.32. If you manage to find the driver and it's just not getting loaded, you ...


3

I did some more Googling and found found this post http://forum.pinguyos.com/Thread-Ubuntu-Intel-Wireless-Driver-Crashes-DD-WRT It does seem to fix my issue. echo "options iwlagn 11n_disable=1" | sudo tee /etc/modprobe.d/iwlagn.conf sudo modprobe -rf iwlagn sudo modprobe -v iwlagn sudo service network-manager restart I do still have my router set to BG ...


3

You need to put if_bwn_load="yes" in /boot/loader.conf. If you don't have a /boot/loader.conf file on your system, just create it. As with the /etc/defaults/rc.conf file, /boot/defaults/loader.conf contains default values that can be overridden in a per-system fashion. Of course, you'll need to either reboot the system to pick up the new setting, or load ...


3

I think that the permissions required to get the wireless information depends on the driver. When I was using the wl driver non-root users could not get information using iwconfig, but I'm now using the b43 driver and non-root users can. I don't know of anywhere else where the ESSID is available. Your options are to either use sudo to give non-root users ...


3

Your problem may be that the Raspberry-Pi uses an arm cpu whereas most linux computers use intel/amd. Here on the Raspberry-Pi wiki there is a list of tested usb wifi dongles. If you cannot get yours to work or cannot get the correct driver then you may consider buying one of these. If you have a model b and can connect your pi to the internet try sudo ...


3

Yes. Assuming you have udev, something like the following would be a decent start: # /etc/udev/rules.d/10-rfkill.rules SUBSYSTEM=="rfkill", ATTR{type}=="wlan", RUN+="/usr/local/bin/toggle-blue" And then: #!/bin/bash #/usr/local/bin/toggle-blue if [ ${RFKILL_STATE} = 2 -o ${RFKILL_STATE} = 0 ]; then ( /etc/rc.d/bluetooth stop ) & else ...


3

Without knowing which method you used, this writeup (a little dated, for Etch) suggests what all it takes is to have the DHCP server listen on the right interface. (Sounds about right, doesn't it?) The Debian Wiki has an DHCP server entry, the Basic configuration mentioned there should be sufficient for your case.


3

I am not entirely sure what you want to achieve, but with /usr/sbin/airport you can obtain various information from wireless networks/your connection: e.g. airport -s gives information about all the networks in range (such as RSSI strength). airport -I gives information about your connection.


3

Have you tried Network Manager? It's easy to set up static IPs for wireless networks using the GUI. Once you get things working there, if you want the connection available all the time even when you're not logged in (e.g. for a file server), just select the "Connect Automatically" and "Available to all users" checkboxes. If you're allergic to GUIs, you ...


3

The wifi being "connected" only gives you the physical layer. Are your IP settings plausable? Did you set static IP because DHCP didn't work at home? ifconfig wlan0 (or name of wifi interface) Check routing route -n Do you have a default gateway? If not, set the correct one route add default gw <ip of gateway> Can you ping an internal address ...



Only top voted, non community-wiki answers of a minimum length are eligible