New answers tagged

0

I had the same questions as you. In my case, the wireless controler is a Broadcom Corporation BCM4313 and the manufacturer and model numbers are 14e4 and 4727 : $ lspci -nn -s 03:00 |grep -i net 03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01) 1 - The module alias of the controler is ...


0

It is likely that kernel 2.6.20.27 has the ath9k module but the module doesn't support the 002D device. (X)Ubuntu 14.04 uses the 3.13 kernel You may be able to check with modinfo ath9k If it supports your wireless you should have a line that shows alias: pci:v0000168Cd0000002Dsvsdbcsci* https://wikidevi.com/wiki/TP-LINK_TL-WN851ND shows that ...


0

I had the same issue. I solved it in 3 steps. Get the source code from Tp-link website related to the Linux OS for T2UH Get the right source code of the kernel in use. This very good tutorial was a great help: https://github.com/notro/rpi-source/wiki Look up in the Makefile in the source code from tp-link, to set up the right platform to compile, fix some ...


0

I don't see which operating system is in use. This is for Devuan / Debian, but the same applies to other distributions using a few different configuration files. Add a new routing table. I will call it 200 local. echo '200 local' >> /etc/iproute2/rt_tables Manually specify the IP address and gateway. Configure the wlan0 interface in ...


0

So after a lot of digging, I found that the issue was because of the kernel's rtlwifi driver. To me, it looks like the rtl8192cu driver was suppose to be responsible for handling missed beacons, by calling the function ieee80211_beacon_loss, but that call is nowhere to be found. I removed support for IEEE80211_HW_BEACON_FILTER in the rtlwifi driver and the ...


0

According to Webupd8 you need to edit /etc/pm/config.d/unload_modules configuration file by adding the following line : SUSPEND_MODULES="$SUSPEND_MODULES <kernel_module_used_by_the_interface>" In your case the kernel module in use is iwlwifi : SUSPEND_MODULES="$SUSPEND_MODULES iwlwifi" then edit you 10_resume_wifi like the following example: ...


1

First of all, this sounds like an XY problem. What are you trying to do? I'm quite sure routing network traffic in this manner is unlikely to be a good solution to whatever your problem is. Having said that, Your routing tables still have a route for 192.168.2.0/24. This means 192.168.2.1 has two routes to reach 192.168.2.2, so the kernel routing subsystem ...


2

It's possible that your router tells the others to send directly, with an ICMP redirect packet. Since they are all on the same network, it knows this should be possible. I set up routes like yours between three Linux machines (mach1 <-> mach3 <-> mach2), and tested with a ping: mach1# ping mach2 PING mach2 (x.x.x.237) 56(84) bytes of data. From ...


0

Add net.ifnames=0 to your kernel command line (via grub or whatever you use) The issue involves the non-standard 'standard' names given to network interfaces. The net.ifnames=0 cmdline option reverts the network device names to the older conventional names. (eth0, wlan0, and so forth)


1

Linux does support wifi adapters. We can't foresee the future but most adapters should work fine. Why don't you install it and address specific issues as they arise, if they do.


2

I assume wpa_supplicant and iw is installed . 1) To connect to wifi through wpa_supplicant you need to create a wpa_supplicant.conf file nano /etc/wpa_supplicant.conf with the following lines: network={ ssid="wifi_name" psk="wifi_key" } Or you can use wpa_passphrase to create the configuration file: wpa_passphrase Your_SSID ...


3

If you run iw list, look for the lines specifying VHT. VHT Capabilities (0x038071a0): Max MPDU length: 3895 Supported Channel Width: neither 160 nor 80+80 short GI (80 MHz) TX STBC SU Beamformee VHT RX MCS set: 1 streams: MCS 0-9 2 streams: MCS 0-9 3 streams: not supported 4 ...


0

Install firmware yum install iwl4965-firmware Open /etc/modprobe.d/blacklist file , and comment the blacklist iwl4965 line # blacklist iwl4965 Reboot your system and start the network services: chkconfig NetworkManager on /etc/init.d/NetworkManager start


0

Uninstall RTL8723BE driver. Install build-essential and linux-headers : sudo apt-get install linux-headers-generic build-essential Download the newest driver from here. git clone https://github.com/lwfinger/rtlwifi_new Compile: cd rtlwifi_new make clean sudo make install Unload and load the driver: modprobe -r rtl8723be modprobe rtl8723be To ...


-1

Solved by switching router mode from 11n to 11g.


0

To get information about linux-headers type the following command: apt-cache search linux-headers The output is somthing like: linux-headers-3.16.0-4-common - Common header files for Linux 3.16.0-4 linux-headers-3.16.0-4-amd64 - Header files for Linux 3.16.0-4-amd64 linux-headers-amd64 - Header files for Linux amd64 configuration (meta-package) ...


0

I finally found the problem, wpa_supplicant was not running. Try this: sudo systemctl start wpa_supplicant.service Now check the wifi list again: nmcli dev wifi list Connect to the network like this: nmcli --ask connection up <ssid>


0

I think QL Proxy from Diladele is very nice. It's ICAP/Squid based and does everything you'd need and far more. The last time I used it, it was fully functional without the purchase of a license, but that may have changed. Just the same, it's worth a look. It'll quickly and easily install on your Ubuntu system. http://www.quintolabs.com/ If you are a ...


0

Installing gnome-keyring solved the problem for me.


1

Your computer is not seeing the nearest wifi AP as it is in channel 13, which by definition should not be used in the US. I advise you to try and configure wpa_supplicant for your country code. In wpa_supplicant.conf please add the directive: country=CZ Then disable and enable wifi again. Hopefully if the card has not any other limitation, you might see ...


0

Applies to: Linux Mint 17.3 Because of an apparent bug, if you're using a Broadcom based WiFi card (such as BCM4321) on this edition of Mint, you need an internet connection already established, either from cable all by using an Atheros based USB Wifi dongle. (E.g. TP-722). At least this is so, if you attempt to install from a USB memory stick, made from an ...


0

I'm embarrassed to say the solution was to kill the already running wpa_supplicant process. The -B argument causes the program to fork into the background, and trying to run it again will fail as long as it is already running. I'm still not sure why it prints that first error message, but it connects to wireless networks without issue.


1

We also have a similar situation here with the FON network in Nós (old ZON) operator. In the past I tried this procedure, nowadays they have randomised the initial URL to try to prevent this, I am planning do some tests in a near future. BT and here our provider use captive portals to authenticate users. If I am not wrong, my own credentials work in BT in ...


0

I was having issues compiling: make defconfig-iwlwifi so I had to add: sudo apt-get install build-essential which resolved my problems and the reboot got everything working.


0

Solution I installed network-manager and network-manager-gnome and removed my wlan1 card from /etc/network/interfaces. The card remained stably connected for over 20 hours and only disconnected when I shut down the raspberry pi. The WPA Gui says "cannot get status from wpa_supplicant" but the card works anyway. Looks like nm-applet has problems with ...


0

Well, I finally tried again to install elementaryOS with the iso of December 2015 and it worked after I've changed UEFI boot to legacy. After installation, the Ethernet port worked but still not the Wifi. To make the Wifi work, I have upgraded the kernel from 3.19 to 4.3.0. Now Ethernet and Wifi seem to work fine.


0

Try AirNEF Specs say: All Canon Cameras with WiFi: Select Images in Camera: No Select Images on Computer: Yes Realtime Download: Yes Works very well for my WiFi equipped Nikon on OSX. However one word of caution; picture size does matter! Trying to pull 24MP RAW images through WiFi is not recommended. Using this method to transfer your pictures ...


0

Ok, I feel dumb now. Jeremy31's comment got me thinking about my subsystem, and that led me back to this thread. I had already decided that this didn't help me as I didn't have this subsystem, but then it suddenly hit me that I could apply the same solution by changing the line to my subsystem number. Bingo! It worked. Thanks for helping me think this ...


0

According to the wireless.wiki you need to download iwlwifi-8000-ucode-25.30.13.0.tgz firmware. Extract it and copy the file to /lib/firmware wget https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-8000-ucode-25.30.13.0.tgz tar xzvf iwlwifi-8000-ucode-25.30.13.0.tgz cd iwlwifi-8000-ucode-25.30.13.0 cp iwlwifi-*.ucode /lib/firmware Edit ...


1

Download the intel driver e1000e from here Change to the driver src directory: cp e1000e-3.3.3.tar /usr/local/src/ unzip the archive tar zxf e1000e-3.3.3.tar Install make install unload and load driver: rmmod e1000e modprobe e1000e update initramfs update-initramfs -u Reboot Connect to the internet Edit your sources.list nano ...


2

You probably need to install firmware-iwlwifi from the non-free repositories; this is the package which contains iwlwifi-6000-4.ucode. The Debian wiki provides detailed instructions. In summary: edit /etc/apt/sources.list to add the non-free repository if necessary (you will end up with a line like deb http://httpredir.debian.org/debian/ jessie main ...


0

I still haven't found anything in terms of a configuration web server as stated in my question, but this article addresses the general problem really well and lays out the current options. Essentially options include: Wi-Fi protected setup including USB flash drive configured from an AP (rare) PIN Push button (possibly the best solution when there is ...


0

(This answer doesn't contain a working solution, but see the end of the post for details we found out while investigating.) The instruction mentions "Linux 2.6", which is ages old—the current version is 4.5.2. I wouldn't expect this driver to work. The second point is: drivers that aren't part of Linux are usually of inferior quality and lack support. So ...



Top 50 recent answers are included