Hot answers tagged

6

Use udev. In Gentoo and many other distributions it is done automatically but you may want to base on that if you want quick'n'dirty solution: # This file was automatically generated by the /lib64/udev/write_net_rules # program, run by the persistent-net-generator.rules rules file. # # You can modify it, as long as you keep each rule on a single # line, and ...


3

The wifi being "connected" only gives you the physical layer. Are your IP settings plausable? Did you set static IP because DHCP didn't work at home? ifconfig wlan0 (or name of wifi interface) Check routing route -n Do you have a default gateway? If not, set the correct one route add default gw <ip of gateway> Can you ping an internal address ...


2

Your first block indicates there's no DHCP server on your local network. When you said the network interface was tested under Windows was it on this network? If it was, simply copy the settings. If it wasn't, call your ISP for the connection information. There may be some PPPoE magic required or even providing your MAC address so they can enable it to get a ...


2

This does not seem to be related to CA cert, neither is this likely to be caused by DBUS. Most likely, you are trying to authenticate using the wrong protocol (PEAP with TKIP/MSCHAPV2) Similar problem is described here. The solution is to use PEAP with GTC instead of PEAP with TKIP/MSCHAPV2.


2

You can change the location of the config files in /usr/share/wicd/daemon/wicd-daemon.py So, if /etc/wicd/ is readonly, move them to /var/lib/wicd/: i.e.: wireless_conf = "/var/lib/wicd/configurations/wireless-settings.conf" wired_conf = "/var/lib/wicd/configurations/wired-settings.conf" self.config = ...


2

wicd is included into Slackware official ISO file, so you don't need to compile it. Here's an installation's step by step: Download it, using wget: $ wget http://ftp.slackware.com/pub/slackware/slackware-14.1/extra/wicd/wicd-1.7.2.4-i486-4.txz Become superuser, type su in a terminal, i.e. xterm. $ su And install it with installpkg. # ...


2

I had problems with network manager on ubuntu , so i set up static networking. You can follow these steps and it will work ( i configured only wlan0 because i use wireless , you just need to skip the wireless related things in it) Show your interfaces: $ ip a show Note the default Ethernet and wifi interfaces: It looks like our Ethernet port is eth0. ...


1

The default WICD doesn't have the PEAP with MSCHAPv2 template. Try this: nano /etc/wicd/encryption/templates/any_name Create the folowing template: name = PEAP with TKIP/MSCHAPv2 author = unknown version = 1 require identity *Identity password *Password ----- ctrl_interface=/var/run/wpa_supplicant network={ ssid="$_ESSID" ...


1

I suggest you do one of the following: Make /etc/wicd/manager-settings.conf a symlink to a file on a filesystem that is not read-only (whether this works or not will depend on the application logic) -- the advantage of this approach is that it only affects this single file; Bind mount /etc/wicd to a directory that is not on a read-only filesystem -- a ...


1

As is often the case in matters such as these, the ArchWiki is your go-to about detailed information: here (addage: those with the best documentation shall eventually carry the day) Two, no three, items about network managers, the first being the only important one: Make sure only one is installed/active. If more than one is active your system will seem ...


1

It seems your question is more "How can I programmatically test available bandwidth?" For your ping test you could do something like this: root@xxxxxxlp01 ~ $ ping ehswebvlp10 -c4 | egrep -wo "time=.*" | cut -f2 -d= | awk '{ sum+=$1} END {print sum/4}' 0.49 root@xxxxxxlp01 ~ $ ping ehswebvlp10 -c4 | egrep -wo "time=.*" | cut -f2 -d= | awk '{ sum+=$1} END ...


1

Firmware Update The first possible side of the problem is firmware. First of all, ensure you have installed it: $ sudo-apt-get install firmware-ipw2x00 If it still would not work, you can try download a new firmware from here corresponding to your kernel driver version. To determine the deiver version use: $ dmesg | grep ipw2200 There you should see ...


1

Try running wpa_supplicant directly: put your wireless configuration in /etc/wpa_supplicant/wpa_supplicant.conf (or where ever it is ocated on your system) - for small (home) networks it usually looks similar to this (real-life, yet still mostly copied from wpa_supplicant.conf man page): network={ ssid="<your SSID goes here>" psk="<your ...


1

You can start by running wpa_supplicant manually without the -B option: it will stay in the foreground and show you what's happening. The Arch wiki has a good section on wpa_supplicant


1

You need a post-connection script for wicd. You can set it in /etc/wicd/wireless-settings.conf or /etc/wicd/wired-settings. Another way is to use wicd-gtk: there is a "Scripts" button in the network's settings page. Another way is to put the script into /etc/wicd/scripts/postconnect/. Then it should be run automatically after every connection to a network. ...


1

Try checking that there is no dhcpcd stuck with a sudo dhcpcd -k. I get not connected errors when I first use my Android phone w/ tethering (for which I just run sudo dhcpd by hand) and then trying to use wifi .


1

One possibility is that your wireless card needs firmware to operate which you haven't installed. Check your dmesg for warnings about firmware, and install the relevant firmware-linux-nonfree package or one of its dependencies if that's the case.



Only top voted, non community-wiki answers of a minimum length are eligible