Tag Info

New answers tagged

0

First of all I'd create a symlink between /var/www/ and my home what this does is, when you land into /home/usr you can go to /home/usr/www and it will redirect you to /var/www for instance. cd /home/usr sudo ln -s /var/www www perform a ls -lrt on /var/www ls -lrt /var/www/ now make sure your usr is part of group that owns www. this tells you who ...


2

This tutorial would seem to be what you're looking for, titled: Setup Virtual Users and Directories in VSFTPD. excerpt In /etc/vsftpd.conf. listen=YES anonymous_enable=NO local_enable=YES virtual_use_local_privs=YES write_enable=YES connect_from_port_20=YES secure_chroot_dir=/var/run/vsftpd pam_service_name=vsftpd guest_enable=YES user_sub_token=$USER ...


0

A slightly heavy-handed solution to allow vsftpd access anywhere, would be: setsebool -P allow_ftpd_full_access=1 At that point, vsftpd can go pretty much anywhere on the system...


1

You can usually find selinux denials in /var/log/messages. Try this (as root): grep avc /var/log/messages | grep ftp Review the output and decide whether the denials are erroneous, given your desired configuration. Tune the grep statements as necessary to whiddle the information down to only the statements you want to fix. It's often useful to ...


1

SELinux won't let vsftpd serve files from places other than /var/ftp or write logs outside /var/log on purpose. SELinux is all about disaster mitigation. FTP is fundamentally insecure. Running vsftpd under SELinux is a good idea, because it minimizes the damage an attacker can do if he decides to attack your FTP service. Running a fundamentally insecure ...


0

500 OOPS: vsftpd: refusing to run with writable root inside chroot() is a bug in version 2.3.5, it was fixed in 3.0 but it is not available in Wheezy. See workaround here ;


0

Check your firewall logs. FTP actually uses ports other than 21 once the connection is established. 21 is only the control port. Try disabling selinux to see if the problem goes away. If it does you get to read up about configuring selinux more.... The browser needs authentication information since anonymous is disabled. This means the URL needs the ...



Top 50 recent answers are included