Tag Info

New answers tagged

3

I think you can set the virtual machine's disk to be immutable in order to get what you want. [...] immutable images only remember write accesses temporarily while the virtual machine is running; all changes are lost when the virtual machine is powered on the next time. As a result, as opposed to "normal" images, the same immutable image can be used with ...


2

Flush the iptables rules just in case (iptables -F). With the network in bridge mode (I assume that was what you were after ideally) run wireshark on the Ubuntu machine and watch for DHCP requests. If you see a request but no response then you're likely looking at network restrictions. Either way wireshark will help you get a better of idea what is ...


1

I needed to change a setting in VirtualBox. I had to change my Network Attached from Bridged Network to NAT and after restart I ran an ifconfig -a and it finally pulled an IP address!


4

Your firewall is off after you ran those commands. The problem here is DNS setting. You don't have any DNS server to resolve host name www.google.com. A quick fix: echo nameserver 8.8.8.8 >> /etc/resolv.conf


0

You need to install the VirtualBox kernel modules. I believe the package you need is virtualbox-ose-dkms.


1

As someone said, the GParted doesn't copy the boot sector. To solve this problem, you need to boot with a LiveCD and then run the following commands: sudo mount /dev/sda3 /mnt sudo grub-install --root-directory=/mnt /dev/sda Considering that sda3 is your new partition


1

From what I remember the share is in /media. More importantly, I could not get it to auto mount the first time, so had to manual mount. A reboot of the guest also does the mount. I think the share is also done via smb, so I think it is accessible via network share immediately, and automatically. — Sorry I don't have a system to test, this is all from ...


0

Just run a simple command in your terminal window: $ sudo apt-get install virtualbox-guest-x11 After completion, reboot your virtual box.


0

For others that may have run into this, as I do not yet see an answer, what is your host OS? Windows 8 perhaps? I ran into the same for many *nix VM's in virtual box and finally discovered that I had outsmarted myself and introduced a conflict. In playing with Win8 I was playing with Hypervisor which I enabled, created VM's, etc., before going to Virtual ...


1

You can not have two kernel modules try to use the vt-x extension at once. So you can't have two hardware assisted virtual machines ran by two different hypervisors at the same time, on the same node. However, you can remove the module that is currently using the extension via modprobe(and friends). This would free up the extension for use by the other ...


2

Some distributions' installers don't eject the installation media when they're finished, so when you reboot you're booting from the installation media again. I've gotten into the habit of always disconnecting the installation media from the VM's virtual CD drive after the first reboot after installation, because the next step is to install the guest ...


1

Install kernel-headers by doing: yum install kernel-headers Also please make sure you are updated and actually running the mentioned kernel (if you updated your kernel, reboot).


0

You'll need to install the guest additions. You may need to install the addons that come with VirtualBox (insert the virtual CD) rather than the ones in the Ubuntu package as the Ubutu package might not support your VirtualBox version. I think you'll need to log out and back in after installing the guest additions. After that, you can resize the VirtualBox ...


1

You can do this with netcat (ssh works too; but I'm assuming both the old machine and the new machine are on the same "secure" LAN). Briefly: Build your VM with your disk space and whatnot. Boot to the FreeBSD install DVD (probably doesn't matter which version). Use the post installation options to partition and format your drives (they don't ...


0

Problem solved, in my hardware/software combination, when I applied "VirtualBox Guest Additions" as manual section 4. On web, posters have reported several different methods and each worked for their particular case. Some reported that manual section 4 procedure crashed under their hardware/software combination.


0

There has been problem with 3D acceleration for 4.3.10 and 4.3.12 with Ubuntu guest. It is advised to find earlier version further down the road until getting one that works fine.


0

You need to use “Additional Driver” in `System → Administration → Additional Driver. Ubuntu will find the correct driver for the VM.


2

In your "sudo" line, the "passwd" prompt is for your local password, not for the remote one. It hasn't started running ssh yet because the sudo hasn't authenticated you yet. Remove line 3 in your "known_hosts" file and try again.


0

Instead of setting a static IP like others suggested, I simply enabled "Bridged Adapter Mode" under "Network Connections", and then this made it such that each new virtual machine I made automatically had a new IP address. If you click "Bridged Adapter Mode" and it doesn't have any choices (i.e.the only option is "Not Selected"), then you can simply go to ...


0

Virtualbox is acting as a DHCP server for these virtual machines. You can either define static IP addresses for these machines, or simply set the IP address manually on each machine. If you don't know how to set a static IP address on your Linux system you need to learn how to do this, so I would suggest you go with the second option. There are detailed ...


0

I have used Virtual box also for testing. From windows 95 to 7 and Linux ;). I have used the NAT mode and then assign an static ip and always this has been working in any OS. This will work inside the same ip range from the LAN. Also please refer to this part of the documentation I guess this is a better way and the one required for yourself ...


1

Instead of using an USB filter, just connect the wireless network on the host operating system, and define a bridged or NAT connection in the VM configuration. On the image referenced in the comments, you have both a bridged adapter to wlan1 and an USB filter. According to the VirtualBox manual, section 3.10: "VirtualBox can allow virtual machines to ...


0

This is an old thread but came up in my search for a similar issue. In case anyone else runs into this, the following answer solved it for me: http://www.if-not-true-then-false.com/2010/install-virtualbox-guest-additions-on-fedora-centos-red-hat-rhel/ Note* The URL says 2010 but the article was updated in 2013.



Top 50 recent answers are included