Hot answers tagged

8

I hit the same issue today after upgrading to 5.0.14 (I am on Ubuntu 15.10, using the official Virtualbox apt repo) I fixed it with: sudo /usr/lib/virtualbox/vboxdrv.sh setup


7

If sudo -H -u $VMUSER VBoxManage list vms returns this: "GYO DB Clone" {1f6e2518-ed20-4d71-a974-1d4823db4a81} "GYO LB Clone" {6ba9a751-91ed-40a4-8a90-385559f67885} "GYO MC Clone" {8bd0d243-887f-49dd-966f-6c104e451277} "GYO Web Clone" {1229d75d-f046-4f3e-b15a-2d6c91b1e0d4} "GYO DB 1" {5274eb5f-d0fe-46dd-8aaf-6d23728790b1} "GYO LB 1" ...


3

Simple way to check the ssh service is up and running locally on the guest: ssh localhost alternatively: netstat -an | grep -w LISTEN | grep -w 22 If not installed, have a look to http://askubuntu.com/questions/51925/how-do-i-configure-a-new-ubuntu-installation-to-accept-ssh-connections


2

Check List: Are you able to Ping Slave-1 ? Slave-1 IPtables have allowed SSH port ? Stop IPTables and try once. service iptables stop Slave-1 is having SSH service running or not ? If yes try restarting once. service sshd start service sshd stop service sshd restart Make sure you didnt changed SSH default port. Hope it will help.


2

It looks like you are using bridged networking and your host and guest already have different IP addresses, 192.168.1.2 for the host (what you call master node) and 192.168.1.5 for the guest (slave node). Don't be confused by addresses in the 127.x.x.x network. These are loopback addresses and they never leave the TCP/IP stack, i.e. two different machines ...


2

Your problem seems to be that your rc-local.service is started before vboxadd-service.service, but it should run after it. Now, rc.local is a SysV thing (where it runs at the very end of the boot process), the compatibility provided by systemd is not perfect (as you can see in your screenshot). You'd probably better off with a custom home-test.mount unit ...


1

Install the full xorg, plus virtualbox support (you might have to reboot after that): pacman -S xorg virtualbox-guest-utils If you really want to use startx you need either to change your ~/.xinitrc to start blackbox or install ugly old twm instead.


1

Of course the answer is very opinion based, but I would go with Ubuntu (or any of its derivatives like Kubuntu) as it offers a huge community (e.g. at http://ubuntuforums.org/ or the askubuntu part of the stack network) that is really helpful. Also, many blog posts etc. deal with Ubuntu. As you are new to Linux, this is what you should look out for. On the ...


1

Fedora 14 is years (4 years!) after EOL (end of life). Current version is 23. The repositories and packages for outdated releases are long gone. Please try to install some up-to-date version.


1

You don't. It's totally unrelated. Whonix uses whatever internet connection the host operating system (in this case: Microsoft Windows) provides. Whonix does not mind about wired connection vs wifi. It's neither required, and recommended against to change VirtualBox network settings. Neither network settings inside Whonix VMs need to be changed. The only ...


1

On CentOS 7, firewalld has replaced iptables as the default firewall. I had to use systemctl stop firewalld to pause the firewall to test the connection from host to CentOS VM. See more here: http://stackoverflow.com/questions/24756240/how-can-i-use-iptables-on-centos-7


1

This worked for me - sudo apt-get purge virtualbox* Source: https://forums.virtualbox.org/viewtopic.php?f=7&t=65539 And this explains the problem - Note that some Linux distributions already come with all or part of the VirtualBox Guest Additions. You may choose to keep the distribution's version of the Guest Additions but these are often not ...



Only top voted, non community-wiki answers of a minimum length are eligible