New answers tagged

0

Simple script with good quality Script: inputFile=$1 FPS=15 WIDTH=320 #Generate palette for better quality ffmpeg -i $inputFile -vf fps=$FPS,scale=$WIDTH:-1:flags=lanczos,palettegen tmp_palette.png #Generate gif using palette ffmpeg -i $inputFile -i tmp_palette.png -loop 0 -filter_complex "fps=$FPS,scale=$WIDTH:-1:flags=lanczos[x];[x][1:v]paletteuse" ...


2

You need to activate the local graphics servers. Just run the command xhost +local:root and it should work. Also keep in mind that you will have to run this command every time you restart your Raspberry Pi.


3

Debian and many other Gnu/Linux distros use X11+Gnu+Linux. The X11 server handles the screen/keyboard/mouse, your process is trying to connect to it, so that it can display stuff. This normally works without problem, but because you have changed user, it is having trouble authenticating. (There is security between user process and X11 display server, as it ...


0

Solve VLC Media Player Video Decoding Problem: Right click on vlc > Tools > Preferences > Input / Codecs > Hardware-accelerated decoding >> VA-API video decoder via X11 Right click on vlc > Tools > Preferences > Video > Output >> X11 video output (XCB)


1

Here's what worked for me: ffmpeg -i animated.gif -movflags faststart -pix_fmt yuv420p -vf "scale=trunc(iw/2)*2:trunc(ih/2)*2" video.mp4 movflags – This option optimizes the structure of the MP4 file so the browser can load it as quickly as possible. pix_fmt – MP4 videos store pixels in different formats. We include this option to specify a specific ...


2

No need to shut down hardware acceleratio/overlay. In VLC and Gnome MPlayer, under preferences choose x11 as video output module. Ubuntu 16.04, i7 6500U, skylake GT2, Intel HD 520 graphics


0

Apparently this is a common problem with Linux and Intel chipsets. If you have i915 chipsets and Grub, try editing /etc/default/grub and adding i915.enable_psr=0 to the GRUB_CMDLINE_LINUX_DEFAULT line. E.g., GRUB_CMDLINE_LINUX_DEFAULT="foo bar i915.enable_psr=0". Then run command update-grub and reboot.


0

smplayer can optionally remember, for each file it plays, where it was in the video or audio file when it exited. This can be enabled or disabled with: Options menu -> Preferences -> General tab, "Remember Time Position" checkbox.



Top 50 recent answers are included