Tag Info

New answers tagged

0

to get the driver for a network interface, just use : ethtool -i en0 and look for the "driver" section : root@odin ~ # ethtool -i eth0 driver: e1000e version: 2.3.2-k firmware-version: 0.13-4 Here, my driver is e1000e. Now you can rmmod your driver and modprobe it again. This will also reset the network counters, of course.


2

You might be able to re-detect it without reboot, by unloading / re-loading the correct module (or just un-binding and re-binding the driver). For example: [ 978.527221] sd 11:0:0:1: [sdk] Attached SCSI removable disk #~> echo 11:0:0:1 > /sys/bus/scsi/drivers/sd/unbind #~> echo 11:0:0:1 > /sys/bus/scsi/drivers/sd/bind [ 5572.027119] sd ...


0

Unfortunately I wasn't able to find the reason why udev and udisks2 didn't work together. But I found a solution for my problem here. Below is a simple example how to implement automount of a ntfs usb hdd. First is a script mount.sh to mount a drive #!/bin/bash mkdir -p /media/usbhdd mount -t ntfs-3g -o ...


2

Apparently, udev has changed the way it matches hardware in v220, which means that it was necessary to change keyboard:usb:v046DpC52B* to evdev:input:b0003v046Dp402D* (the b0003 is the bus-id of USB) What irritates me is that another product ID is now needed. Before v220, the ID C52B was used for all parts of the device (a multi-button mouse), however ...


1

You'll probably want to write a rule for udev. Assuming no changes to udev.conf, your rules file should be placed into /etc/udev/rules.d/; it may help you to crib from packages' rules which may be found in /lib/udev/rules.d/. Writing good rules is a bit of an acquired art, but you could start with something simple if you have no other ttyACM* devices: # ...


2

Turns out CUPS offers the commands cupsreject and cupsaccept to mark/unmark a printer as unusable (so it will appear greyed out in print dialogs). cupsreject also accepts an optional -r parameter with a string that gives a reason for the printer's unavailability. Combined with two udev rules that are executed when the printer is connected to the USB port ...


1

You target the wrong node. Your current rule: UBSYSTEM=="usb", ATTR{idVendor}=="0451", ATTR{idProduct}=="f430" matches this node: /devices/pci0000:00/0000:00:13.0/usb2/2-2 Where you should target the leaf node which match your device /dev/ttyUSB0 ie: /devices/pci0000:00/0000:00:13.0/usb2/2-2/2-2:2.0/ttyUSB0/tty/ttyUSB0 or may be: ...


0

Typo mistake, use == for match and = for assignment. So your rule should be: KERNEL=="nvidia[0-9]", GROUP="video", MODE="0666"


0

From insmod manpage: insmod is a trivial program to insert a module into the kernel. Most users will want to use modprobe(8) instead, which is more clever and can handle module dependencies. pcnet32 module depends on mii module, which is not loaded when you load pcnet32 using insmod. modprobe pcnet32 should solve the problem. Alternatively you can ...


0

Disable your Network Manager and Configure the devices using files defined in /etc/network/interfaces you can also rename the device name using udev rules as Using Udev rules to rename the devices cd /etc/udev/rules.d/ cat 70-persistent-net.rules edit the 70-persistent-net.rules to change the name of PCI Devices in your case USB device and connect it ...


0

Version 220-7 on Debian dropped the patch that made this opt-in: * Switch to net.ifnames persistent network interfaces (on new installations/for new hardware), and deprecate the old 75-persistent-net-generator.rules. This came about from a proposal in debian-devel list. Systems which were using the old naming won't be renamed until the user migrates. ...


-1

Ubuntu 15 uses biosdevname which doesn't provide predictable network interface names. Even if you remove it (apt-get remove biosdevname) and edit grub (GRUB_CMDLINE_LINUX_DEFAULT="net.ifnames=1") and the persistent rules, you still don't get predicatble network interaces. The main reason seems to be backward compatibility. I tested it just now with 2 ...


2

I found solution to (a) atleast. I need to run udevadm test <sys_path_of_Device> This command will run in dry-mode, but will give the correct pointer to rules file.



Top 50 recent answers are included