New answers tagged

6

It shows ? since there is no TTY (terminal interface) to which this process is attached. This is fortunate since sshd is a system daemon and should not be dependent on a client session. As mentioned in the comments, closing a session will terminate all related processes for that TTY, which is not desired for system wide processes.


0

I finally found out what was the issue for this behaviour. I used some busy waiting in my communication loop, which lead to heavy cpu load. I read then, that using SerialPort commands like BytesToRead and Read are not ideal at all: If you must use .NET System.IO.Port.Serialport Therefore I tried using asynchronous functions of ByteStream ReadAsync and ...


0

The simplest solution I found was to edit /etc/default/console-setup to set FONT="Lat7-Terminus32x16.psf.gz" and comment out everything else except the ACTIVE_CONSOLES line. You can apply this immediately with setupcon, and it will be applied after rebooting as well. Specifying the font name rather than the individual components works around the naming ...


1

In RedHat 6 there is an upstart script /etc/init/serial.conf that will ensure the console is designated a secure terminal before starting the getty process, and so ensuring root can login on the console. You may be better off setting the root password to something unknown, thus forcing people to always login as a non-root user and then using sudo to switch ...


4

The reason is that ttyname(3) isn't a system call, it's a C library function. You can check out its implementation, e.g. in glibc, to see what system calls it uses itself (and which you'll then see in strace's output). To trace library calls on Linux, you can use ltrace (which can also trace system calls). (Thanks to Marki555 for the suggestion.)


0

For those who manage to connect via SSH after finding out the IP using arp -an on the host, you can perform the following steps (taken from the bottom of this page) once you are connected to the guest. Edit the grub configuration file: sudo vim /etc/default/grub Add the text console=ttyS0 to the GRUB_CMDLINE_LINUX_DEFAULT parameter as shown below: ...



Top 50 recent answers are included