Hot answers tagged

3

C-b c already has a standard binding which it might be wise to leave unchanged. Choosing another character, eg C-b C you can setup a binding in your ~/.tmux.conf file as follows: bind C send-keys -t.- 'mvn install' Enter The -t.- means "the other pane". Enter stands for the key of that name, i.e. the newline at the end of the command.


2

From here you can unbind the key combination in byobu: Create a file ~/.byobu/.tmux.conf with (or add if the file exists): set-window-option -g xterm-keys on Then add the following to ~/.byobu/keybindings.tmux: unbind-key -n C-Left unbind-key -n C-Right


2

The question (and suggested answer) are a little obscure, but what is being described is mutt's use of the default color feature of ncurses (or slang). If your mutt color scheme uses the word "default" for the foreground or background, then at runtime mutt will ask ncurses/slang to use the terminal's default color. Whether in an application such as mutt or ...


1

Add this to ~/.tmux.conf: bind-key 0 if-shell 'tmux select-window -t :0' '' 'new-window -t :0' This will first attempt to switch to window 0, and if that failed, create it. Repeat for 1-9.


1

just provide the directory you want manually when you create the split :split-window -c "/dir/you/want" e.g. <prefix>,:, split-window -c "/var/lib/apt" Explanation split-window is the tmux command to create a split, it takes alot of options to allow you to specify size, string interpolations as well as -c to specify working directory. from man ...


1

Ok, so it appears this was an issue with the Gnome Dropdown Terminal extension. Under settings > Terminal, I had a custom command setup as "tmux". Removing this solved the issue. When opening a dropdown terminal now, I just run "tmux" manually, and I am able to escape the weird suspended mode using the "FG" shortcut as recommended.


1

You probably ended up typing Ctrl-Z which suspended tmux. Try typing fg, then enter to continue.


1

If you have the GNU version of more installed: more -d -f -10 foo This displays the file foo 10 lines at a time, pausing with a prompt messsage after each 10 lines. Press spacebar or Enter at each pause to display the next 10 lines. You can also press h or ? at the more prompt to see more's other capabilities. see man more for more details. BTW, if ...


1

You can always, at the end of your process, send the special "alert" or bell character, eg with $ echo -en '\a' and this should make the outer tmux session window beep or flash if you configure your terminal for a visible bell. On the inner tmux you might need to have the bell propagated with set-option bell-on-alert on


1

What you are asking does not seem to be developed on linux yet : Terminator has an open issue, somebody seems to be working on it actively : https://bugs.launchpad.net/terminator/+bug/1301605 Gnome-terminal doesn't seem to have any support. No bug has been filed related to this feature anyways : gnome-terminal bugs Konsole neither : ...



Only top voted, non community-wiki answers of a minimum length are eligible