New answers tagged

2

There are two things that you want to achieve: Disallow the authentication using ~/.ssh/authorized_keys As proposed set AuthorizedKeysFile to some different place. If there is the discussed requirement, it will not be evaluated (otherwise there is nothing more to solve). Set AuthorizedKeysCommand The command will return you the authorized keys from your ...


1

The rssh manpage indicates it should be the login shell of these users: The system administrator should install the shell on the restricted system. Then the password file entry of any user for whom it is desireable to provide restricted access should be edited, such that their shell is rssh. For example: ...


0

I found the keys generated by puttygen to be troublesome in almost every attempt I made. I am not exactly sure why and how, but the format of the file it generates is not accepted by my Linux and other legacy UNIX systems. My suggestion is, once you are on the server, generate keys using command ssh-keygen -t rsa enter pass phrase if you want and file ...


1

As pointed out by Ulrich Schwarz, .ssh/authorized_keys must be a regular file. In your case, it looks like it's a directory. You need to remove the directory and create a single text file with the key in it.


0

Based on the output i.e. "Authorized Use Only" you do seem to connect. (I assume that is coming from the server.) You could check the sshd server log messages. You appear to have shown the server side sshd configuration, so it looks like you can login there via some other mechanism. The suggestion of running the sshd server in debug mode (perhaps also on a ...


0

So, I'm assuming you added your machine to AD the right way and used realm. Let's assume you did that. This is what I do. Groups: generaluser and linuxadm CentOS 6 and CentOS 7 (in your case) use SSSD for authentication Since this is the case, I don't use realm (nor ssh) to judge who can login. I do it directly from sssd, because that will control not ...


1

I believe you need is ssh-keygen, which remembers your "device signature". So even you changed your password, it still works as long as you ssh from the same device. Here is a detailed tutorial how to set it up. Does it need to be run in root privilege? No, you only need root privilege on the host-server when you set it up, in order to edit some file ...


1

It was asked before on ServerFault. Quoting with few modification and notes: Start the process with /usr/sbin/sshd -f ~/.ssh/sshd_config where ~/.ssh/sshd_config is a new file you created. Among other options (such as a different host key, different port, etc) you need to add the line UsePrivilegeSeparation no. This will prevent the sshd process from ...


0

I believe they run some kind of containers so you don't see the whole picture. Your ps aux is really limited. When there is nothing running, they probably stop the box/swap memory somewhere and report zeros, if you ssh in, they put the box online and load the whole system. 500 MB is too much for one ssh connection. It correlates to whole system.


2

Get a better provider than GoDaddy. BlueHost or Hostgator spring to mind, although I've never used either. Your ps aux output shows that your ssh session is currently using 1.8kib of memory 1.8 SSH 1.6 -bash 124 cpaneld 1.02 ps aux All sizes are in kib, so total is about 128mb. It's not unreasonable to think that a fully configured and running OS ...


1

On CentOS, sshd (the daemon) is usually in /usr/sbin/sshd. In any event, you can find out from the RPM: rpm -qil openssh-server | grep sshd


0

I believe much more secure and useful is to ForwardAgent from your workstation, than having some keys on some server and fiddle during each login with agent reinitialization. You can simply add to your ~/ssh/config for appropriate host (or use -A switch to ssh command): ForwardAgent yes Add the local key to your local agent and you don't have to care if ...



Top 50 recent answers are included