Tag Info

Hot answers tagged

11

The default ssh settings make for a pretty slow connection. Try the following instead: ssh -YC4c arcfour,blowfish-cbc user@hostname firefox -no-remote The options used are: -Y Enables trusted X11 forwarding. Trusted X11 forwardings are not subjected to the X11 SECURITY extension controls. -C Requests compression of all data ...


8

One of the biggest issues when launching some X-client remotely is the X-protocol, not so much the ssh overhead! The X-protocol requires a lot of ping-pong'ing between the client and the server which absolutely kills performance in the case of remote applications. Try something like "x2go" (which also goes over ssh with default setups) in you will notice ...


3

On your local system, create a skeleton of what you want. For example, if you want to copy file foo to remote location /etc/foo, then you need to create an etc directory and then put foo into it. Then tar the skeleton. Now you can do this via cron as suggested by @Anthon in the comments to the question above. Step by step: On the remote host, create ...


3

This is untested (since I don't use GUIs) but try this: #!/bin/bash # From this answer http://unix.stackexchange.com/a/29949/82289 SSH_HOST=me@mylab.myuniversity.edu ssh -f -N -D 12345 -M -S /tmp/ssh_tunnel_%h.sock -o ExitOnForwardFailure=yes $SSH_HOST && \ echo "ssh tunnel started successfully" || \ echo "ssh tunnel failed to start" # Launch ...


2

Here is the solution from the link I posted in my comment. This comes from here, which references this superuser post. Create .ssh folder in /home for the keys to be stored sudo mkdir /home/.ssh Move existing authorized_keys file into .ssh dir as username sudo mv ~/.ssh/authorized_keys /home/.ssh/username Create symbolic link to authorized_keys file ...


2

You use DenyHOSTS. From the blurp on their webpage: enyHosts is a script intended to be run by Linux system administrators to help thwart SSH server attacks (also known as dictionary based attacks and brute force attacks). If you've ever looked at your ssh log (/var/log/secure on Redhat, /var/log/auth.log on Mandrake, etc...) you may be alarmed to ...


2

Check your /etc/ssh/sshd_config. Find the line smth like Subsystem sftp /usr/libexec/openssh/sftp-server. Next you have two options (should work both, I do not remember which one I have used). First, you may register this executable as a shell and set it for the user, or, the second one, ForcedCommand for that user in sshd_config.


2

You can use an SSH agent for this: eval $(ssh-agent) ssh-add on the client. This will request your password once, then remember your private key and use it whenever you connect to the server.


1

Didn't try by myself, but it should be possible to wrap the sftp executable. (check sshd_config for something like: Subsystem sftp /usr/libexec/openssh/sftp-server). It doesn't look to be setuid, so it can be a shell script wrapper. The rest depends on how it is called.


1

If you want to remove the need to ever enter a passphrase you can do it this way (using "" as new_passphrase) - on the Pi: ssh-keygen -p [-P old_passphrase] [-N new_passphrase] [-f keyfile]


1

{What are} / {are there} security implications of leaving a ssh connection perpetually open? The session key is renegotiated periodically so there aren't many confidentiality issues. You can configure the time between renegotiates with RekeyLimit (second parameter to that directive) if that's a concern for you. As shadowbq kind of alluded, the security ...


1

ssh by default and by design doesn't do it. This is because clear text passwords embedded in scripts is pretty fundamentally a bad idea. Not least because - if it's specified on a single command line, it normally shows up in the ps list that every user can see. So it's deliberately made difficult, to encourage better habits. public-private key pairs and ...


1

It is possible if you can install sshpass, so you can run: sshpass -p 'password' ssh 192.168.1.1



Only top voted, non community-wiki answers of a minimum length are eligible