Tag Info

New answers tagged

0

I found a dirty but working solution <HTML><HEAD> </HEAD> <script type="text/javascript"> var searchURL = "%U"; var newSearchURL = searchURL.replace("http://",""); var newSearchURL = newSearchURL.replace("/",""); var redirectTo = "http://www.google.com/search?hl=en&q=" window.location = redirectTo + newSearchURL ...


0

cache deny asks Squid not to keep a cache of the matched URLs, but not to prevent users from accessing them; what you want here is http_access deny disable-website.


0

I fixed my problem my writing ssl_bump server-first all and removing ssl_bump allow all. I'm not sure if it contributed to fixing the problem, but I also put these lines into my terminal: /sbin/iptables -t nat -A PREROUTING -p TCP -s 127.0.0.1 --dport 80 -j REDIRECT --to-port 3128 /sbin/iptables -t nat -A PREROUTING -p TCP -s 127.0.0.1 --dport 443 -j ...


2

Due to the fact that SSL is end-to-end encryption, a proxy such as Squid normally knows much less about an HTTPS request than it does on HTTP (http://wiki.squid-cache.org/Features/HTTPS#CONNECT_tunnel): [Many] common parts of the request URL do not exist in a CONNECT request: the URL scheme or protocol (e.g., http://, https://, ftp://, voip://, ...


0

Quoting the Squid FAQ: MAC address is only available for clients that are on the same subnet. If the client is on a different subnet, then Squid can not find out its MAC address as the MAC is replaced by the router MAC when a packet is router. If it is on the same subnet/L2 domain, this shall be enough acl M1 arp 01:02:03:04:05:06 acl M2 arp ...


0

You can just use update-rc.d squid3 disable. You will get a warning about the init script not existing, but it will still disable the upstart job perfectly.



Top 50 recent answers are included