Tag Info

New answers tagged

0

Try installing CodeAnalyst with yum: yum localinstall <path to CodeAnalyst rpm>


1

If you take one of the urls that gives a 404 error and put it in your browser, you will see that you get the 404 error as well. This might be temporary, or a server error so what you can do is search up the directory structure until your url is http://archive.ubuntu.com/ubuntu/dists/. There you will see subdirectories for lucid (10.04), precise (12.04), ...


3

Set the environment variable DEBIAN_FRONTEND=noninteractive. For example: export DEBIAN_FRONTEND=noninteractive apt-get install -y libpq-dev This will make apt-get select the default options.


3

You should be able to achieve this using debconf-set-selections. From the man page: debconf-set-selections can be used to pre-seed the debconf database with answers, or to change answers in the database. Each question will be marked as seen to prevent debconf from asking the question interactively. In order to determine the required input to ...


4

GNU sed is bundled with releases newer than Solaris 10. Otherwise, you can easily build it from source or retrieve it from opencsw or other freeware repositories. Solaris 10 packages are listed in this pdf: http://docs.oracle.com/cd/E19253-01/pdf/817-0545.pdf


2

If you just installed it it's likely that your shell has cached the old path. Use: hash -r to clear the command hash table and then try running the command again.


0

../include/id3/id3lib_strings.h: In static member function 'static std::char_traits<unsigned char>::char_type* std::char_traits<unsigned char>::move(std::char_traits<unsigned char>::char_type*, const char_type*, std::size_t)': ../include/id3/id3lib_strings.h:87:72: error: 'memmove' was not declared in this scope ...


0

I think the problem is that you don't want the first two lines you put in /etc/apt/sources.list, namely deb http://llvm.org/apt/trusty/ llvm-toolchain-trusty main deb-src http://llvm.org/apt/trusty/ llvm-toolchain-trusty main I suspect these correspond to 3.5 (trunk). You can verify this by running apt-cache policy pkg1 ... pkgn where the pkgs run ...


0

Check your .bashrc. I found strange vars in mine: /root/.bashrc:PERL_MM_OPT="INSTALL_BASE=/root/perl5"; export PERL_MM_OPT; remove them and re-login.


0

If you don't want to resort to OpenJDK, you can just use a different Ubuntu version in your /etc/apt/sources.list.d/webupd8team-java.list file: deb http://ppa.launchpad.net/webupd8team/java/ubuntu quantal main # deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu quantal main Instead of "quantal" you can probably use any of the values from the ...


1

I don't have Elementary (or anything Debian-based) in front of me to test, but I think you're right to identify that line as the source of the confusion. The instructions you link have some assumed steps. After you download the source package, you should unpack it (with tar xvf filename), and then cd into the created directory. That directory should ...


3

What you have is an archive. Linux has a massive manual with nearly every command right at your fingertips. These are called the man pages. To use man command, and it will give you everything on how to use it. In your case, you want tar to unarchive your file. To see how to do this, man 1 tar, or simply man tar will show you all of the options for archiving ...


3

Like goldilocks, I keep the installation files around in a folder designated src -- in my case sometimes it's /usr/local/src, but often it's /opt/src. I take it a step further -- I use 'script' to record a typescript all the way through the process, and I rename those typescript files to help me remember what they were for later. I keep them in the same ...


3

The phrase "supposed to" implies that there is some sort of rule about how a developer or user is expected to behave. That's not really reasonable. :-) People who distribute software can take the packaging as far as they choose to -- their time is their time, after all. "Users" come in all flavors -- that could be anyone from a complete neophyte to a ...


2

q1. Is an installer always used for binary installation, not doing any compilation work for source installation? No. You can actually run a binary from anywhere on the filesystem in most linux systems, you do not need an installer. q2a. Does Linux have the concept "installer" for package installation? Yes, lots of packaging tools will call installers to ...


2

I wouldn't store just the makefile. While the uninstall target may not (or perhap, should not) need anything else to succeed, that's not a guarantee. So that means keeping a copy of the original package. There's not much point, though, if there's a public archive of old versions and you aren't worried about it going away. You can just download it again ...


1

In general, ./configure && make && make install without any parameters sticks everything under /usr/local, which would place foo.pc in /usr/local/lib/pkgconfig/foo.pc To make use of this, you'd need to do basically PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:${PKG_CONFIG_PATH} pkg-config --cflags foo, or, compile in this manner: ./configure ...


1

Since what commands are used in a makefile is essentially up to the project developers, it is difficult to give a definite answer here. Generally I would say that it is good practice to use the install command in a makefile for any installation processes mentioned in 2, but then again install is not POSIX so always using it may not be the most portable ...


5

install offers a number of features in addition to copying files to a directory. the -s option removes the symbol table from an executable, saving space the -m option sets the permission bits. The files sitting in the developer's directory were created subject to his or her umask, which may prevent others from executing them. install -m 755 file1 ...


0

Make sure bin subdirectories of both packages (libxml2/libxslt) are on your PATH. They contain *-config scripts which are used during compilation of lxml to find out where libxml2/libxslt were installed. [pdobrogost@host /]$ echo $PATH (...):/opt/libxslt-1.1.27/bin:/opt/libxml2-2.6.32/bin:(...) [pdobrogost@host /]$ which xml2-config && which ...


2

I would encourage you to not replace any executables that are part of a package that was installed using APT or dpkg. It's better to keep this file in the directory /usr/local/bin, IMO, given it's custom software that you've built yourself. Also I'd take a look at that "Makefile", Makefile.Debian to see if it includes a make install target. That target, ...


1

You can try (as root), typing in yum install rsh It's probably not installed, since it's old and insecure, but you CAN install it and get it going. RCP/RSH is old and insecure, and designing things to work with it, rather than updating to make use of more current technology, is pointless. Maybe try showing the 'designer' this or even better, show your ...


3

I am using CentOS 6.5 and rcp binary belongs to package krb5-appl-clients-1.0.1-7.el6_2.1.x86_64 [root@CentOS-VM1 6]# rpm -qf $(which rcp) krb5-appl-servers-1.0.1-7.el6_2.1.x86_64 krb5-appl-clients-1.0.1-7.el6_2.1.x86_64 My CentOS version -- [root@CentOS-VM1 6]# lsb_release -d Description: CentOS release 6.5 (Final) You can install package ...


1

In my opinion, there is nothing here that can be reasonably fixed. After a discussion with the poster on chat, it became clear that is he is basically doing unsupported things. He first installed Knoppix, and then added Debian repositories and then tried to install/upgrade to Debian packages. This is not supported by Knoppix or Debian or anyone else as far ...


2

0 upgraded, 6 newly installed, 0 to remove and 488 not upgraded. The problem here is that you are in-between several upgrade paths for every package. You are not using stable, nor testing, and that brings about problems. You should upgrade as many packages as possible to stable first: sudo apt-get -t stable dist-upgrade Then decide if you want to ...


0

This sounds like your issue in this forum post about peak titled: PEAK 7.8 Drivers - Debian. You need to make sure that the Linux Kernel source is installed, so that you can compile this driver. $ sudo apt-get install linux-headers


0

The message "Dependency is not satisfiable: python-central(>=0.6.11)" means that you also need to install the python-central package, at version 0.6.11 as a minimum. However, since you are working on an offline computer, is very likely that you will run into another missing dependencies problem. You can check several methods to download and install ...


1

This is telling you that a dependancy (another package that is required to run the one you want to install) is either not installed on the system, or that the version installed is too old. The easiest way to make that work is to connect the machine to the internet and install with the package manager. This will automatically get and install any dependancies ...


3

You assume correctly :-) Your package manager is complaining that the package you're trying to install is requesting that python-central with a version greater than or equal to 0.6.11 is installed, but it can't install it. You have two problems here - the first is that you're not connected to the internet and the second is the fact that python-central is ...


1

It means python central is not installed, or too old. You need to connect to the internet, or go chase the dependencies manually. There'll probably be more after this one.



Top 50 recent answers are included