Tag Info

Hot answers tagged

7

For a moment, I thought that this might be inherited from the GDM configuration (since the GDM login screen does the same thing), but apparently it's not. After checking a few other places without any luck, I decided to find out for myself and took a look at the source code(v2.30). The code responsible for the shaking only checks to make sure the dialog ...


7

See: $ xscreensaver-command -time XScreenSaver 5.15: screen locked since Wed Sep 26 16:26:15 2012


6

You could use xautolock: Xautolock monitors console activity under the X window system, and fires up a program of your choice if nothing happens during a user configurable period of time. You can use this to automatically start up a screen locker in case you tend to forget to do so manually before having a coffee break. Something along the lines of: ...


5

The simplest is slock, the suckless screen locker. You could combine this with xautolock if you wanted to automate it after a period of inactivity. If you want something more "featurefull" you could install xscreensaver. Of course, gnome-screensaver is an option as well...


4

You can use xscreensaver command . $ xscreensaver-command -activate If it is not there on your system install it by : $ sudo apt-get install xscreensaver On Fedora/CentOS/RHEL you install it with this command: $ sudo yum install xscreensaver-base


4

The xset command controls a number of parameters of the X server (the part of the system that provides a graphical display with windows), including its built-in screen saver and blanking ability. xset -dpms s off If you're using a third party screensaver, it might still be triggered.


4

I believe that this phoronix article has some answers for you about wayland and screensaver. This article mainly says that it will be more integrated : it can ensure that no window can appear atop the screensaver surface, it can properly detect idling and grabs already, and has complete control over the screen. Unlike the X design, there wouldn't ...


4

mplayer has the switch -heartbeat-cmd to run a command every 30 seconds, but as the man page says: This can be "misused" to disable screensavers that do not support the proper X API The actual switch meant to disable screensavers is -stop-xscreensaver; you should probably try that first


3

If you are using KDE's own builtin screensaver, I'm not sure... however, if you are using xscreensaver or are interested in using xscreensaver the following should help. Using xscreensaver you can adjust the number of pixels that the mouse must move before deactivating the screensaver; not sure about completing disabling the mouse though. If you are not ...


3

You could run a script: #!/bin/bash gnome-screensaver-command --lock xset dpms force off Bind this to a key sequence and whenever you lock your screen, the display will turn off.


3

Turns out that I found the answer. Debian has a package called fbi that draws an image to the framebuffer from the console (the real one, not the terminal emulator in X11). Even can do slideshows :)


3

I haven't been able to find an actual command to change the lock feature, but in the configuration file .xscreensaver, located in the home folder, I've found the value of lock: lock: False In order to modify its value, I can change the value in the config file by using the command: sed -i 's/\(lock:\t\t\).*/\1False/' /home/username/.xscreensaver False ...


3

If you saw this on an older system, chances that it was running xscreensaver. You can see its standard collection; there's a maze one which looks like what you describe. Note that it was common for people to install their own screensavers, for the decorative appeal. So this could have been something added locally, perhaps even something coded locally. ...


3

The details on how to do this were found here in this blog post titled: Locking the screen from the command line in Gnome 3.8. Manually triggering The dbus-send command can be used to send this message, in this case we're sending the "Lock" message to the screensaver. $ dbus-send --type=method_call --dest=org.gnome.ScreenSaver \ ...


2

Ubuntu Forums suggests the following: gconftool --type int -s /apps/gnome-power-manager/backlight/idle_dim_time ***time*** gconftool --type int -s /apps/gnome-power-manager/timeout/sleep_display_battery ***time*** gconftool --type int -s /apps/gnome-power-manager/timeout/sleep_computer_battery ***time***


2

You'll find different scripts in order to do that on ubuntu forum. It's quite hacky and it does not seem that a clean way exist.


2

If all you want to do is blank the screen, as opposed to running a fancy animation or locking the screen, then xset can do it. xset dpms force off If you want to lock the display, you need a screen locking program, e.g. xscreensaver-command -lock -activate or gnome-screensaver -al or (for KDE4) qdbus org.freedesktop.ScreenSaver /ScreenSaver Lock. If you ...


2

A few years ago I used a PC keyboard with a Macintosh multi-booting Mac OS 9, Mac OS X and Linux. The windows key generated the same keycode as the Apple Command Key and showed up in linux as 'meta' or something. Try geekosaur's answer for mapping the windows key here. Even if it is the wrong keycode, something very similar should do for you. Edit: Example ...


2

The latest versions of Cinnamon come with their wn screensaver package so these solutions might not work, but they do on my Cinnamon 1.8.8. lightsOn LighstOn is a simple BASH script that will inhibit the screensaver when it detects any of a list of user defined programs (mplayer, and therefore smplayer, are on the list by default) running in full screen ...


2

Use caffeine yaourt -S caffeine-bzr if yaourt installed otherwise you will have to build it from here AUR For caffeine-bzr after it is running. Activate it. It differs slightly based on DM how to set it up. You just need to add the executable to caffeine. I am not familiar with Urban Terror, but you might have to include the wine part of the ...


2

Background There are 2 solutions that were determined for this particular problem. The 1st involved launching xscreensaver, and disabling it so that no screensaver is configured. The 2nd method involved completely disabling the screensaver in X altogether, through the use of the xset command. Solution #1 A solution with a narrow scope (by cipricus) is ...


2

Source: http://comments.gmane.org/gmane.linux.redhat.fedora.general/385326 Install the xdotool package (available on F11...not sure if F14 has it) and then use one of the commands to move the mouse.


2

Unless you are starting your graphical environment using startx or xinit, ~/.xinitrc is not being read. You should add the lines to your ~/.profile instead. To make sure they are only run when you have an active X session, use: if [ ! -t 0 ]; then set s off. xset -dpms xset s noblank exec /etc/alternatives/x-session-manager fi


1

Adding xset -dpms s off to the file ~/.fluxbox/startup seems to do the trick very well.


1

in your /etc/systemd/logind.conf file, add the line HandleLidSwitch=suspend or if that doesn't work, HandleLidSwitch=hibernate Source: http://www.freedesktop.org/software/systemd/man/logind.conf.html


1

I don't think this is possible looking at how GNOME3 and GDM currently work. At least not without having to restart /etc/init.d/gdm3 every time you want the image to rotate. This seems impractical. The steps to change the login and the lock screen wallpaper are discussed here in this post titled: Change desktop, login and lock screen wallpapers in GNOME ...


1

Your pygobject is too old. gi.repository used to be provided by PyGI. It was merged into pygobject, but not until 2.21.4, so you either need to update pygobject or install PyGI (probably the former)


1

This question really belongs back on raspberrypi.stackexchange.com because it's a Raspberry Pi-specific issue: the kernel framebuffer driver for the Raspberry Pi does not support the function that X uses to put the monitor to sleep: https://github.com/raspberrypi/linux/issues/487 Until this issue is fixed, it won't be possible for X to put the monitor to ...


1

Dispelling wrong paths First, virtually all modern displays support sleep modes. Also, xset dpms force off (or other ways to tell the X server) is the correct way (under X) to turn off monitors. I've used that for years without a hitch. Second, the mention DPMS is Disabled only comes from your xset -dpms. As soon as you issue xset dpms force off or other ...


1

Your screen lock time is longer than your low-power time, hence your system doesn't technically lock until after it's gone into low-power mode. However, since your system is in low-power mode it can't lock but instead locks at the earliest possible time, which would be once it has been woken back up.



Only top voted, non community-wiki answers of a minimum length are eligible