Tag Info

New answers tagged

0

Found it!! It seems that in Ubuntu the entries in ~/.ssh/known_hosts are hashed, so SSH completion cannot read them. This is a feature, not a bug. Even by adding HashKnownHosts no to ~/.ssh/config and /etc/ssh/ssh_config I was unable to prevent the host hashing. However, the hosts that I am interested in are also found in ~/.ssh/config. Here is a script ...


0

I found that the autocomplete was not working because Ubuntu hashes known hosts. You can add HashKnownHosts no To your .ssh/config file but existing hosts won't be un-hashed.


-1

If you happen to be on OSX... When I tried running it with username@local:/file_directory... I got the following error: ssh: local: node name or service name not known Solution On my Mac I had to do the following to setup local ssh: ‘System Preferences’ --> ‘Internet & Networking’ --> ‘Sharing’ --> ENABLE ‘Remote Login’ This then provided the ...


0

AFAIK, scp does not initialize a shell, thus don't source any file such as .profile, .bashrc, /etc/profile. So the only way of doing this seems to use the pam module pam_umask.so. But it will be applied to all users (unless you use a more complicated PAM setup) The file /etc/pam.d/sshd is probably the best place to do it, if you want to limit this behavior ...


0

try replacing while true ; do echo ... by while tty -s ; do echo ... This will disable double password checking. This might not be you intend. Now if you keep to your double password strategy, the only choice left is to pull the file with scp once your are loggon (and twice identified), this depend on the plateform the file is comming from.


1

Does the command below work? % ssh -o ProxyCommand='ssh -p 2222 userS@SERVER /usr/bin/nc %h %p' userD@DESKTOP If so, you can bake the proxycommand into your ~/.ssh/config to make scp and sshfs calls easier.


1

scp has a -p option: -p Preserves modification times, access times, and modes from the original file. So set your permissions locally and then do the scp. Or, you can use tar: tar -zc file.* | ssh guy@... 'tar -zx -C ~/public_html/kool-stuff; chmod 755 ~/public_html/kool-stuff/file.*' In either case, I doubt execute permissions are ...



Top 50 recent answers are included