Tag Info

New answers tagged

1

All you need to do to do this is (as the error message says) unset the $TMUX variable: (unset TMUX; urxvt -e tmux) The subshell is necessary to avoid it being unset in your current environment, too. If you don't care about that, you don't need the subshell.


0

I am shamelessly posting the answer given by u/jbaumy93 on reddit. Here is what I am using now, In ~/.Xresources I am not setting URxvt.meta8: true as the encoding is breaking when I set it. If I use set termencoding=latin, it is messing up with powerline characters. I decided to use the Esc mappings as @graywh has posted and using the answer linked above ...


2

If you need to enter non-ASCII text, try changing your mappings in vim from <A-x> to <Esc>x. If you enter only ASCII text, you may try launching urxvt with --meta8 option, and in vim set termencoding=latin1. You may also try other solutions from: http://vim.wikia.com/wiki/Get_Alt_key_to_work_in_terminal


3

When you make an <A-x> mapping in Vim when x is a printable character (i.e., not a cursor or arrow key), it tells Vim to expect that character with the 8th/high bit set (aka, add 128 to the ASCII value). In your example, <A-h> means Vim will trigger the mapping when you type รจ. The ASCII value of h is 104 (binary 01101000) and when you set the ...



Top 50 recent answers are included