Tag Info

New answers tagged

0

You are just using ln the wrong way around: ln is ln <source> <target>. So you could do: ORIGINAL="$(which firefox)" sudo mv "$ORIGINAL" "${ORIGINAL}.orig" sudo ln -s "$HOME/Desktop/firefox/firefox" "$ORIGINAL" This will backup the current firefox binary from your path and create a symlink to your manually installed version.


3

Easiest way apt-get install firefox this will update to new one or which firefox this will give you path of firefox then replace the same sudo ln -fs $HOME/Desktop/firefox/firefox /usr/bin/firefox For Ex. which firefox /usr/bin/firefox sudo ln -fs $HOME/Desktop/firefox/firefox /usr/bin/firefox


3

There are two ways to fix this: You can alter your $PATH variable so that the directory where the new firefox version lives is checked before any other directory, by running the command export PATH=$HOME/Desktop/firefox:$PATH And if you add that same command to your .bashrc, all your future sessions will have the new PATH too. You can use ln to symlink the ...


1

Why you downloaded the version, you apparently did not install it in one of the directories in the PATH variable. When you execute simply 'firefox' it will find firefox in the first directory using the PATH directory. If you execute firefox with a more fully qualified name it will use whatever is found in that SPECIFIC directory only. The easiest thing to ...


0

May be the filesystem mounted at /srv or / is read-only. You should look at the output of /proc/mounts. Example output: rootfs / rootfs rw 0 0 /dev/root / ext3 rw,noatime,errors=continue,barrier=1,data=ordered 0 0 devtmpfs /dev devtmpfs rw,size=247996k,nr_inodes=61999,mode=755 0 0 none /proc proc rw,nosuid,nodev,noexec,relatime 0 0 none /sys sysfs ...


0

Need to look at the contents of /etc/yum.repos.d/ and also the output of the following command to be able to debug: $ rpm -q --verify -f /etc/yum.repos.d/* I had once got into a similar problem and the quick solution was to disable the offending repo by changing the enabled variable to 0 in the correct yum config file. But your error is not related to any ...


1

To remove rpm packages you can use rpm's -e flag. Firstly find the name of the rpm you have installed; rpm -qa | egrep -i "webmin|virtualmin" Then remove the package from the name that you see from above; rpm -e $packagename


1

Yes, it is possible. Take a look at this useful wiki page from Fedora which explains that the pre and post build "scriplets" take an argument that is passed in to them when they are run as part of the RPM installation. You can add a check to detect whether its an upgrade or a fresh install to your scriplet. The link provided contains an example of how to ...


2

localinstall libxml2-2.9.1-99.1.src.rpm This is a source code rpm, it contains sources, not binary, you should use rpmbuild before trying to install it. About that, i'm confused, you give 2 differents rpm names ? yum localinstall libxml2-2.9.1-99.1.src.rpm and rpm -Uvh libxml2-2.9.1-2.1.rpm Is it because you already used rpmbuild ? If it's the case, ...


0

I've made a tutorial to compile Couchbase version 3.0.1 for those who gets the same problem http://kokizzu.blogspot.com/2014/11/how-to-install-couchbase-on-archlinux.html


2

It is pretty easy to build it from sources if you need it on your development machine: https://github.com/couchbase/manifest#building-with-repo repo init -u git://github.com/couchbase/manifest.git -m rel-3.0.1.xml repo sync make it will install server for you to $PWD/install



Top 50 recent answers are included