Tag Info

New answers tagged

0

OK, it looks like we have now access to the raid. At least the first checked files looked good. So here is what we have done: The raid recovery article on the kernel.org wiki suggests two possible solutions for our problem: using --assemble --force (also mentioned by derobert) The article says: [...] If the event count differs by less than 50, then ...


0

Your only option here, since you turned your drives spare and lost their metadata, is to re-create the RAID. This is very dangerous, a mistake will wipe your data. When re-creating a RAID there are several things to consider. You must use --assume-clean so it won't sync. You should leave one drive out (preferably the one that is in the worst state) by ...


0

mdadm --force should fix this. Note that you may suffer minor data corruption, as its going to pretend its in sync. Use it like this: mdadm --stop /dev/md127 (you need to stop what's currently running first) mdadm -v --assemble --run --force /dev/md127 /dev/sd[a-hl-z]. The key thing is leaving out /dev/sdi here, as we know that disk is the least recent. ...


1

Yes it's possible - in a manner of speaking, just for RAID1. Change it to one drive. mdadm --grow /dev/md5 --raid-devices=1 --force It should then show up as being in a good state: md0 : active raid1 sdx1[42] 12345678 blocks super 1.2 [1/1] [U] With this there is no longer a missing drive and mdadm should no longer complain about it being ...


0

Not really. Peeking at the source code, if you use the --scan command line switch, mdadm parses /proc/mdstat without any kind of filtering in place. And if you don't use --scan, you have to supply a device name, which defeats your purpose.


0

One possible solution is to use LVM to manage redundancy, instead of using the mdadm Linux software RAID. Simply initialize all three disks as LVM physical volumes, assign them to the same volume group and use the correct flags when setting up logical volumes. -m, --mirrors Mirrors Creates a mirrored logical volume with Mirrors ...


0

A server poweroff / on resolved the problem..


0

Have solved the problem. By examining the disks I've found out that disks had individual windows disk signatures which allowed them to work properly in windows environment. However Linux had still seen them as RAID configuration. What I had to do is to switch back on the RAID controller and remove the drives from RAID configuration at BIOS level. Before I ...



Top 50 recent answers are included