Tag Info

New answers tagged

1

Try this on when launching qemu -redir tcp:2222::22 $ ssh -p 2222 localhost The tcp:2222::22 flag in the qemu launch command maps the 2222 port of the host machine to port 22 (the default ssh port) on the virtual machine. Then, simply sshing to the 2222 port on your localhost (the host machine) will redirect any traffic into the ssh 22 port in the ...


0

Since you haven't mentioned the 'cert key' used in tls encryption, I think you are using the 'plain spice' channel. And your are right , it is insecure, especially the 'input channel' can be risky if someone type 'password or credit card number' via spice console. To encrypt with tls-spice, you need Create a cert, deploy the private-key part on server, ...


1

I came to the same screen when installing Debian in a virtual machine, I eventually found that when I disconnected and reconnected after the initial boot screen, it would be the correct size. It seems the reason for the cropped screen was that TightVNC wasn't resizing when the vm was. So my bad solution is to close the client whenever there's a screen ...


1

(I dont know from when), qemu will create the tap first and then call your /etc/qemu-ifup script. So you see the error report, just because the same tap already exists. Reference: qemu source: net/tap-linux.c (check the function: tap_open()).


0

Are you using an abstraction layer such as libvirt? If so then simply add a disk image file as a USB Disk. If you're running kvm/qemu directly, then the man page (man kvm or man qemu) provides the answers: USB options: -usb Enable → the USB driver (will be the default soon) -usbdevice devname → Add the USB device devname. ...


1

An init script would be the way to go. Use of modprobe to ensure your kvm modules are loaded into the kernel may be unnecessary since they may already be loaded but if you run into problems you can always add it to your script.


2

It's a year-old subject, but someone may be still interested... I can confirm that qemu-kvm can be successfully wrapped with tsocks relay, using ssh SOCKS proxy. For DNS, ttdns is run on the host OS, so incoming UDP-DNS request from guest OS/qemu-kvm is converted to TCP-DNS request, and then relayed over tsocks+ssh. Actual command-line used: # env -i ...


1

Yes, the spice client just shows what a monitor would show. The machine continues to run in the background, even if you are not connected via spice. It also doesn't matter which spice client you are using. Of course the qemu process must keep running If you kill that one, it's like "pressing the button".


0

On my machine I could solve the problem by setting user-ID bit on execution on the "qemu-bridge-helper": sudo chmod u+s /usr/lib/qemu-bridge-helper ls -la /usr/lib/qemu-bridge-helper -rwsr-xr-x 1 root root 14336 Dez 16 15:36 /usr/lib/qemu-bridge-helper



Top 50 recent answers are included