Tag Info

New answers tagged

0

Click on the System menu at the upper left corner of the PuTTY window. Select Change Settings > Window > Colours. In the box that says "Select a colour to adjust", choose ANSI Blue and click the Modify Button. Slide the black arrow on the right up until you see a lighter shade of blue that you like. Click OK. Perform the same steps for ANSI Blue Bold so you ...


1

VirtualBox will create a private network (10.0.2.x) which will be connected to your host network using NAT. (Unless configured otherwise.) This means that you cannot directly access any host of the private network from then host network. To do so, you need some port forwarding. In the network preferences of your VM you can for example configure that ...


0

First you need to decide if you VM connected to your host machine via a bridge connection or via a NAT, but ether way you'll need to put the VM IP address in putty to be able to connect to ip, in the VM terminal run this command to show you the machine IP address (and no 127.0.0.1 is not the machine IP address) VM # ip addr show 1: lo: ...


0

When I do it from sftp with the ! prefix, it says it's worked It has! But ! executes the command on the client, not on the server. So watch out for what you may inadvertently have changed on the client. The SFTP protocol deliberately doesn't allow the client to specify commands to run on the server. It's only a file transfer protocol. You may however ...


1

Removed ForceCommand internal-sftp from /etc/ssh/sshd_config and rebooted the server (to refresh the configuration file) and I'm back in.


1

As michas has explained, those are terminal escape sequences. How they are interpreted is up to the terminal. You can do as michas has suggested and call ls like \ls, which will call the ls executable in $PATH, instead of the common shell alias ls --color=auto. To remove that shell alias you could do: unalias ls You can also add the option... ls ${opts} ...


4

Those are escape sequences to set colors: ←[00;34 tries to turn on blue color ←[00m tries to reset the color It is up to your terminal to interpret those sequences and do the coloring. The real putty brings it's own terminal, which is able to interpret these. If you use plink, you are using your windows terminal, which is not able to do so and simply ...


0

The user pi does not have LC_ALL set in its startup files. The user XX does, and every shell subordinate to su XX will inherit the value of LC_ALL. Find the line export LC_ALL=en_GB.UTF-8 in the .profile/.login/.bashrc/etc. of user XX and add that to the same place in user pi. You might also want to look for something like /etc/default/locale which ...



Top 50 recent answers are included