Tag Info

New answers tagged

0

I once had such problem on freshly installed distro (it was CentOS or Debian).the culprit was avahi deamon (mDNS) (don't know what it was trying to resolve on every ping and why). Stop this daemon if its running and try to ping again


6

Outgoing ICMP (ping) is probably blocked by your firewall or gateway. That you are able to browse the Internet does not need ICMP (ping) to be working. You also might have a proxy configured which allows you to only surf the web.


1

Simplified: your host sends ARP requests for "who has host2.lan"; when it doesn't receive any response, it sends an "echo-request for host2.lan" to its gateway (presumably host1.lan); the gateway answers with a host-unreachable; when host2.lan wakes up it replies to the ARP requests, and gets registered in the ARP tables on all machines in your LAN; your ...


1

I doubt ping is printing the wrong IP address—I'm pretty sure it'll print what's actually in the packet. I'd suggest tcpdump/wireshark to investigate further. Things that come to mind: Firewall NAT rules. On both the machine you're pinging from, the machine you're pinging, and (especially if its a hop between you and to host2!) host1. DNS confusion. Your ...


0

One possible cause is the firewall rejecting ICMP traffic. To test the hypothesis turn off the firewall in yast and try again.


1

Without double quotes around $PINGFULL, it's turning multiple lines into a single line, so you're getting the first line. Also, the rtt stats are on the last line, so get rid of the head -n 5. for myHost in $HOSTS; do PINGFULL=$(ping -c 5 "$myHost") PINGLOSS=$(echo "$PINGFULL" | grep loss | cut -d ',' -f 3 | grep -Eo '[0-9]{1,4}') PINGVAL=$(echo ...


0

I was able to solve the problem myself - it appears that by bug or by feature the pipe starts working correctly as soon as some parameters of the pipe are configured. In my case, I issued the following command: ipfw pipe 1 config delay 0ms.



Top 50 recent answers are included