Tag Info

New answers tagged

0

My guess would be (although I've never done this before, I've always had the nfs mount up first) is that the running user didn't have access until it was reloaded - either it didn't know about it or something along those lines. Never tried this before though so I'm not really sure


0

If this is an application that you wrote/can modify, I would recommend using register_shutdown_function at the time you create the temporary file. That way you can unlink even if your script is interrupted.


0

Your happy hacky solution is something along these lines (as root): export NOW=$(date); watch -n1 date --set=\"$NOW\" But it's probably not a grand idea :)


0

There'a a very neat tool called warp that makes it possible to adjust how the time for a given process is to be adjusted in arbitrary ways - e.g. shifted and even scaled! - while the global system time is unaffected. The time adjustment formula is time = time + warp + (time - base) * (factor - 1). Details are described on the warp manpage. The method it uses ...


4

This should do the work: #!/bin/bash ezstream -c $1 >log.txt 2>error.txt & ezpid=$! echo $ezpid sleep 2 if ps | grep $ezpid ; then echo ezsteam is still running! cat log.txt exit 0 else echo ezstream is dead cat error.txt exit 1 fi


3

I don't think you can pause system time. Lots of programs wouldn't like it anyway, because they generally expect time to go forward. If you paused the time, then any program going into sleep would never wake up. I don't understand exactly what you're trying to do, but I suspect that faketime would do what you're after. It lets you run programs with a fake ...


0

This oneliner gathers the mailq output (I often pipe that to a file and then run the script against the file so I can tweak it with less performance impact). Then it cuts out only the mail ID first by using the cut command to identify the proper field and then using egrep to clean that up (removing empty lines, irrelevant IDs ending in * and lines starting ...


1

If your find command has the -maxdepth option (Linux (GNU or BusyBox), FreeBSD, NetBSD, OSX): find /var/www -maxdepth 3 -name wp-cron.php -exec php -q "{}" \; If you want to run wp-cron.php files at an exact depth, you can use wildcards: for x in /var/www/*/*/wp-cron.php; do php -q wp-cron.php done You can run locate wp-cron.php to quickly list ...


0

Uninstall PHP5.3.3 and than install imagemagic. Read what yum is printing on screen (if it is not trying to install PHP5.3.3 again). P.S. I just read what have you really done. You have compiled PHP5.6 and it is out of package manager support. Why did you need PHP5.6? You can have PHP5.4 on CentOS without compiling anything.


0

maybe password is being encrypted with some additional salt, I think you should change it through some configuration file, not sure though


1

The default directory for html seems to be /var/www/html and not /var/www. As per the comments on the page you link to.



Top 50 recent answers are included