Hot answers tagged

6

A solution can be made with a simple script: Open file $ vim yaourt-helper.sh Create script #!/bin/bash _update="yaourt -Syua --noconfirm" if ! which $1 2>/dev/null 1>&2; then echo 'Package not installed, installing' $_update $1 exit $?; fi echo 'Already installed, checking for upgrade' $_update Set permissions and execute $ chmod +...


4

gdebi is the appropriate tool for this: sudo gdebi foo_1.0.0.deb will install foo from the given package file, and any necessary dependencies.


4

Package managers need to run as root because what they do affects all users. IMO package managers should require sudo only when writing files to a dir owned by root. like /bin or /etc. They also require root access to manage the database of installed packages. A package manager that installs software under a user's home directory doesn't need to run ...


3

Generally speaking, new versions of libraries which introduce backwards incompatibilities should change their soname, and this will then result in a new package name for the runtime library (e.g. for GTK+, libgtk2.0-0 and libgtk2.1-0 or whatever is appropriate). It's usually considered a serious bug to introduce a breaking version upgrade without following ...


3

The easiest is probably just to install them as Stephen suggests in the other answer, but you can also just mark them as manually installed with aptitude unmarkauto <packages>....


3

Use Ubuntu elisp ppa to install latest Emacs snapshot available. After installing you need to run emacs-snapshot instead of emacs. $ sudo apt-add-repository ppa:ubuntu-elisp/ppa $ sudo apt-get update $ sudo apt-get install emacs-snapshot This will install emacs without any further steps. Good luck.


3

If you go to the package AUR page and View Changes, you can see that in the most recent commit one of the version numbers was increased, but that file's corresponding md5sum didn't change. # Module Versions _about_arch_url="fusion809/about" -_about_arch_ver=1.5.17 +_about_arch_ver=1.5.18 _dark_bint_syntax_ver=0.8.6 _fusion_ui_ver=0.10.5 ...


2

nixpkgs reorganized things since the accepted answer was posted and there is a new function for disabling tests. You now wrap any Haskell package with the nixpkgs.pkgs.haskell.lib.dontCheck function to disable tests. Here is an example Nix expression from one of my Haskell projects where I had to disable tests for the shared-memory dependency when building ...


2

Edit sources.list sudo nano /etc/apt/sources.list Comment out a line that starts with this: deb cdrom


2

According to the npm config help, it will only derive its proxy settings from the environment If the HTTPS_PROXY or https_proxy or HTTP_PROXY or http_proxy environment variables are set (from the https_proxy section, the proxy section only mentions HTTP_PROXY and http_proxy). The help also doesn't list all_proxy as a configuration key anywhere, just ...


2

Debian policy is that libraries, tools, etc bundled with a program should be unbundled from it when creating a debian package. Debian policy also requires that libs be split into at least a runtime package (e.g. libfoo-version) and a development version with the static library and headers (e.g. libfoo-version-dev). What you do on your own system is your ...


2

So my question is, if the upstream developers created their software with the intention to distribute a large monolithic install complete with bundled dependencies, do the APT package maintainers need to rewrite the source so that the software uses the communal collection of dependencies rather than the local dependencies? Not necessarily, as long ...


1

You need to (at least) remove apache2.2-bin: apt-get remove apache2.2-bin Alternatively, you can force the installation of apache2-bin: dpkg -i --force-overwrite /var/cache/apt/archives/apache2-bin_2.4.20-2_amd64.deb and then try apt-get -f install again.


1

You should be able to do sudo apt-get install .... and the packages you want to keep. This will tell the system the packages were "manually" installed and so remove them from the autoremove scope eg we can see my system wants to auto-remove a number of packages: # apt-get upgrade Reading package lists... Done Building dependency tree Reading state ...


1

CLTM might be required if your corporate proxy uses NTLM from Microsoft. After you have cntlm proxy server configured for upstream proxy (which is your corporate proxy), just configure npm to use it: npm config set proxy http://127.0.0.1:3128 npm config set https-proxy http://127.0.0.1:3128 You must have both http and https. Most package managers work ...


1

While make(1) and many buildsystems, such as autotools, do support incremental compilation, Gentoo with stock Portage does not take advantage of it. After a package is compiled and installed, the working directory is discarded. The actual difficulty with using incremental compilation would be getting packages to build reliably in this fashion. It is much ...


1

Portage compiles full sources of the new package as delivered by upstream (sometimes gentoo team patches the source themselves, but that is another story). The binaries of the old package are usually removed, although some old libraries may stay if deleting them would harm other packages. To remove old sources you need to run eclean -d distfiles yourself.


1

dpkg is not lying, you do not have enough space to install unity-editor-5.3.5f1+20160525_amd64.deb. Your root filesystem only has 404.25 MB of space available, and you are trying to install a package that is 1.2 GB. Filesystem 1K-blocks Used Available Use% Mounted on /cow 4062904 3439240 413952 90% / 413952 KB available. 413952 KB =...


1

I found this answer to a duplicate question on ServerFault titled: yum equivalent of “apt-get purge" that provides the only method I've seen that can do what apt-get purge <pkg> does on Ubuntu/Debian. for package in package1 package2 package3 do echo "removing config files for $package" for file in $(rpm -q --configfiles $package) do echo " ...



Only top voted, non community-wiki answers of a minimum length are eligible