New answers tagged

1

Yes, doing it as the root user would allow you to change the permissions on (and owner of) these files and directories. $ cd /backup/dir/somewhere $ sudo chown myname:mygroup myfile $ sudo chmod u+rw myfile ... where myname and mygroup is your username and default group (check you other files in your home directory or use id -n -u (for username) and id -n ...


0

You need to become root (using su or sudo) as only the owner of a file can change its permissions.


1

You didn't specify the OS of the server, nor the server code. If it's the standard Linux client then you specify "insecure" as part of the export eg /directory server(rw,no_root_squash,async,insecure)


15

In the image you show that the "other" group has read permissions; if you tried to append echo testline >> useradd or execute ./useradd it would give you a permission denied. If you're looking to remove read permissions for the 'other' users you can use sudo chmod o-r useradd


7

I believe it is because the permission on the useradd file is set to rw-r--r--, thus giving read access to all users.


1

If you need to unpack initramfs and repack it later you can use -s/-i options to store fakeroot environment in a file. $ mkdir initrd $ cd initrd $ zcat ../initrd.gz | fakeroot -s ../initrd.fakeroot cpio -i Now you have file with fakeroot environment containing something like that: … dev=fe05,ino=20326044,mode=120777,uid=0,gid=0,nlink=1,rdev=0 dev=...


0

Upon further review, I believe the script was launching correctly, but there was a problem encountered during the apt-get, related to the libc6 package. I am using a Debian rolling release OS and just found out about Unattended Upgrades. I'll be looking more into how to properly use this feature.


0

If you want to run apt-get as a normal user, you will need to add a line to your /etc/sudoers file to allow you to execute specific commands with no password. First, change your script to: #!/bin/bash sudo apt-get clean && sudo apt-get update && sudo apt-get upgrade -y Second, add the following line to your /etc/sudoers file: ...


1

The USERCTL parameter does not mean what you think it means. From: https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/3/html/Reference_Guide/s1-networkscripts-interfaces.html (same meaning in later versions): USERCTL=<answer>, where <answer> is one of the following: yes — Non-root users are allowed to control this ...



Top 50 recent answers are included