Tag Info

Hot answers tagged

9

The dhclient that NetworkManager calls should be the same irregardless. On my Fedora 19 system I'm getting the following command run via NetworkManager when I allow it to connect: /sbin/dhclient -d -sf /usr/libexec/nm-dhcp-client.action \ -pf /var/run/dhclient-wlp3s0.pid \ -lf ...


8

Under Linux, you can use the iw* series of commands to configure and display information about wireless networks: iwconfig - configure a wireless network interface iwlist - Get more detailed wireless information from a wireless interface iwpriv - configure optionals (private) parameters of a wireless network interface iw - show / manipulate wireless ...


7

Mostly to make configuration "just work" smoothly when one has a diversity of connection methods (many different Wi-Fi networks, Ethernet, 3G, Bluetooth etc...). Configuring some of those by hand can be a hassle, specially when you only need them temporarily (e.g. on a laptop). Of course, one can fall back to the older config and do it by hand or use, ...


7

Upstream added a separate service for the dispatcher. Try running: systemctl enable NetworkManager-dispatcher.service then systemctl start NetworkManager-dispatcher.service Since dbus-org.freedesktop.nm-dispatcher.service is an alias, it should be working: systemctl status dbus-org.freedesktop.nm-dispatcher.service NetworkManager-dispatcher.service - ...


5

If you are using NetworkManager (which, I believe Xubuntu does), it should be in /etc/NetworkManager/nm-system-settings.conf. There is more information about it here: http://live.gnome.org/NetworkManager/SystemSettings.


4

Since version 0.8.1, Network Manager comes with a command line tool, nmcli. Its capabilities in older versions are very limited; for the most part, you can use it to view available connections and switch between them but not configure new ones. Since version 0.9.6, nmcli can create new connections. There are other, third-party command-line interfaces to ...


4

NetworkManager has the functionality to manage a local dnsmasq server built in. It is not necessary to use resolvconf/openresolv to do this. To enable this: Disable the resolvconf/openresolv dnsmasq configuration if it was previously enabled, and ensure there are no instances of dnsmasq running. Ensure dnsmasq is installed Add dns=dnsmasq to ...


4

This is a known issue and several bug reports have been submitted. There is also a workaround for ubuntu, but I don't think it will work for Arch users because they no longer use init scripts. I bet their fix can be ported but I don't know enough about systemd to do it. Here is a solution from the Fedora forums that looks like it works: Right-click on ...


4

One method for configuring multiple NIC cards is through the use of what's called bonding. It goes by other names as well: Bonding Channel Bonding Link Aggregation Using NetworkManager What version of NetworkManager are you using? Version 0.9.8 is the first that purports to offer support for network bonding. excerpt from phoronix.com Add a ...


3

Without knowing which method you used, this writeup (a little dated, for Etch) suggests what all it takes is to have the DHCP server listen on the right interface. (Sounds about right, doesn't it?) The Debian Wiki has an DHCP server entry, the Basic configuration mentioned there should be sufficient for your case.


3

I had similar problems with NetworkManager under AwesomeWM (sic!) (on a Ubuntu 11.10 system). After fixing other permission related stuff I noticed that NM applet also needs a ConsoleKit session. To check if this also your problem you can start the NM applet like this: $ ck-launch-session nm-applet (for testing purposes you can start it from an xterm)


3

If the modem is recognised, but fails to connect check these (rfkill control wireless devices blocking on your system): # get a list of devices and states rfkill list # unblock all wireless devices. With one integrated card this is not enough # for some reason and I have to leave it "on" on Windows 7 to # get it to work on linux rfkill unblock all To ...


3

It must be just the KDE front-end because the basic NetworkManager meets both of the requirements above for me and has for all versions over the last several years. Is it possible for you to either use the NetworkManager provided interface instead of the KDE wrapper or that you are using the wrapper wrong and have it mis-configured so that it doesn't work? ...


3

At a very basic level, nohup cnetworkmanager -C 'ESSID' --unprotected & but it might be worth thinking about writing it as a daemon, or a service of some kind if the tool doesn't already support it. You could also run it in the foreground, then background it, cnetworkmanager -C 'ESSID' --unprotected Then hit CTRL-Z which drops you to the command ...


3

I do not know if it's standard, but in Ubuntu there are script that are run before suspend / after resume in /etc/pm/sleep.d and in /usr/lib/pm-utils/sleep.d. In my system seems that the network is shut down by /usr/lib/pm-utils/sleep.d/60_wpa_supplicant. You can write a script for example /etc/pm/sleep.d/10-umount to unmount your shares before suspend. The ...


3

Method 1# Find NetworkManager configuration file and add/modify following entry in CentOS5 it is in /etc/NetworkManager/nm-system-settings.conf Or /etc/NetworkManager/system-connections/ and edit your DSL connection file : [ipv4] method=auto dns=8.8.8.8;4.2.2.2; ignore-auto-dns=true Note:- if [ipv4] not work then try with [ppp] Method 2# You can Change ...


3

You should be able to add a hidden network like so using NetworkManager. Step #1 - open NetworkManager's main menu                                   ...


2

Network Manager may ignore interfaces configured in /etc/network/interfaces, so check that your interface isn't already in there. If it is, remove it and reboot. Network Manager has a config file for which interfaces to manage at /etc/NetworkManager/nm-system-settings.conf It may have managed=false which you could need to change to true. The network ...


2

You will have to modify default pppd parameter (e.g place a persist parameter) , into NetworkManager 's source code , which is not guaranteed to work. However , with powerful script you could try with some shit like the following , given you have a workable pppd connection , called provider Keeping dialing until we have a default route configured: while ...


2

Problem solved with help of Arch wiki. /opt/dropbox/dropboxd was replaced with: #!/bin/sh # Copyright 2008 Evenflow, Inc., 2010 Dropbox # # Environment script for the dropbox executable. start_dropbox() { PAR=$(dirname $(readlink -f $0)) OLD_LD_LIBRARY_PATH=$LD_LIBRARY_PATH LD_LIBRARY_PATH=$PAR:$LD_LIBRARY_PATH TMP1=`ps ax|grep dropbox|grep -v grep` if ...


2

The sed command is broken (I guess people overlooked it somehow on the forum you refer to). It should be: sed '/-z/s:dnsmasq:dnsmasq -r /etc/dnsmasq/resolv.conf :g' dnsmasq>dnsmasq.local The fact that you used that broken sed command resulted in erasing /etc/rc.d/dnsmasq.local (or creating it as an empty file). I don't know the details of how ...


2

I have a Huawei mobile broadband device, it behaved the same in 10.04. Connect the device, let it settle. Then unmount it via the Desktop icon, but don't unplug it. then check if it appears in the list when you create a new broadband connection in network manager. If not, check if your device is listed in the usb_modeswitch known hardware list. ...


2

The way these "captive portal" WLANs work, two things are to be discerned: local network connection, which enables you to access the captive portal (web form) but nothing further connecting to the internet, unlocked using the captive portal where (1) works as always and (2) needs something to be done, i.e., entering a password in some web form. As you ...


2

If it worked with the last release and doesn't with the latest, I'd say it's a bug. You could file one here and if they consider it an upstream issue at GNOME's bug tracker. Beside filing a bug report, you could try dropping by the #gnome IRC channel, maybe prepared with your logs pasted somewhere. look for a little more Ubuntu-specific help


2

As you said, your network card is 00:19.0 Ethernet controller: intel corporation unknown device 1502 (rev 04) This makes me think that, being seen as an 'unknown device', it's not supported by CentOS 5.5. Can you try a more recent CentOS version (CentOS 5.7 or CentOS 6.2)? According to this, CentOS 5.7 should recognize the card. Try installing ...


2

As buddies said the simplest way is to power off wireless adapter using its hardware switch. But if your computer hasn't such a switch, go to system>preference>network connections; now go to the wireless section (second tab), select the wireless adapter that automatically connects to access point from list, click edit button,in this window, uncheck "Connect ...


2

While this is something that is usually done on the server as mentioned in the comments, there might be cases where you only want to use the VPN's DNS for queries inside of the VPN. In that case you'd probably want to run a lightweight DNS daemon on your system and instruct it where to send what query. If you are in several VPNs at once this is basically a ...


2

Dell has versions of their laptops with and without the chipset for 3G. The slot is available whether the chip is installed or not. Looks like you don't have the 3G hardware though. You can check by opening up the laptop. The wwan/3g chip usually has a place next to the bluetooth and wifi chip and is removable.


2

When you set up your phone as a network device you should get in your OS a device akin to phone0 which may or may not have an IP address on it. When this device come online you should make it default route for all traffic. sudo route del default sudo route add default gw phone0 Devices on your local network will still be accessible since route to that ...


2

The speed that is indicated there is based on the information the applet gets from the the status of your Ethernet hardware. It is the speed which with the network card talks to the next device (your router). I am not sure if your pcnet32 is indicating Unknown (maybe it is a virtual device?) From the commandline you can check with cat ...



Only top voted, non community-wiki answers of a minimum length are eligible