New answers tagged

2

In an answer to another question on mutt, the answerer says they have no problems sending to gmail with an entry like set smtp_url = "smtps://user@gmail.com@smtp.gmail.com:465/" So it seems mutt knows about this situation. Other people suggest url-encoding the @ as %40 but perhaps it depends on the mutt version.


0

Extending @Scott McClung correct answer. If you want to apply mutt commands by default to all selected (tagged) messages without using tag-prefix (bounded to ; by default), you can set auto_tag variable add to your .muttrc line: set auto_tag = true


2

As a workaround you can use display_filter setting Add to your .muttrc: set display_filter="sed -e '/^Tags:.*/d'"


0

I've had the following in my ~/.vimrc for years: autocmd BufNewFile,BufRead /tmp/mutt* set noautoindent filetype=mail wm=0 tw=78 nonumber digraph nolist autocmd BufNewFile,BufRead ~/tmp/mutt* set noautoindent filetype=mail wm=0 tw=78 nonumber digraph nolist They tell vim to set those options when editing matching files. It works well for me. The only ...


1

You can use a shell script to hold the options, and set your editor variable to that. For example #!/bin/sh vim -c "set fo+=aw" "$@" The Mutt FAQ suggests a similar approach in How to trim quoted replies (like stripping signatures)?, though this is not generally material for an FAQ.


0

In muttrc, use set crypt_opportunistic_encrypt = yes From $ man 5 muttrc crypt_opportunistic_encrypt Type: boolean Default: no Setting this variable will cause Mutt to automatically enable and disable encryption, based on whether all message recipient keys can be located by mutt. When this option is enabled, mutt ...


1

It looks like Dale Woolridge's confirm-crypt-hook patch has been merged into mutt. use crypt-hook rather than pgp-hook. crypt-hook foo@bar.com 0x123456789ABCDE01 set crypt_confirmhook=no for that recipient. e.g. send-hook ~t foo@bar.com 'set crypt_confirmhook=no' This should work with mutt or neomutt.



Top 50 recent answers are included