New answers tagged

0

df --output=source /var/www Gives you the device. In case of btrfs is does not give you the subvolume, though. But maybe the device is enough for you. If there is only one mount for the device then you can get it with this command: awk -v dev=/dev/mapper/backup '$1==dev { count++; path=$2; } END { if(count==1) print path; else exit 1; }' /proc/mounts


2

Type lsblk: > lsblk NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT sda 8:0 0 111,8G 0 disk ├─sda1 8:1 0 1020K 0 part ├─sda2 8:2 0 41G 0 part ├─sda3 8:3 0 11G 0 part ├─sda4 8:4 0 19G 0 part / ├─sda5 8:5 0 33,6G 0 part ├─sda6 8:6 0 2G 0 part ├─sda7 8:7 0 2G 0 part └─sda8 8:8 0 ...


0

try this command sudo apt-get install exfat-fuse exfat-utils


0

Try googling recover lost partitions. One product is http://findandmount.com/. It says it can find filesystems even if the master boot record has lost partitions. I also remember using a product on http://www.ultimatebootcd.com/ to do the same thing. I just can't remember which product.


0

Logging shows that there's something going on with the MTP device detection. Try uninstalling libmtp if you can get away with it, or just comment out the udev rule in the relevant file.


0

You must need add uid (user identifier) and guid (group user identifier) like these: $ sudo mount -t nfs 10.9.XXX.XXX:/root/src /home/patryk/nfs_share -o rw,user,vers=3,uid=1001,guid=1001 Maybe you need to use id command to find your id/guid: $ id username Although you may use actual user/groupnames (beware of spaces) instead numeric uid, gid values.


1

How about a symlink, which of course will only work when the mount is active on the particular machine: ln -s /mnt/asteriskstorage /var/spool/asterisk/monitor


0

There are several answers to this question. If you want to check, whether a specifc device is mounted or not (i.e. your backup device), then you should check it by its UUID, which you can find out by issuing blkid. UUID="place the UUID here" TRIES=0 DEVFILE="" while [[ -z $DEVFILE ]] && [[ $TRIES -lt 5 ]]; do DEVFILE=$(blkid -U $UUID) ...


0

You're pretty close. How about: ### START CHECK start_check_mtpt() { local volume="$1" local delay=5 local tries=$[ 60 / delay ] local mounted=0 while [[ 0 = $mounted ]] && [[ $tries -ge 0 ]]; do if cut -d' ' -f2 /etc/mtab | grep -qF "${volume}" ; then mounted=1 # optional: break else sleep $delay let tries=tries-1 ...


1

while ! mount | grep "on ${volume} type" > /dev/null; do sleep $delay if [ "$delay" -gt 60 ]; then exit fi delay=$((delay+5)) done using /proc/mounts You might consider using /proc/mounts instead of the output of mount (which is just /etc/mtab). while ! grep " ${volume} " /proc/mounts &>/dev/null; do


0

Disclaimer: I don't know if this is the right thing to do, but it worked for me. So, I essentially needed the startup process to take a little extra time so that networking services could finish loading and the iSCSI mounts could be created so there would be something to mount to. What I did was add sleep 5 to the /etc/rc.d/mountlate script. # PROVIDE: ...


0

Answer I ran across this thread on the FreeBSD Forums. While it was nearly identical to my issue in almost every way, the main differentiating point was it was in reference to ext4, not ext2. Since ext4 is technically backward compatible with ext2/3, I I decided to take the chance and see if I could try this solution - it worked. Here's what I did to ...


0

So it's a permissions problem. The FAT filesystem mounted by root cannot be accessed by normal users. It's a result of the fact that FAT doesn't include ownership information, so all files are considered owned by the user who mounted it.[1] The chown error message is because you're trying to copy files owned by you, to the FAT filesystem, using the -a ...


0

Two ideas: add space or remove files from the mount in the hopes of getting it under whatever threshold this wall process is using. Try to block the rpc traffic. Run rpcinfo | grep walld. Then run rpcinfo -d <the number from the first column> 1. This will remove walld from the list of listening rpc services on your host. Example: $ rpcinfo | ...


0

I was running into this same "mount error(2): No such file or directory" error using mount.cifs on a CentOS 7 VM. I never determined exactly why the error was being generated when using the default ntlm security (and the variants), but I did discover that using Kerberos authentication worked around the problem. So my final working command line looked like ...


0

I added "noauto,x-systemd.automount" to my mount options in fstab like suggested by "DavidCWGA" here: https://github.com/raspberrypi/linux/issues/824 Working for me now!


-1

Add to /etc/usbmount/usbmount.conf: FS_MOUNTOPTIONS="-fstype=vfat,uid=$UID,gid=floppy,dmask=0007,fmask=0117"


3

Mounting a disk over /home/user/mydata does NOT remove anything from the existing /home/user/mydata. It just 'covers up' the directory with the other disk. If you want to reclaim the disk space from /home/user/mydata, you need to manually delete/move those files to the new disk before mounting.


0

Please show the partitioning scheme. Use "gpart show". You'll probably see a partition of type freebsd-ufs. The third column (small number) shows which slice it is. You have the device name above. For example, if you see "ada0" and "2", connect those two into "ada0p2".


0

@siblynx, thank you for you reply. Mounting the media still fails. This is what I get with commands that you have proposed to me: # df -h Filesystem Size Used Available Use% Mounted on cramfs 3.4M 3.4M 0 100% /mnt/cramfs # # cat /proc/mounts rootfs / rootfs rw 0 0 cramfs ...


2

Don't use -o remount. That's only useful for remounting, that is, unmounting and mounting again in one operation which isn't supported in your case. Therefore, you need to unmount just like you did and then run: sudo mount -o rw /media/sda3


1

Could be late, but was digging in the same problem and found the topic. Hope this will be usefull for someone too. Working excellent in Ubuntu 14.04: sudo -i mdadm --assemble --scan You will get: mdadm: /dev/md/1 has been started with 1 drive (out of 2) Then mount and see your files: cd /mnt && mkdir to-restore-md1 && mount /dev/md1 ...


0

Typically this is done by adding the setting user to the /etc/fstab entry which defines the mount points. Further reading: mount(8) Normally, only the superuser can mount filesystems. However, when fstab contains the user option on a line, anybody can mount the corresponding filesystem. fstab(5) The fourth field (fs_mntops). This ...


0

A friend helped me with this. $ umount /media/user/... manually unmount filesystem $ lvs information about logical volumes $ vgs information about volume groups $ vgchange -a y X change attributes of a volume group $ lvs $ fsck.ext4 -y /dev/mapper/x-root "filesystem checker" check and optionally repair filesystems $ mount /dev/mapper/x-home /mnt ...


0

In a nutshell, what happens on Ubuntu is that udisksctl is called by udev rules , which then mount the devide to media as user into /media/$USER/diskname folder. For all practical purposes it sufficient that you manually do udisksctl mount -b /dev/sdb1 Remember to replace your device with actual name Since in your question you also asked for ...


2

The ext2fs file system is optional on FreeBSD and needs to be loaded. Add the following line to /boot/loader.conf to have it loaded at boot time: ext2fs_load="YES"


0

The normal way in Linux is to change the very last number of the fstab line from 0 to 2. From the man page for fstab(5): The sixth field (fs_passno). This field is used by the fsck(8) program to determine the order in which filesystem checks are done at reboot time. The root filesystem should be specified with a ...


0

To verify that you have your /etc/fstab set up correctly, the mount point exists, you're not relying on a disk manager to mount the drive for you, and you have ntfs-3g installed, can you try rebooting the server, then mount it with this command? sudo mount /mnt/ext/drive01


1

The exact meaning of "defaults" varies from filesystem to filesystem and from kernel version to kernel version. You can't depend on "defaults" not including "acl", but you also can't depend on it being included. If you want to be sure, you'll have to specify it explicitly.


1

The output of the mount command with no arguments is what the input of mount was when the filesystem was mounted (i.e., what its arguments were, what it detected the filesystem to be, and/or what was configured in /etc/fstab). The mount command expects at least three bits of information: the thing to mount, the place to mount it on, and the type of the ...


0

A could be the physical device, as you see it in 'fdisk -l' or could be a node/file in special cases.


2

The output of df /tmp gives the answer: the “Mounted on” column lists /, so /tmp is part of the filesystem that's mounted on /, i.e. the root filesystem. It is not a separate filesystem. To be more accurate, you should run df /tmp/: if /tmp is a symbolic link, then df /tmp lists information about the location of the symbolic link, whereas df /tmp/ lists ...


-1

To check this, mount is more appropriate. You can try it, and grep its output on 'tmp' Ex: $ mount | grep tmp tmpfs on /dev/shm type tmpfs ... Here it says that my partition /dev/shm is mounted with tmpfs (temporary file storage, i.e. in RAM). If your partition isn't mounted with tmpfs then it's not in volatile memory.


3

If the output is as above, it's on the hard disk. You can get /dev/root by looking at the kernel commandline: $ cat /proc/cmdline | grep root BOOT_IMAGE=/boot/vmlinuz-3.19.0-32-generic root=UUID=0cde5cf9-b15d-4369-b3b1-4405204fd9ff ro So /dev/root is equivalent to the partition with the UUID printed above; your's will differ. To look this UUID up, use $ ...


0

With a systemd enabled system you can use tmpfiles. See man 5 tmpfiles.d for details. Create a file /etc/tmpfiles.d/tmp.conf with this content: d /tmp 1777 root root - - systemd-tmpfiles-setup.service will take care of your permissions.


1

root (hd0,0) - Configures the root partition for GRUB, such as (hd0,0) first hard disk, first Partition and mounts the partition. kernel /vmlinuz-i686-up-4GB root=/dev/hda9 - Specifies the kernel location which is inside the /boot folder. This location is related to the root(hd0,0) statement.The root partition is specified according to the Linux ...


1

The mount command looks at /etc/fstab, but there is no requirement that an arbitrary command that mounts a filesystem has to look at /etc/fstab. And there are many such commands. From man mount If only the directory or the device is given, for example: mount /dir then mount looks for a mountpoint (and if not found then for a ...


2

Using lsof I discovered that two libraries were not installed on the machine, so I copied them: /usr/lib/libgphoto2/2.4.8/ptp2.so /usr/lib/libgphoto2_port/0.8.0/usb.so Then, gphotofs started to work correctly. Regards.


0

Did you try taking out x-systemd.automount?


0

# pkg info | grep mount automount-1.5.7 # pkg remove automount


-1

I would personally use mountpoint (very portable on Linux!): NAME mountpoint - see if a directory is a mountpoint SYNOPSIS mountpoint [-d|-q] directory or showmount which is pretty much required to be installed on any system that actually mount NFS shares (part of nfs-common package): NAME showmount - show mount information for an ...


1

It's possible the encrypted filesystem is toast. Hopefully not. Depending on what sorts of encryption options you chose, you may need slightly different commands. But you can try this to start. If it doesn't just work, looking at where it fails may help you debug your problem better. # cryptsetup luksOpen /dev/sdb5 foo # mount /dev/mapper/foo /mnt You ...



Top 50 recent answers are included