New answers tagged

1

Resource limits are generally controlled through ulimit (user-based) or sysctl (system-based). For example, the kernel.shmmax parameter, set by sysctl defines the maximum size in bytes of a single shared memory segment that a Linux process can allocate in its virtual address space. ulimit is used to set the limits of normal user processes. These values ...


1

From man bashbuiltins: ulimit [-HSTabcdefilmnpqrstuvx [limit]] Provides control over the resources available to the shell and to processes started by it, on systems that allow such control. Use ulimit -a to show current limits.


0

Ramp up sar and output the ps table every minute. See my detailed answer here. The next time the server blows up, use sar -r to help track down when it happened. Now use the output from ps-cronjob or from my perl wrapper for ps on github, to figure out which process may have been the culprit. Let's say the server blew up between 12:00:00 and 13:00:00. ...


1

I understand you're using Hyper-V, but the concepts are similar. Maybe this will set you on the right track. Your issue is likely due to virtual memory ballooning, a technique the hypervisor uses to optimize memory. See this link for a description I observed your exact same symptoms with my VMs in vSphere. A 4G machine with nothing running on it would ...


0

With fexsend you can send files of any number and size to any recipient on-the-fly, see: http://fex.rus.uni-stuttgart.de:8080/usecases/downunder.html Of course, you need a F*EX server, but it is free: http://fex.rus.uni-stuttgart.de:8080/


4

MemAvailable is included in /proc/meminfo since version 3.14 of the kernel; it was added by commit 34e431b0a. That's the determining factor in the output variations you show. The commit message indicates how to estimate available memory without MemAvailable: Currently, the amount of memory that is available for a new workload, without pushing the system ...


2

Your PHP interpreter is set to terminate any script which requires more than 132MB of memory. Your script is trying to allocate more than 161MB of memory. The problem is quite simple, and so are the solutions. You can either: Get your PHP interpreter to allocate more. The reason why your host is advising against that is that if he didn't, he'd end up ...


1

So the quick answer : depending on your linux distro, try either : top -M OR, after starting top, type capital E (then W to write the config). One of those should work for nearly everybody (except Solaris, of course, where you'd be lucky to have top at all). bonus tip : every time you start a top instance on a new install, type ExyzW to save colours and ...


0

I recommend you to run pgrep server_binary to know the PID of each instance and then top -p PIDs to know all virtual memory, resident memory and shared memory used by each bash instance. Example #know PID of each bash instance > pgrep bash 4301 4420 4426 4432 4438 4444 4450 4456 #list all resources used by each instance > top -p ...


0

Swap space in Linux is used when the amount of physical memory (RAM) is full. If the system needs more memory resources and the RAM is full, inactive pages in memory are moved to the swap space. While swap space can help machines with a small amount of RAM, it should not be considered a replacement for more RAM. Swap is a good thing and its virtual memory ...


3

Swap space is located on hard drives, which have a slower access time than RAM. Also the CPU cannot access/address hard drives directly because there is no direct physical data connection between the CPU and the HDD.


1

http://serverfault.com/questions/85470/meaning-of-the-buffers-cache-line-in-the-output-of-free Short answer: the kernel uses the buffers/cache memory for various tasks, such as caching files. This memory is available to applications if it is needed, so you are correct in saying you have 944 MB used.


0

The free -tm command also shows the swap usage by files backed via tmpfs. If you can empty your /tmp folder, the memory usage of smem -t -k should be simular to free -tm.


0

So it's solved. There were two things that I did. First i updated the system and then installed mate desktop. Now it works like a charm.


0

kcore is the virtual allocation of your RAM for the kernel. On 64 bit systems that size can be an absolute limit of 128T since that is the most the system can allocate.


1

In general, it probably won't have a bad effect. However, Linux by default allows overcommitting memory. That means that if a process asks for memory, Linux will say "sure". Then, if it actually runs out of memory (including swap space), Linux will start killing processes to free up memory. So, if your process allocates 117GB but does not use most of it, it ...


0

So one of the ways to fix this is to make use of a few additional environment variables. If we look in include/configs/ti_armv7_common.h we have: /* * We setup defaults based on constraints from the Linux kernel, which should * also be safe elsewhere. We have the default load at 32MB into DDR (for * the kernel), FDT above 128MB (the maximum location ...


0

Mac OS X lets you allocate "a lot", though the system may flail frantically or be just fine, depending on how that allocated memory is used by any subsequent code. I probably had to pkill the following code after it allocated "a lot" of integers (via the -M flag), though it's been a while since I tested on Mac OS X. /* # (Ab)uses memory via the allocation ...


2

The short answer is no: once an application has allocated memory, and used it, it "belongs" to that application, and unless that application releases it nothing else can reclaim it. (This isn't as simple as a call to free() though since that just returns memory to the individual application's pool, not to the system.) Swap is supposed to help with this: ...


1

Linux is quiet aggressive to swap out pages to disk. This doesn't mean that there is no copy of the page in RAM any more, but it can still be duplicated in the swap cache (a RAM section which caches pages written to the disk). The advantage of this is, that pages in RAM can be freed immediately in case some process needs memory. You can check the amount by ...


1

shouldn't the OS use less memory for fs cache instead of using swap? I guess the OS was short on RAM once in the past and swapped out some memory. The shortage is now over but the pages left in the swap are not in use so it is better for the OS to keep RAM for "hot" data including fs cache instead of these unused pages.


-1

Ubuntu 14.04 - this works just fine: htop --sort-key=PERCENT_MEM


0

I believe they run some kind of containers so you don't see the whole picture. Your ps aux is really limited. When there is nothing running, they probably stop the box/swap memory somewhere and report zeros, if you ssh in, they put the box online and load the whole system. 500 MB is too much for one ssh connection. It correlates to whole system.


2

Get a better provider than GoDaddy. BlueHost or Hostgator spring to mind, although I've never used either. Your ps aux output shows that your ssh session is currently using 1.8kib of memory 1.8 SSH 1.6 -bash 124 cpaneld 1.02 ps aux All sizes are in kib, so total is about 128mb. It's not unreasonable to think that a fully configured and running OS ...


0

Sounds like your issue was addressed in a related ServerFault question. I would check there, but it seems like you might need to upgrade your kernel to address a known bug. Also, I would recommend searching for similar questions before posting. :-)



Top 50 recent answers are included