Tag Info

New answers tagged

3

The \+ and \? parts of your sed command are GNU extensions - POSIX compatible sed cannot use these aspects of extended regex at all. Instead you can use \{1,\} and \{0,1\}. Try this: LOCATION='\033[01;34m\]`pwd | sed "s#\(/[^/]\{1,\}/[^/]\{1,\}/[^/]\{1,\}/\).*\(/[^/]\{1,\}/[^/]\{1,\}\)/\{0,1\}#\1_\2#g"`' For more information on this see - ...


1

Putting this in my .tmux.conf file was the trick: set -g history-limit 20000


3

For tmux you can alter its scrollback buffer with set-option history-limit 10000 The default is 2000. You can put this directive in your ~/.tmux.conf or at the tmux command prompt (prefix + :). It looks like iTerm is integrated with tmux. See: https://code.google.com/p/iterm2/wiki/TmuxIntegration



Top 50 recent answers are included