Hot answers tagged

14

You can do this with mutt's mime support. In addition, you can use this with Autoview to denote two commands for viewing an attachment, one to be viewed automatically, the other to be viewed interactively from the attachment menu. Essentially, you include two options in your mailcap file1. text/html; luakit '%s' &; test=test -n "$DISPLAY"; needsterminal; ...


8

You are better off using links for table rendering: links -width 80 -dump http://website.com/ > file.html


6

Press o to change the options. In the very first preference “User mode”, select “Advanced” (“Novice” has the huge help, “Intermediate” has a one-line help, and “Advanced” shows the selected URL in the modeline). Check the “Save options to disk” box then follow the “Accept” link at the top. The corresponding setting in ~/.lynxrc is user_mode=ADVANCED ...


6

You can escape a string on the command line by using single ticks, so lynx 'http://www.example.com/This(URL)is anExample.html' Will pass the URL unchanged to lynx, or any other program.


5

Lynx does the standard thing (unlike Firefox and Chrome) and uses the system's mailcap database. The system mailcap is in /etc/mailcap, and the per-user file is ~/.mailcap. Add entries like application/x-bittorrent; transmission-cli '%s'; needsterminal application/pdf; pdftotext '%s'; copiousoutput application/ogg; vlc '%s'; test=test -n "$DISPLAY"


5

I think you're having the same issue as posted here: http://serverfault.com/questions/296602/dns-wildcard-and-etc-resolv-conf-problem Appending a dot to your fqdn queries should work around the issue: curl http://jksodf89s9df9sudfisdf.com. Or, if you don't rely on the wildcard DNS entry, just replace it by specific DNS entries for your subdomains (that's ...


5

Lynx is actively maintained, but mostly for bug fixes. The last release of Links 2 was on 2011-08-10. The elinks fork still has an active developer mailing list with occasional bug fixes, but hasn't seen a release since 2009. W3m is actively maintained, though no major feature has been added in several years. The latest version is w3m 0.5.3 released on ...


3

You need to execute lynx once per file, to produce separate output files. To do something over multiple files in sequence, use a for loop. The pattern *.html matches all files in the current directory whose name ends with .html. for x in *.html; do … done In each run through the loop, the variable x designates the current file name. Use "$x" to refer to ...


2

Set Lynx to advanced mode. Options, user mode, advanced. General Preferences User mode : [Advanced___] Editor : ________ Type of Search : [Case insensitive]


2

It should be as simple as: ./configure --with-ssl Use: ./configure --help to get all configuration options. Of course, this requires OpenSSL to be built and installed. If you installed it in a non-standard directory, you might need to specify the path with --with-ssl=path, and/or add an include directory. CFLAGS=-I/path/to/openssl/headers ./configure ...


2

First make .desktop application for lynx: [Desktop Entry] Type=Application Name=Lynx Exec=gnome-terminal -e 'lynx %u' And save it to application directory e.g /usr/share/applications/ naming like lynx.desktop and give it execution permission (chmod+ x). Then set it as default web browser by using: xdg-settings set default-web-browser lynx.desktop Now ...


2

No. You can use lynx for this: lynx -dump URL UPDATE. Ops. Sorry. I did not see you know about lynx. I advice to use lynx for this purpose. It often produces very readable output. Sometimes you should use -width option to increase width of the output.


2

If you type o inside lynx you will open the option menu. Inside you will find the editor field, which specifies which external editor lynx will launch when requested. So the displayed value is the currently editor you are using (may be vim/emacs/nano). Then you have two options : learn how to use this editor set the editor value to one you already ...


2

You can specify an editor on the command line. -editor=EDITOR enable external editing, using the specified EDITOR. (vi, ed, emacs, etc.) You can start the external editor with CTRL-x-e Further information can be found here: http://lynx.invisible-island.net/lynx_help/keystrokes/edit_help.html


2

elinks If I understand your question then I believe elinks supports this feature. Using the UTF-8-demo.txt that @michas provided in his answer, here's a screenshot of elinks viewing that page. Example Invoking elinks like so: $ elinks http://www.cl.cam.ac.uk/~mgk25/ucs/examples/UTF-8-demo.txt Here's a screenshot of the terminal running elinks: ...


2

Lynx can be configured to modify this behavior using COLLAPSE_BR_TAGS in the configuration file, e.g., lynx.cfg: If COLLAPSE_BR_TAGS is set FALSE, Lynx will not collapse serial BR tags. If set TRUE, two or more concurrent BRs will be collapsed into a single line break. Note that the valid way to insert extra blank lines in HTML is via a PRE block with ...


1

The given answers are close: locale settings are the basis for each of the programs (lynx, w3m, elinks) to decide how to render things. There are a few points of disagreement though: The lynx behavior depends also on the locale_charset setting, e.g., in the lynx.cfg file: Description LOCALE_CHARSET overrides CHARACTER_SET if true, using the ...


1

After getting some hints here, it seems that the answer is that lynx, elinks, and w3m, all work if the locate is configured correctly. locale revealed that everything was set to "POSIX". export LC_ALL="en_US.UTF-8" fixed the problem. Added it to ~/.bashrc so that the change persists. Thanks folks!


1

To manually test the capabilities of your terminal you can use a file like UTF-8-demo.txt. Is your terminal able to display your boxes? If it is able, does your browser know that your terminal is able to do so? Otherwise the browser will take the safe option and emulate boxes using ASCII characters. What is the output of locale and echo $TERM? - Most ...


1

Turns out it was a simple mistake. When I used the flag -cmd_script="myscript.lynx", I had placed myscript.lynx in the same directory as the script (which happened to be /root/bin). I figured out that lynx was never running the script, the reason being that apparently cron runs from the home directory of the user. Because I was using root's crontab, it was ...



Only top voted, non community-wiki answers of a minimum length are eligible