Tag Info

Hot answers tagged

6

Edit ~/.config/openbox/lxde-rc.xml with your favorite text editor and then, within the existing <keyboard> element, add the following lines: <keybind key="Print"> <action name="Execute"> <command>scrot</command> </action> </keybind> Use the openbox --reconfigure command to use the new settings. ...


5

I doubt that LXDE vs GNOME will make a significant difference, but I don't have hard figures. I doubt less that the default configuration of LXDE and the default configuration of GNOME will make some difference. To keep power consumption down, turn off desktop effects (animations, anything 3D). Make sure you're not running any kind of “screen saver”. Most ...


4

Two things to check for: Port 6000 needs to be open on the 222 machine (configure or disable the firewall), and the X server itself needs to be listening on that port. This is often disabled in modern distros. Check if it's listening with # netstat -nltp | grep 6000 tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN 10818/Xorg ...


4

I don't have Lubuntu installed to test but maybe: To configuration file ~/.config/openbox/lubuntu-rc.xml adding the lines below : <!-- Option to maximize all normal window when launched--> <application type="normal"> <maximized>true</maximized> </application> Removal of this was suggested as a way to STOP it from doing so ...


4

First a couple of terms which will help you to understand this issue in particular and other things in general WRT a linux GUI: Window Manager (WM) Desktop Environment (DE) Someone should really write a simple, canonical explanation of these in a linux context...anyway, the base windowing system generally used on *nix systems (including linux) is the ...


3

That's an lxterminal bug. It doesn't show in other shells because zsh is nice enough to try and show you hidden characters showed by the previous command when you don't include a trailing newline before issuing a prompt. If you type echo -n foo, you'll see foo%. The % indicates that there was no newline character. Above, what happens is that lxterminal ...


3

In the file .config/lxpanel/LXDE/panels/panel you can find the following stanza: Plugin { type = menu Config { image=/usr/share/lxde/images/lxde-icon.png system { } separator { } item { command=run } separator { } item { image=gnome-logout ...


3

Short answer: aptitude install lxde xorg will do. Longer answer: The aptitude show command will show you a description of a package and its dependencies from the command line, so you can use that to decide whether to install the package or not. Keep in mind that aptitude and apt-get have automated dependency resolution, so package lxde will install ...


2

Apparently LXDE doesn't have a proper session manager. However as you've mentioned we can use the autostart file. All we need to do is create a dynamic list of the programs we are running before we exit the desktop. Here is a little bash script I whipped up that will parse the children of the root X11 window looking for apps to add to the autostart file. ...


2

Here's the answer http://ubuntuforums.org/showthread.php?t=1920761&highlight=double+click It's a separate setting for java programs (netbeans for example). For that create a file called .Xresources and/or .Xdefaults. Add to both of them this line *.multiClickTime: 750. 750ms is the double click speed. You're welcome.


2

See this post. You have to modify /etc/xdg/openbox/rc.xml and "smartly" remove all the tags matching a "ShowMenu" command. This will completely disable the OpenBox menus (all of them), but you can adapt it to your needs, as the file contents are pretty intuitive. You can also modify a copy of this file under ~/.config/openbox/rc.xml to make the changes only ...


2

Because your current theme doesn't support GTK-3, i.e a gtk-3.0 folder in the themes directory, all gtk3 based app will look ugly (the default builtin theme), So simply goto gnome-looks.org and find some awesome theme (in the gtk-3.0 category, which will support both gtk2 and gtk3), and put it to ~/.themes/ To change the theme, use lxappearance


2

On my computer (111): ssh -X 192.168.0.222 followed simply by: xclock will run xclock on the other computer (222) and display on my computer (111). Note: For this to work X11Forwarding should be enabled in /etc/ssh/sshd_config at computer (222)


2

I'm not the expert in X11 and even Linux, but I heard that OS X implementation of Xorg Server doesn't support some required extensions for visually rich UI. Or may be transparency (and other effects) in Linux can only be achieved with composition manager (such as xcompmgr, Compiz, etc.) on client side, so they can not transfer them over network based X11 ...


2

You should see the output from your program in ~/.xsession-errors. If you want to run the command in a terminal itself you have to install a terminal which allows you to specify the command to be executed (most of them should support it), i.e. for xterm you can run: xterm -e python /path/to/script and place it in your autostart file.


2

you could try the jupiter applet, its a power management applet for laptops and netbooks, very very handy to get longer battery life,i use it in ubuntu, but its also meant to be supported in Fedora 14, have a look here http://www.fewt.com/2011/01/jupiter-applet-gets-its-own-home.html


2

Though this is a bad idea yes it is possible. The fastest method would be to do a Ctl+Alt+F1 and login as root. If there is no root password then login as a regular user and do the sudo su. After that you can use top to find and kill the xserver. Lastly run startx which should put you at a graphical desktop. This is a very bad idea. If you need to run ...


2

As warl0ck noted, LXDE uses openbox as the WM, so you may just have a problem in your configuration settings. Hopefully these LXDE file locations should get you back on course: The config files of LXPanel are stored in ~/.config/lxpanel/. Under LXDE, we use a different profile name - LXDE. So it's in ~/.config/lxpanel/LXDE. In this way, if you changed the ...


2

Try gdevilspie, match lxterminal window, and auto-maximizing, Just an example on how it works (with gnome-terminal), first hit on 'Get' and select the LXterminal, And in actions, select 'maximize', save the rule. So any time you start LXterminal, it would start maximized. Last thing you need to make sure if daemon is running at start:


2

From the Openbox documentation: The Key is the name of the key, such as "a", "space", "Escape", "less", or "F1". You can find the name of any key by using the xev command in a terminal, pressing the desired key, and watching the output from xev in the terminal. To answer your question <keybind key="A-Prior"> for the Alt+PgUp binding and ...


2

I would try to answer you a more generic question: Is there a way to "tell" a process to use the swap space anyway? The Linux kernel provides via /proc/sys interface a property which defines how aggressively memory pages (anonymous only !) are swapped out to disk. The vm.swappiness property is applied globally per system but not per process. Set this ...


2

Just remove the NumLock key mapping by mapping it to nothing: first run xev and press Num Lock (it will probably print 77), and then run the command: xmodmap -e "keycode # = """ where # is the keycode of NumLock. You'd also put this to ~/.xprofile to disable NumLock in x sessions.


2

Find your numlock keycode with xev. For example, here, Num_Lock is 77. Use xmodmap to remap the keycode: For current X sessions, inside a shell, use xmodmap -e 'keycode 77 = '. To all future X sessions, inside ~/.xprofile place xmodmap -e 'keycode 77 = '. EDIT: Note: Doesn't work if a software is changing the Num Lock state.


2

On my laptop keyboard (Ubuntu 10.04) keyboard lock is currently On. $ xmodmap -pke|grep 77 keycode 77 = Num_Lock Pointer_EnableKeys Num_Lock Pointer_EnableKeys keycode 177 = XF86Phone NoSymbol XF86Phone $ xmodmap -e "keycode 77 =" Voila ! numlock is now disabled. xmodmap -e "keycode 77 = Num_Lock Pointer_EnableKeys Num_Lock Pointer_EnableKeys" Puts ...


1

Why are you doing this in .xsessionrc and not e.g. in .bash_profile or whatever other file your shell uses on login (don't confuse with .bashrc, which is sourced by each shell)? Here (Fedora) it even has a helpful comment User specific environment and startup programs...


1

mc needs to run inside a terminal emulator, which is itself an application. There are various terminal emulators (xterm, aterm, eterm); generally DEs (such as lxde) have one of their own -- in lxde's case, it's lxterminal. Check what happens if you type lxterminal & on the command line ;) With regard to your launcher, change the Exec line in ...


1

Maybe Shutter, it has a few GNOME dependencies however (some are optional). Shutter is a feature-rich screenshot program. You can take a screenshot of a specific area, window, your whole screen, or even of a website – apply different effects to it, draw on it to highlight points, and then upload to an image hosting site, all within one window. Shutter is ...


1

As always, there is probably a million ways to do this and the way I read your question your are going about your problem the wrong way, but first things first. After entering your username and password correctly all the scripts in /etc/X11/Xsession.d are sourced (not run, that's a very important difference!) in alphabetical order. So if you want some logic ...


1

It looks to me, on fedora 19 at least, that root login in LXDE is prevented by a pam configuration. The file /etc/pam.d/lxde contains the line auth required pam_succeed_if.so user != root quiet Which clearly indicates that the root user is silently refused to log in. Commenting out this line immediately causes lxdm to allow root to log in.



Only top voted, non community-wiki answers of a minimum length are eligible