Hot answers tagged

23

From the bottom up: Xorg, XFree86 and X11 are display servers. This creates the graphical environment. [gkx]dm (and others) are display managers. A login manager is a synonym. This is the first X program run by the system if the system (not the user) is starting X and allows you to log on to the local system, or network systems. A window manager controls ...


9

I think the most probable stopper here would be that your .xsession script lacks the execute permission (+x). In gdm, you also need to choose “Custom Session” (and not the standard “Xmonad” session) in the Session menu before logging in.


9

If you experiment with this, it'll be clear: In /etc/rc2.d, you'll find files that are instructions what your computer should do when it starts. If you use GNOME, look for a file with gdm in its name, then replace the S (first letter of the name) by a lowercase s. (GDM is as you might have guessed the GNOME display manager. If you use some other suite, of ...


6

I found that this is possible by editing the slim.conf file available in /etc. You would need admin credentials to open this file. SLiM themes are placed in /usr/share/slim/themes: In the slim.conf file, there is a section that mentions the theme: # current theme, use comma separated list to specify a set to # randomly choose from current_theme ...


6

Edit /etc/mdm/mdm.conf and set AutomaticLoginEnable=false


5

Create system user account - with UID less than 1000. Accounts with UID less than 1000 are hidden in gdm and probably others display managers. You can create system account by running useradd with -r flag.


4

Edit /etc/gdm/custom.conf and add or change the Exclude directive in the [greeter] section: [greeter] Exclude=nobody,alice,bob Users alice and bob won't be shown on the list at the login screen but can still log in by typing their name and password (if they have a password). See more details in How to hide users from the GDM login screen? (it's mostly ...


3

To me, disabling "Enable Automatic Login" in "Auto Login" tab from Login Window Preferences wasn't enough (login screen was showing up, but a moment later system was automatic logging me). I had to uncheck also "Enable Timed Login" from the same section.


3

Given that a reboot fixed the problem, what you missed is that you needed to tell the login manager (gdm) to reload its configuration. Most system services do not reload their configuration when you change it, in fact few applications automatically reload their configuration files if you edit the file directly (as opposed to going through that application's ...


2

The SLiM website has a page detailing how to create your own theme. You can find additional themes on a number of sites, including Gnome Look and in the Arch User Repository...


2

Yes, you can create a password-less account. sudo useradd -m guest sudo passwd -d guest Important, though, it to make sure no network daemons like sshd will allow access to password-less accounts. That's usually default, but it's good to check. Make sure PermitEmptyPasswords is no/false in /etc/ssh/sshd_config or just try and ssh into guest and see if ...


2

Open 'Menu' > 'Login Window' to open the Login Window Preferences. Select the 'Security' tab > uncheck the 'Enable Automatic Login' option.


2

You want to use pam_usb. Read more here: http://pamusb.org/


2

look for any relevant entries under /var/log/secure or /var/log/auth.log. Also, make sure that you don't have custom rules added under /etc/security/access.conf which might access to the server for that user. Those logs will contain information about failed logins and may indicate clearly what went wrong. The /etc/security/access.conf file specifies (user/...


2

I think I've made some progress on understanding this question, so I'll post what I know here. This answer is currently for those systems that use PAM. I'll add more on other methods of login as I encounter them. After you type in your username and password into the fields of your display manager, the display manager takes these two fields and starts the ...


2

Use small footprint Display Manager. SLIM With this display manager, some manual configuration is needed. Please refer to their official document and write your /etc/slim.conf and ~/.xinitrc. The command you should put in your ~/.xinitrc to start LXDE is: exec startlxde The above is coming from : http://wiki.lxde.org/en/Debian It supports autologin.


2

This command should list all of your Login managers installed: dpkg -l | grep -i 'Display Manager\|Login Manager' | awk '$2 !~ /^lib/' It will search for the keywords "Display Manager" and "Login Manager" and show only things that do not start with "lib" on the second column. Note: If you have more than one Display Manager configured, it will show both. ...


2

It's a mechanism that prevents you to set a password that is too weak. Your password strength should be at least "Fair" in order to unlock the Change button. Weak: Fair:


1

I generally use the automount service for shares like this that I'll periodically want to mount and use. Setting this up, once you understand how, is fairly trivial. Step #1 - setup automounting You'll need to make sure that packages are installed. On CentOS 6 that would be autofs. Most likely other distros will use a similar name. You'll then need to ...


1

There are different incarnations of init, including SysVinit, Upstart, and systemd. But I doubt if any of them incorporates a login manager, whatever that is. It may spawn other processes that offer logins: on terminals including the console and serial ports, so that users can log in on those terminals (getty) on a graphical display, for local logins with ...


1

The location of the X cookie file can be configured with the XAUTHORITY environment variable. The default is ~/.Xauthority. Of course, the location that you pass to applications has to match the location where the cookie is stored. SLiM doesn't offer a way to add the cookie to a different file: it has ~/.Xauthority hard-coded. If you want to use a different ...


1

Turns out it's because the screen "copies" the laptop screen - apparently both are enabled, even though one is closed under the lid. In my case, the fix was easy: edit /etc/lxdm/LoginReady and add a xrandr line you want: In my case: FILE: /etc/lxdm/LoginReady #!/bin/sh xrandr --output VGA1 --mode 1920x1080 --rate 60.00 --same-as LVDS1 --output LVDS1 --...


1

unsecure, but works # chmod u+s /sbin/shutdown $ shutdown -h now


1

You may want to tell SLiM to call sudo shutdown -h now and sudo to not ask password for that command ( your_user ALL=(ALL) ALL, NOPASSWD: /sbin/shutdown in your /etc/sudoers). You can also switch tty by typing CTRL + ALT + Fx (where x is the tty you want to switch to), login in and shutdown the computer.


1

Next to adding the user on the Linux machine, you'll have to generate a key (protocol type 2, preferably RSA) for that user as well. You can find instructions for that using Putty's key generator here. Select all of the text in the ‘Public key for pasting into authorized_keys file’ box in putty's key generator, paste it into a text editor and save it under ...


1

Trying many possible combinations of settings I solved it but the conclusion is that there is something amiss with Xfce's session manager settings or GUI. What I have verified is: As stated in the question, when this problem happens, under Settings/Login Window/Security - "Enable automatic login" is checked, like so: Enable timed login is not checked....


1

That was not enough. For some weird reason Mint added a user by default to the nopasswdlogin group and no mater how long you play with the settings above, that user will be challenge for password. Solution. Got to User manager and remove that user from the nowpasswdlogin group.


1

are you using gdm 3.x ? if yes, then the account properties are managed trough the dbus service org.freedesktop.Accounts. You can install d-feet, which is a python+gtk browser of the dbus, conect to system bus, search for the org.freedesktop.Accounts service, then the object path "/org/freedesktop/Accounts/UserXXXXX" (with XXXX your uid), interface "org....


1

In one sentence: Your display manager create a nice graphical display where you can use a login manager to login to your X session which will start a window manager and may start a desktop manager.


1

Actually if you could restart gdm using some mechanism then you would not have to reboot. This blog entry explains how to restart gdm.



Only top voted, non community-wiki answers of a minimum length are eligible