Tag Info

New answers tagged

1

Found it, was actually the /etc/default/locale It must have slipped me when editing it and I actually left no space between locale and the comment after it (#Comment here), hence it was getting the # from the comment... How silly... If anyone ever gets anything like this, just look in your /etc/default/locale


3

date is separate from your shell, so unless you instruct your shell to modify the environment date sees, your changes to LC_TIME won't have any effect. You can fix this in two ways; either by specifying a value for LC_TIME only for date: LC_TIME=zh_CN.UTF-8 date or by exporting LC_TIME so its new value is given to all subsequent processes started by the ...


2

ssh will forward "some" environnement var from mirind4-pc to raspberry, among them "locale" variable (which are use to print friendly date and number). According to misc link on Raspian and Ask Unbuntu you may need to generate local locale. From what I guess sudo locale-gen de_DE.UTF-8 sudo dpkg-reconfigure locales you can check immediatly afer using ...


0

Based on comment from Gilles I managed to fix this issue. The problem was missing pl_PL locale. I found instructions on PC LOAD LETTER blog: cd ~/sometemp wget http://sourceforge.net/projects/dsgpl/files/DSM%203.1%20Tool%20Chains/Marvell%2088F628x%20Linux%202.6.32/gcc421_glibc25_88f628x.tgz tar xvfz gcc421_glibc25_88f628x.tgz cd ...


-1

in putty… this is what I changed… setting --> window --> translation -->remote character set, I chose the first one in the drop down and saved the session (ISO-8859-1:1998 (Latin-1, West Europe) and it started displaying the UTF8 characters


1

With export LC_ALL=C I actually got rid of the warning. This is more of a workaround (as LC_ALL is also strongly discouraged), but my guess is the reason for this behaviour lies in assumptions nix makes about locales on the system which don't apply on openSUSE.


1

Comments in GNU libc sources (intl/l10nflist.c:_nl_normalize_codeset) state: There is no standard for the codeset names. Codeset names are normalized by that function to all-lowercase with all non-alphanumeric characters stripped i.e. "UTF-8" turns into "utf8". The locale names inside the locale archive are using normalized codeset names. Since ...


4

With Debian You can do: dpkg-reconfigure -plow locales With Ubuntu The Debian solution doesn't work with Ubuntu, probably because the locales package comes from the langpack-locales source instead of glibc or eglibc. But you can choose which language-pack-* package to install. For finer configuration, you might want to modify files under the ...



Top 50 recent answers are included