Hot answers tagged

28

LightDM is an x display manager that aims to be lightweight, fast, extensible and multi-desktop. It uses various front-ends to draw login interfaces, so-called Greeters. Key features are: A well-defined greeter API allowing multiple GUIs Support for all display manager use cases, with plugins where appropriate Low code complexity Fast performance  &...


6

The disable didn't work because the Debian /etc/X11/default-display-manager logic is winding up overriding it. In order to make text boot the default under systemd (regardless of which distro, really): systemctl set-default multi-user.target To change back to booting to the GUI, systemctl set-default graphical.target I confirmed those work on my ...


5

The problem was that I forgot the file /etc/X11/xorg.conf.d/20-keyboard.conf . I created it with the content: Section "InputClass" Identifier "keyboard" MatchIsKeyboard "yes" Option "XkbLayout" "de" Option "XkbVariant" "nodeadkeys" EndSection and now LightDM works.


5

For your first question, it typically depends on your session, i.e. the file in your example is not necessarily sufficient as it doesn't start your WM/DE. Normally ~/.xsession or ~/.xinitrc start the whole environment and are not only used to automatically launch some programs, i.e. they should contain a line like exec x-window-manager but the global ...


4

I Googled/emailed around a bit and got these two commands. To lock the screen: xflock4 To activate user switching: gdmflexiserver For Lightdm, this file resides in a strange spot (at least on Arch Linux): /usr/lib/lightdm/lightdm/gdmflexiserver I merged these two into XFCE's logout button dialog, in case anyone's interested, so the patch is ...


4

It depends on your configuration: you can have X-window Server started by itself and then the Display Manager process or Display Manager could start the X-window server. I have X server started by kdm in OpenSuse 12.1: kdm(4655)─┬─Xorg(4671) └─kdm(4698)───startkde(4800)─┬─gpg-agent(4877) ├─kwrapper4(4977) ...


3

To stop lightdm from automatically logging in user bob, edit /etc/lightdm/lightdm.conf and change the line autologin-user=bob to autologin-user= (the = will be the line's last character)


3

Redshift is tied to an X server. While you can start it as part of the system startup, that's fragile; the robust way to start it is within the context of the X server session (which is broader than the X login session). There can be multiple X servers running on the same machine at a given time. They are assigned display numbers on a first-come, first-...


3

This just seems to be a bug in the service script. The behaviour is different for --status-all than for a single process. For a single process, service just uses exec to hand over to the init script itself (in this case /etc/init.d/lightdm). Here is the relevant snippet: if [ -x "${SERVICEDIR}/${SERVICE}" ]; then exec env -i LANG="$LANG" PATH="$PATH" ...


3

I was able to solve problem by using the following commands: (sleep 0.5 && systemctl suspend) & It would be interesting to know, why exactly the sleep command is needed to get the desired behaviour.


2

You can always reconfigure lightdm and check settings or loads defaults, like this: sudo dpkg-reconfigure lightdm EDIT If you don't have trouble to start lightdm manually, maybe there is a problem with your PATH on boot. Check content of file /etc/X11/default-display-manager. If only entry is lightdm, change this to /usr/sbin/lightdm. sudo echo "/usr/...


2

[The ArchWiki looks dead currently, so I don't know what is contained in the instructions you linked to.] To change the looks of LightDM, you need to install a theme and configure it. This page suggests that the relevant Arch packages might be lightdm-unity-greeter or lightdm-webkit-greeter.


2

The display manager passes control to your desktop session by running a program. All you have to do to return control is have your desktop session terminate by calling exit. For example, on my Fedora system, the display manager runs /etc/X11/xinit/Xsession, which starts the desktop session manager. For shutdown? Terminate all the processes you started (...


2

If you want it to run after you login (which is how I read the title of your question), search for Startup Application in Unity and add your service there. If you are using the older desktop of Ubuntu Classic you should have something like that in the menu System Tools → Preferences → Startup Applications


2

Instead of having the notifications occur in pam_exec, you could have pam_exec write to a file (like you are, with /tmp/pam_output), and have a separate daemon executed by lightdm before the user logs in, which monitors /tmp/pam_output and pops up a note when it sees new output. The background process run by lightdm would have the X environment and X11 ...


2

Press Ctrl+Alt+F1 to switch to a different virtual console. You will have a text mode login prompt. Once you've done your repairs, you can switch back to the virtual console with the X window display by pressing Ctrl+Alt+F7. If you want to have several terminals, you get 6 virtual consoles with a login prompt by default: press Ctrl+Alt+F2, etc.


2

Usual warnings of root login is dangerous, do not use unless you are expert. Linux Mint Rebecca 17.1 uses nemo desktop as do others. root login text has been moved to: /usr/share/mdm/defaults.conf line 185. those who don't know how, this is what to do. Open Terminal and type sudo passwd root you will be prompted for a new root password. Next type, sudo ...


2

Linux Mint 16 uses the Mint-X theme by default which only displays the password box for chosen non-root users. In order to enable the User entry field (from which you will be able to specify root) do this. From Menu ==> Administration ==> Login Window ==> Theme choose Clouds and logout.


2

From the commands you are using, I take it that you use Systemd and LightDM. The correct command to stop the display server is sudo systemctl stop lightdm I think it's safe to run from a graphical terminal, not only from TTY. If you want to disable auto starting of LightDM altogether, replace stop with disable. Note that stopping the X server, even from ...


2

I finally solved my problem using this very helpful answer here. (It's the one with the green check mark. I recommend you also read the comments as I hit a snag and this led to the answer being amended.) Also, I filed a bug report about the system not booting without lightdm and it should be fixed by now.


2

You can use sed to do it automatically: sudo sed -i.backup -e 's/autologin-user=\(.*\)/autologin-user=/ /etc/lightdm/lightdm.conf This will change the first occurrence of autologin-user=someUser with autologin-user= (replace someUser with whatever user was set to auto login). It will also create a backup of the original file named lightdm.conf.backup. ...


2

I figured it out. I'm writing the lightDM configuration when configuring autologin anyway, and that's where I'm specifying the user, so the right thing is to specify the system default at the same time: wiki.ubuntu.com/LightDM#Changing_the_Default_Session However, when this bug is fixed: https://bugs.launchpad.net/lightdm/+bug/1371710 I'll need a better way ...


2

In Debian xterm is automatically started if no window manager is selected. Even if you have no slightest idea about who started xterm easiest way to find this out: as root rename /usr/bin/xterm to /usr/bin/xterm_. Create /usr/bin/xterm script: #!/bin/bash ( echo $$; ps -f --forest ) >/tmp/xterm.txt Than take a look into output.


2

IDK if there is a way to do it with a GUI, but you could place a icon.face file in your user directory. That may cause issues, however. An alternative is to use the AccountsService. Edit/create the file /var/lib/AccountsService/users/<username>, and add the following lines: [User] Icon=/somewhere/pathToIcon.icon Make sure the lightdm user has read ...


2

~/.xinitrc is only read when you start a GUI session with startx (or otherwise calling xinit) after logging in in text mode. So that won't help you. Whether ~/.bash_profile, ~/.profile, ~/.xprofile and ~/.xsessionrc are read when logging in with a display manager depends on how the display manager is configured and what session type you select when logging ...


1

I don't know much about Debian, but on my Ubuntu 14.04 laptop, here is the standard procedure I use when I want to disable X and boot to command prompt for troubleshooting: Edit the file /etc/default/grub in superuser mode and set GRUB_CMDLINE_LINUX_DEFAULT="text" Optionally, also uncomment this line: #GRUB_TERMINAL=console and then do sudo update-...


1

The answer for setting default configuration is here: https://wiki.ubuntu.com/LightDM#Changing_the_Default_Session


1

Since the Mate desktop-environment was introduced in Debian, this is now available in the mate-about-me application, which is part of mate-control-center as it was before in Gnome 2.


1

Update: (after comments) Try to modify in /etc/lightdm/lightdm.conf: greeter-hide-users=true in greeter-hide-users=false It's seems it's needed in all lightdm .conf files. It's possible you need to use lightdm-set-defaults [OPTION...] to fix it. The full options available are in the file: /usr/share/doc/lightdm/lightdm.conf.gz (if installed). ...


1

Boot into recovery mode, when the recovery menu is up, use the "Root Shell" option to gain a shell, then remove the command in the lightdm.conf.



Only top voted, non community-wiki answers of a minimum length are eligible