Tag Info

New answers tagged

1

The problem is here: libgmodule-2.0.so.0 => /usr/local/lib/libgmodule-2.0.so.0 (0x00007f1bba2a7000) libgio-2.0.so.0 => /usr/local/lib/libgio-2.0.so.0 (0x00007f1bb884f000) libgobject-2.0.so.0 => /usr/local/lib/libgobject-2.0.so.0 (0x00007f1bb7f81000) libglib-2.0.so.0 => /usr/local/lib/libglib-2.0.so.0 (0x00007f1bb7c64000) libgthread-2.0.so.0 ...


0

I have seen similar issue with one of my application and it was due to selinux in enforcing state. Change : /etc/selinux/config from SELINUX=enforcing ## or permissive to SELINUX=disabled This should fix it. http://sysadminupdates.com/blog/2015/05/11/so-cannot-open-shared-object-file-permission-denied/


0

When you compiled are you included the elf and out file format? And compat32? When you compile ensure all "standard" options of the standard kernel are included best way is cd /usr/src/linux(must point to your new sources) zcat /proc/config.gz > .config make clean make oldconfig #answer only if sure and use a lot the ? make,make install etc etc Of ...


0

In your script, these two lines close to the top should do the trick: LD_LIBRARY_PATH="$(pwd)/lib" export LD_LIBRARY_PATH Although bash allows you to set and export a variable in a single statement, not all shells do, so the two step approach is more portable, if that's a concern. If this isn't working for you, check that you are running the script from ...


0

you should execute you program in this way: LD_LIBRARY_PATH=$(pwd)/lib/ <your_executable_here>



Top 50 recent answers are included