Tag Info

New answers tagged

2

All GNU Screen's keys binding work exactly the same in byobu. To select a window, simply pressing Ctrl+a, then Window number Note that Ctrl+a is conflict with GNU Emacs keys binding, so byobu will ask you to chose the behavior. In any case, you can use Ctrl+a, then a to go to beginning of line in Emacs keys binding mode.


0

Thanks for your answers, guys! It looks like my problem was solved even as I was asking the question. JuiceSSH just released an update which fixes the enter key problem. https://juicessh.com/changelog The July 25 JuiceSSH update "Fixed enter key in Nano when using the latest version of Google Keyboard" seems to be the solution to my problem. I found the ...


0

I think you want: stty -icrnl ...though that seems a little strange to me. It's my understanding that apple systems default to a \return line-ending, but on all of my linux systems a default stty sane terminal will do exactly the opposite and translate input carriage returns newlines. Your Android device and my linux systems share a system kernel - which ...


0

If the phone literally emits c-j, then no, the only solution is to change the binding in tmux-navigator. And I think ssh is purely byte-based. (You can also send unix signals e.g. like ctrl+c / interrupt, but that's it). It's able to work because your phone tells the ssh server it's using c-j as newline when the session opens. RFC 4254 - The Secure Shell ...


0

@xenoterracide's solution is ok if the AutoAddDevice option is enabled in the ServerLayout of your xorg.conf. If not (especially in multiseat X configurations), you need to insert the XkbOptions line into the InputDevice section describing your keyboard. For example: Section "InputDevice" Identifier "keyboard-vmware" Driver "evdev" Option ...


0

I think it is not possible to set Meta/Ctrl solely as a prefix for tmux. As for Super key, you need to set up both your tmux and terminal emulator as Super is X key and tmux works on shell. This answer explains better. I recommend to set the prefix to something like Ctrl-a or Ctrl-s then simply bind , and . to move through windows. # remap prefix unbind ...


1

In your .tmux.conf file located in your user's home directory you can change or add keyboard shortcuts to your tmux sessions. If this file doesn't exist you can just create it. There are lots of sample .tmux.conf files around the web and several good gists out there. If all you want to do is make comma or dot cycle to previous or next window add the ...


1

I had the same question/problem. Alt-LeftArrow and Alt-RightArrow didn't do anything for me. They just printed ^[[C and ^[[D on the screen. Mine ended up being Ctrl-Alt-F3. It varied depending on number of ttys that were configured in /etc/ttys. I had 2 uncommented ttys, so it was Ctrl-Alt-F3. When I uncommented another tty, it became Ctrl-Alt-F4.


0

If those settings are not applied, than your desktop is broken. Is xfsettingsd running and reacting? Is xfwm4 running and reacting? Join me in IRC for live help


0

Thanks to @MikeCraffey: this now "just works". Pressing Super+E opens the Files window.


0

Ctrl+Z is actually a feature of the generic terminal interface in the kernel, not of bash. It causes a SIGTSTP signal to be sent to the foreground process. Likewise Ctrl+C sends SIGTERM and Ctrl+\ sends SIGQUIT. There are two ways in which a program can cause Ctrl+Z to lose its effect. The program can ignore the SIGTSTP signal. You can check the a ...


1

A solution for X11 is described in the post by @Jav. Remapping the keys in the Linux console: read the docs: man 5 keymaps dump the current mappings to a file with dumpkeys run showkey to find the keycodes for the keys you want to remap change the relevant entries in the file produced by dumpkeys install the new mappings with loadkeys. Steps 2., 3., and ...


1

I suggest you use xmodmap which works only with X. In a file (for example: ~/.Xmodmap), write something like this: keycode 0x63 = Up keycode 0x69 = Down You just have to execute xmodmap ~/.Xmodmap to enable your new configuration. Here you will find a list of all the keycode and to what key they correspond.


2

The command stty -a will show you all keyboard shortcuts in your current terminal. Generally in Unix-like systems, the only signals mapped are Ctrl+C (SIGINT), Ctrl+\ (SIGQUIT), and Ctrl+Z (SIGTSTP). There are no other bindings to other signals, and therefore no other signals that you can send within your current session with the keyboard. Generally ...


0

As long as your bluetooth or wwan module is on, just turning the wifi off won't set the airplane mode. So you have to turn them off as well and then the GUI of the Networkmanager will show you that the airplane mode is on.


0

my config is something like this (shortcuts that matter): <keybind key="W"> <action name="Execute"> <command>dmenu_run</command> </action> and the combination: <keybind key="W-Left"> <action name="UnmaximizeFull"/> <action name="MoveResizeTo"> <x>0</x> ...


1

I ended up using xcape, a utility designed to do exactly this: xcape allows you to use a modifier key as another key when pressed and released on its own. Note that it is slightly slower than pressing the original key, because the pressed event does not occur until the key is released. Quoted from the xcape readme Using xcape, you can assign the ...


0

Run xev and press your super key to get the appropriate key name. Mine is Super_L according to the output: KeyRelease event, serial 48, synthetic NO, window 0x3600001, root 0x91, subw 0x0, time 1648471775, (167,-8), root:(927,138), state 0x50, keycode 133 (keysym 0xffeb, Super_L), same_screen YES, XLookupString gives 0 bytes: XFilterEvent ...


2

You'll have to define a new option. First, make a new symbol file e.g. /usr​/share​/X11​/xkb​/symbols/bksp with the following content: partial alphanumeric_keys xkb_symbols "bksp_escape" { key <BKSP> { [ Escape ] }; }; Then create the new option like this: bksp:bksp_escape = +bksp(bksp_escape) (where bksp is the name of the symbol file ...


2

A simple solution is to suspend the running command, usually by typing control-Z. You should then be back in the shell. Give the fg command to return and bring the command back to the foreground again.


0

And improved version of @Leif answer could be: tmux bind-key '[' run "tmux copy-mode; tmux bind-key -n ']' run \"tmux send-keys Enter; tmux save-buffer - | xclip -i -selection clipboard; tmux unbind-key -n ']'\"; tmux bind-key -n q run \"tmux unbind -n ']'; tmux send-keys q\"; tmux bind-key -n C-c run \"tmux unbind -n ']'; tmux send-keys C-c\"" This way ...


12

Ctrl+M sends the same character(RET) as the Enter key in terminal. Programs have no way to tell them apart, so these keys cannot be configured separately. Ctrl+Q is already used for XON by default, so it cannot be used by Bash, but you should still be able to use it in tmux, because tmux uses raw input mode. A GUI program could read from the keyboard, that ...


2

There is a "Reset" toolbar command to the right of compile. That will stop the running program in Dr. Java.



Top 50 recent answers are included