Tag Info

Hot answers tagged

12

Use Ctrl+u: From bash documentation, Killing And Yanking: unix-line-discard (C-u) Kill backward from the cursor to the beginning of the current line. Ctrl+u behavior is not only controlled by the shells that have their own line editor like bash, zsh, tcsh, sh -o emacs, but also by the line discipline of the terminal driver when in canonical mode ...


4

The Vim term for text that can be selected, yanked, deleted, and modified based on certain groupings of characters is text object (see :help text-objects). There's a comment-aware text object plugin called textobj-comment.


4

Without a count, ^ and _ are indeed equivalent, but the latter supports a count: _ <underscore> [count] - 1 lines downward, on the first non-blank character |linewise|. The linewise explains your second observation: when used as a motion, it not just covers the text between the previous position and the new ...


3

Well, running program or function in bash on F12 key press in easy: ~/.bash_profile: sendsig(){ kill -KILL <somepid> } bind -x '"\e[24~":sendsig' But sending it to proper process is up to you… HTH, Cheers


3

I agree that would be seriously useful, but you can't currently do this. In the source code, the input-bar exec command mapping is here in config.c. However, the shortcut mappings (starting here) which seem to define what functions can be referred to from the configs don't mention exec. The code isn't structured to easily mix "command" functions and ...


2

First of all don't be worry about [ 602.262297] bcm2708_fb_blank blank_mode=1 and similar messages, they are all kernel messages, which are written to console because logging daemon is not ready yet for writing them to a file. Just ignore it or put loglevel=3 into kernel commandline options. Second thing is with passing passphrase do decrypt luks master ...


2

I don't think that is possible. The key problem here is, that the panel does neither become an active window when you hover over it with mouse nor does it grab the keyboard. Which means it is probably not receiving the keyboard events at all. See also related discussion where a workaround via xdotool is suggested. If you decided to go down that road, you ...


1

I do not know the exact answer to your question. But this may help. I am using Fedora and not Mint however I still believe this should work. There are different shortcut keys assigned for a particular type of command execution.You can find them in your System -> Preferences -> [System] ->Keyboard Shortcuts. You will also see various different ...



Only top voted, non community-wiki answers of a minimum length are eligible