Tag Info

New answers tagged

1

There's no easy method for determining which terminal program to use on Linux. Even though it's possible to get distribution info, use may or may not remove default GUI terminal program and install others. Generally the approach is to get a list of common terminal programs and find the first one usable. As an example, here is how virtualbox linux guest ...


0

It's better if you execute the commands using /Bin/Bash <terminal command> This would work for every linux distribution.


1

Run the software behind a reverse proxy. There are many to choose from. Probably the most popular is nginx, but many web servers have a way to configure them as a reverse proxy. There are also dedicated reverse proxy programs like Apache Traffic Server. Alternately, if you are running on Linux, you can do NAT port forwarding via iptables. This assumes you ...


1

I found the solution to my problem here. The workaround: I increased the memory used to 1024M with these instructions. I set the "Maximum files opened for read/write" to a 101. I ran the application from the command line with this command: sudo bash -c 'ulimit -n 8192; sudo -u username ./azureus'


2

You will need to modify the vuze shell script. This shell script is actually a link to a file called azureus, vuze's previous name. Within this script change the line JAVA_ARGS="-Xmx128m" to JAVA_ARGS="-Xmx256m", for example if you want to increase the memory to 256MB. Then restart vuze


0

It seems that you have oracle java installed in your machine. Using this command to check: $ dpkg -l | grep oracle-java Then you can see result like oracle-java*-installer, where * is version. You can remove it by this command: sudo apt-get --purge autoremove oracle-java*-installer Replace * with your version.


1

Setting class path The JDBC connector will be located in the path /usr/share/java/. We can export the classpath as, export CLASSPATH=/usr/share/java/mysql-connector-java.jar:$CLASSPATH Grant privileges to user For the user connecting to the database, the privileges should be granted. This can be achieved using the below mysql query. GRANT ALL ...


0

You need to R click on your script, go to Permissions and then mark the checkbox "Allow executing file as a program".


0

# rm /etc/bash.bashrc # apt-get -o Dpkg::Options::="--force-confmiss" install --reinstall bash I hit those two commands up Reinstallation of bash is not possible, it cannot be downloaded. I am on a ubuntu 14.04


5

Sherlock! Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. --Arthur Conan Doyle First you may want to check out this talk, which is a discussion about the sources of performance problems and how to diagnose them. It compares Linux to SmartOS, which is kind of separate from the point of your post, but it ...


1

Try: java -XX:+PrintFlagsFinal And looking for value you want. In my machine, output is: uintx MaxHeapSize := 1570766848 {product} uintx MaxNewSize = 18446744073709486080{product} uintx MaxPermHeapExpansion = 5439488 {product} ...


0

If you don't want to resort to OpenJDK, you can just use a different Ubuntu version in your /etc/apt/sources.list.d/webupd8team-java.list file: deb http://ppa.launchpad.net/webupd8team/java/ubuntu quantal main # deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu quantal main Instead of "quantal" you can probably use any of the values from the ...


0

I had the same problem. After upgrading to Mathematica 10, sound generation works on Linux.


2

The JDK sources are in $JAVA_HOME/src.zip.


0

This isn't a direct answer (I'm not an SUSE/zypper user), but it's a recommendation based on your description of your actual problem: "I want to install Oracle jdk. What I intended was to first uninstall open_jdk/ice tea stuff"). You don't need to uninstall ice tea, and this hassle w/ the package manager is the first indication that life will be easier if ...


5

The read system call reads some bytes from an open file. The “odd string” is the bytes that are read by the call. This call attempts to read 32 bytes (third parameter), and succeeds (return value), from file descriptor 34. To find out what file your application is reading for, look back in the trace for the system call that opens this file descriptor. This ...


0

I downloaded "1.7.0_60" from java.com in .tar.gz format and installed it into /usr/local/jre1.7.0_60. I then created a hard link to /usr/local/bin/java and received the error described above. Changing the hardlink to a symbolic link fixed the issue. Short version: $ sudo ln /usr/local/jre1.7.0_60/bin/java /usr/local/bin/java Is bad. $ sudo ln -s ...


2

This was only to be found in the Oracle version but now support is dropped. http://docs.oracle.com/javase/7/docs/technotes/guides/jdbc/bridge.html


1

I do not know of any Java APIs which expose KVM but the source for virt-manager is accessible here in the official Git repo. https://git.fedorahosted.org/git/virt-manager.git Additionally I'd look to the libvirt API for interacting with KVM or any other virtualization technology. Specifically there are Java bindings to the libvirt API.


1

Perhaps one of the methods in Interface OperatingSystemMXBean be adapted to what you are looking for. See http://docs.oracle.com/javase/7/docs/jre/api/management/extension/com/sun/management/OperatingSystemMXBean.html


0

This seems to be known Java related bug on Linux: https://netbeans.org/bugzilla/show_bug.cgi?id=227754 On above URL you can find workaround for NetBeans IDE, workaround which works for Java app I use is to NOT maximize Java app by pressing maximize button, but to resize window manually to size you prefer. Please share info if this help you, thanks!


1

To restore your /etc/bash.bashrc to its original state (if you can't remember what that is), you can do: sudo rm /etc/bash.bashrc sudo apt-get -o Dpkg::Options::="--force-confmiss" install --reinstall bash Otherwise @aprad046's answer seems like the best solution.


1

Try restoring bash.bashrc to its default setting, and edit your local copy of PATH in your ~/.bashrc file instead. In other words, put those last two lines: export PATH=$PATH:/usr/lib/jvm/jdk1.7.0_60/bin/ export JAVA_HOME=$JAVA_HOME:/usr/lib/jvm/jdk1.7.0_60/bin/java/ in your ~/.bashrc file instead of /etc/bash.bashrc. You might have to restart for changes ...


-1

Java is a non script language so you need to compile the code. I recommend compiling it into a jar bundle and then write a Shell Script to launch the jar. #!/bin/sh java -jar <compiled jar>.jar exit 0



Top 50 recent answers are included