Tag Info

New answers tagged

0

This could be effected by mistypes. If your TERM=xterm config is anything like mine, then practically every function key on your keyboard will send escape sequences like... infocmp -1 | grep -n \~ | tail -n3 138: kich1=\E[2~, 141: knp=\E[6~, 142: kpp=\E[5~, More than half of the output of infocmp -1 contains ~tilde escapes on my machine - and I'm ...


0

The $HOME/.ssh directory mode must be 700 and authorized_keys should be readable by the owner only, i.e. mode 600: chmod u=rwx,g=,o= /var/git/.ssh chmod u=rw,g=,o= /var/git/.ssh/authorized_keys As to the private key, it must be read-write-able by the owner only: chmod u=rw,g=,o= /var/git/.ssh/id_?sa


4

For reasons of paranoia, the .ssh directory and authorized_keys must not be group-writable. I guess the thinking is, the user must be the only one with explicit control over his/her authorization. I believe a work-around for this lies with ACL. The other work around is StrictModes=no setting in sshd's configuration file. But it would be too dangerous to do ...


1

The problem is the fact that files permissions are too open. Try setting the mode of authorized_keys to 600 and the .ssh directory to 700.



Top 50 recent answers are included