Hot answers tagged

14

As Julie said, you can use df to display free space, passing it either the mount point or the device name: df --human-readable /home df --human-readable /dev/sda1 You'll get something like this: Filesystem Size Used Avail Use% Mounted on /dev/sda1 833G 84G 749G 10% /home To run it continuously, use watch. Default update interval is 2 seconds, but ...


5

# strace hdparm -i /dev/sda … ioctl(3, HDIO_GET_IDENTITY, 0x7fffa930c320) = 0 brk(0) = 0x1c42000 brk(0x1c63000) = 0x1c63000 write(1, "\n", 1 ) = 1 write(1, " Model=… So hdparm gets its information from the HDIO_GET_IDENTITY ioctl, not from sysfs. That doesn't mean that the ...


4

Most filesystems have unique UUIDs and have labels which you can set to a distinctive values. These allow you to refer to the volume containing the filesystem through /dev/disk/by-uuid or /dev/disk/by-label. Other types of volumes (RAID, LVM, etc.) generally have a name as well. RAID and LVM volumes are assembled based on unique identifiers in the physical ...


3

When the partition is in clean state, there is no actual fsck run, which is why the date isn't updated. If you want to force it, the -f option does just that: sudo fsck -f /dev/sda1.


3

If you don't like the idea of dedicating a whole terminal to watching the output of df, you could consider a tool such as conky. There are countless examples of using conky to monitor everything from HDD usage, HDD temp, ram usage, local weather, news headlines... you name it.


2

df is a simple command line utility that shows you disk usage, including free space. Check man df for details.


1

It seems that kernel erroneously detected some device as floppy or just created a non existent reference because your machine does not have real floppy drive. So these blk_update_request for fd0 are completely unrelated to your hard drives. Many disk managing programs such as fdisk like to enumerate all available block devices, and definitely fdisk did hit ...


1

Finally found the answer from somebody else on another site, just zeroed the inodes and rechecked the system, that was all! debugfs -w /dev/sda2 :clri <1415> :clri <1416> :clri <1417> :q fsck -y /dev/sda2 To anybody else with this issue, I found my bad inodes using find on the bad mount, then checked dmesg for errors on the bad inodes.


1

Here is what worked for me, using Debian jessie (stable). I basically took the instructions from this wiki post, and stripped out all the steps about dual-booting with Windows, since those didn't apply to my case. In the BIOS, set "UEFI only" boot. Using Gparted, create a FAT32 partition at the beginning of the disk with the boot and esp flags. (The Debian ...



Only top voted, non community-wiki answers of a minimum length are eligible