Tag Info

Hot answers tagged

5

GVFS provides a layer just below the user applications you use like firefox. This layer is called a virtual filesystem and basically presents to firefox, thunderbird and pidgin a common layer that allows them to see local file resource and remote file resource as a single set of resources. Meaning your access to the resource whether on your local machine or ...


3

Nautilus uses GVFS to mount networked filesystems. Unlike its predecessor GnomeVFS, GVFS includes a FUSE bridge so that non GVFS-aware applications can still access GVFS data. That means that there are two ways to do this: using the FUSE bridge, or using the native GVFS tools. Using the FUSE bridge According to man gvfsd-fuse, the GVFS daemon will mount ...


3

You aren't doing anything wrong, and there's nothing to fix. /run/user/$uid/gvfs or ~$user/.gvfs is the mount point for the FUSE interface to GVFS. GVFS is a virtual filesystem implementation for Gnome, which allows Gnome applications to access resources such as FTP or Samba servers or the content of zip files like local directories. FUSE is a way to ...


3

It's a fuse issue. No user except the owner can read. To work around the default configuration, try enabling the user_allow_other option. This option is specified by adding it to /etc/fuse.conf. It has no value, just specify the option on a blank line.


3

Gvfsd(1) states: ENVIRONMENT GVFS_DISABLE_FUSE If this environment variable is set, gvfsd will not start the fuse filesystem. So if you configure your display manager or ~/.profile to set this variable it should work. On the other hand most unix utilities have switches to disable recursion into other filesystems (mostly -x, ...


2

Writing a .desktop file is not enough. You also need to change the default setting for the mime type. You can get the current default value with xdg-mime query default x-scheme-handler/ssh and can change it with xdg-mime default ssh-terminal.desktop x-scheme-handler/ssh The corresponding configuration file is ...


2

It's a virtual file system, not a real one, but is made to look real. I just ran into it myself it shows 170G being used on it. But if I check with du -hc it shows 0G. So in truth there is 170G being used, but on another networked hard drive in my house not on the system I was looking on and with. This was likely samba mounts that I copied files from or to ...


2

You might want to take a look at this tutorial titled: Scripting the Linux desktop, Part 2: Scripting Nautilus, which discusses how to add your own items to Nautilus' right click context menu as well as which variables Nautilus provides you when manipulating/dragging objects around inside of it. example Variables presented in Nautilus. Environment ...


1

I'm just like you, I like to mount/umount my filesystems from the command line. About the stdin option I'm not sure if it's reasonably safe. Is it worse than .netrc items? You should be aware that on many systems, process names and command line arguments are visible to all users. In Linux for example, do grep -a . /proc/*/cmdline to see them all. ...


1

You could use something like expect to provide the credentials each time you want to connect. It's not super secure but gives you what you want. #!/usr/local/bin/expect -- set timeout -1 spawn gvfs-mount {args} expect "User" send "joe\n" expect "Password:" send "xxxxx\n" expect eof Source: gvfs-mount specify username password


1

I'm not sure that you can do this quite the way you expect. What I do is I create a symlink to .gvfs called network in my home folder. cd ~ ln -s .gvfs network Then browse to network in Nautilus which will contain the network shares created in Nautilus. You should be able to open the file in emacs from there.


1

The location that SMB shares get mounted by gvfs can be very distro specific or GNOME specific (GNOME2 vs. GNOME3). The locations are often $HOME/.gvfs in older versions but in newer versions of gvfs the location has changed to /run/user/<userid>/gvfs. If you're ever questioning where this directory is on a given system then use the mount command to ...


1

Most likely it's related to this bug. /home/$USER/.gvfs is used as a mount point for the GVFS of $USER. Try to unmount it prior to delete it: umount /home/$USER/.gvfs rm –r /home/$USER/.gvfs


1

I might have experienced similar problem, but just with single file missing. I suspect, that linux samba mount helper is problematic. Could you run following tests on your client? cd [dir-with-missing-subdirs] ls -al | grep [missing name] -> nothing found (readdir is broken) ls -al [missing name] -> lists the element (stat working) -- use ...



Only top voted, non community-wiki answers of a minimum length are eligible