Tag Info

Hot answers tagged

20

Open the System Settings > Displays control applet. It's not evident - at all - but you can drag the miniature of the top black panel onto the display you want to mark as primary. Panels, activity overlay and everything will migrate on that display.


13

Replacing the main theme with the dark one in /usr/share/themes is not an ideal solution as each time gnome-themes is updated your theme will revert to default. It's preferable to properly configure your user account to use the dark theme, that way your settings will be preserved between updates. You can do that: Manually: create (open if already present) ...


9

You can restart the gnome-shell by pressing Alt+F2 and then typing in either "restart" or just "r" and pressing enter. Otherwise I've noticed that it automatically refreshes .desktop files after waiting a little while.


9

GNOME Shell is just one part of GNOME 3. It (together with Mutter, the window managet), is its primary user interface. The secondary interface (for hardware that can't handle the 3D workload, or for people who don't care about glitz), is Gnome Panel + Metacity (old window manager), which will basically give you the look of current GNOME 2. GNOME (3) itself ...


7

Fedora is an obvious choice. Frequent (6 month) releases, lots of community support, and on top of that its a pretty good operating system. Fedora 15 with Gnome 3 releases later this month, but you can download the beta now. Fedora Project


7

OK, I found how to do this at How to change gnome-shell calendar default application Just execute this in a terminal!! gsettings set org.gnome.desktop.default-applications.office.calendar exec thunderbird I have tested it and it works!! (it's not exaclty what I wanted but it's a start)


7

It depends on your Display Manager! (i.e. KDM, GDM) Please bear in mind your DM runs as root! (it needs root privileges in order to run your session process as the user you log in) When you click shutdown in KDE or GNOME, your DE sends a signal to your DM to power off or restart after the session has terminated. Then, your DE tells every program to end and ...


6

Normally you would Alt-F2 to run gnome-session-properties, and select "Automatically remember running applications when logging out" under the Options tab. However, it is broken at the moment. There is a bug filed: https://bugzilla.gnome.org/show_bug.cgi?id=647359


6

Gnome provides services (such as Gnome keyring, GConf, PolicyKit integration, etc.) that some programs use as well as additional features like theme application and application autostarting. If you use programs that make use of those services and you don't have Gnome, you may miss out on some functionality. Depending on what you use, it might be critical, or ...


6

http://www.gnome.org/getting-gnome/ Fedora Just install or try it live to use GNOME 3. openSUSE GNOME 3.2 is the default desktop environment of openSUSE 12.1. Mageia GNOME 3 will be part of Mageia 2. Install ‘task-gnome’ after installing Mageia. Arch Linux Arch Linux has GNOME 3 in the extra repository. Ubuntu ...


6

The other answers are better for most cases, but I'm adding this here for completion's sake: # shows all displays $ xrandr # set one of the displays to primary $ xrandr --output <display> --primary This method is better if you're docking or attaching your laptop to different / multiple monitors because it adjusts it on the fly. It's also a command ...


6

In GNOME and other freedesktop.org-compliant desktop environments, such as KDE and Unity, applications are added to the desktop's menus or desktop shell via desktop entries, defined in text files with the .desktop extension (referred to as desktop files). The desktop environments construct menus for a user from the combined information extracted from ...


5

From the Arch Wiki on Gnome (where Gnome 3 is now in the main repos): GNOME3 comes with two interfaces, gnome-shell (the new, standard layout) and fallback mode. gnome-session will automatically detect if your computer is capable of running gnome-shell and will start fallback mode if not. Fallback mode is very similar to the GNOME 2.x layout (while using ...


5

As far as I know, there is no GUI application allowing that for gnome 3. If you have Gnome 2, you can still use the settings application from menu. The easiest ways for me is to edit settings through gconf-editor: specify your command in /apps/metacity/keybinding_commands/command_X specify your keyboard shortcut in ...


5

It seems like the debian guys are working on this. http://www.0d.be/debian/debian-gnome-3.0-status.html And maybe you can have a look a Linux Mint (the one that is based on Debian that is). http://www.ainer.org/news/linux-mint-11-katya-with-gnome-3-announced


5

"A picture is worth a thousand words..." Picture shows Docky running in Gnome-Shell in 11.10


5

I doubt that LXDE vs GNOME will make a significant difference, but I don't have hard figures. I doubt less that the default configuration of LXDE and the default configuration of GNOME will make some difference. To keep power consumption down, turn off desktop effects (animations, anything 3D). Make sure you're not running any kind of “screen saver”. Most ...


5

I'm going to guess the following all of those tools use XdgUtils if you type xdg-open http://google.com it'll open with Chromium and that you have the problem described in this Ubuntu forumspost So my suggested answer is: $ xdg-mime default firefox.desktop x-scheme-handler/http (and ditto for https)


5

Are you clear on the difference between Gnome3 and the Gnome shell? If you don't like the Gnome shell GUI, and prefer the Gnome2 style with the panels and menu, you can try the Gnome3 classic desktop. It should be an option when you login. The main thing to know about this is that right-click by itself doesn't work on the panels. You will need to press ...


5

On my ThinkPad X220T running GNOME 3 it's pretty easy to be typing along and accidentally bump the touchpad, causing some window other than the one you're typing into to be raised. Ostensibly, the solution to this problem is to click your name in the upper right, then click "System Settings", then "Mouse and Touchpad", and then "Disable touchpad while ...


5

Found the answer elsewhere. The .desktop file needs to be named EXACTLY the same as the binary that's launching. Mine was something like eclipse_ide.desktop and the binary that runs is just "eclipse". Gnome shell does not seem to like that.


5

It's impossible that this page is supposed to be the tool for managing extensions - it makes absolutely zero sense Whether it makes sense or not is also a matter of opinion. But yes, that page is the main tool, read Owen Taylor's explanation. As to managing the extensions already installed on your system, you can enable/disable them via ...


5

This is actually a known and currently open bug. However, there is a very easy workaround; just issue the following command: gsettings set org.gnome.Vino require-encryption false You will now be able to connect with most vnc viewers.


4

I know this is late but...Fist, create a desktop file in ~/.local/share/applications/ for example sublime.desktop would be something like ~/.local/share/applications/sublime.desktop with the following content: [Desktop Entry] Keywords=Plaintext;Write;Programming;Syntax;Ruby;HTML Categories=; Comment=sublime Exec=sublime_text %U Hidden=false Icon=icon-name ...


4

The program powertop should help you identify the problem. $ sudo yum -y install powertop $ sudo powertop Look at the various output, and then arrow-key over to the rightmost "tab", Tunables. Look at the things which are "bad", and press enter to fix them. Also, on the first Overview screen, look for any egregiously bad processes that might be ...


4

System Settings > Keyboard > Shortcuts > Navigation > Hide all normal windows Click the second field which says Disabled and type in a key combination of choice (e.g., Ctrl+Alt+D). System restart may be required for changes to take effect.


4

Use xmodmap -pm to verify that both keys have the mod4 modifier associated with them. vikktakkht:686 Z$ xmodmap -pm xmodmap: up to 4 keys per modifier, (keycodes in parentheses): shift Shift_L (0x32), Shift_R (0x3e) lock Caps_Lock (0x42) control Control_L (0x25), Control_R (0x69) mod1 Alt_L (0x40), Alt_R (0x6c), Meta_L (0xcd) ...


4

From the OpenSUSE forums, I found that the new openSUSE 12.2 Gnome 3 GUI uses fancier features, which cause the GUI to crash over the network. To fix this, I have to insert an option into the AGENT_EXTRA_OPTIONS_X option in my /etc/nxserver/node.conf file. My original node.conf file actually had nothing in it (no un-commented lines), but I found a commented ...


4

For me this sounds most likely that your graphics card drivers are not installed correctly. Could this be a possibility ? Because then GNOME would start in "Fallback mode" which looks most likely like Gnome2. Check /var/log/gdm3/:0.log and /var/log/Xorg.0.log for errors, particularly stemming from the graphics card driver.


4

Answer in 2 words: The location of Xserver for GDM is hard-coded at compile time in configure.ac, line 1199 in X_SERVER variable and can't be configured. So, may be you could play with symlinks, linking /usr/bin/Xorg (or, less probably /usr/bin/X, see this) to your build of Xserver. Details: I have a Debian 7, too and here's my process tree: ...



Only top voted, non community-wiki answers of a minimum length are eligible